aboutsummaryrefslogtreecommitdiff
path: root/security/cops
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-09-03 08:03:36 +0000
committerCy Schubert <cy@FreeBSD.org>2011-09-03 08:03:36 +0000
commit84645c416e8e934e2ab2766e123c7963a3638500 (patch)
tree4ecd2c55fa88089b051988f5a30af560d57eefe4 /security/cops
parent2d9297a50f4fad6e0bc320dae1d260ad4b6942c4 (diff)
downloadports-84645c416e8e934e2ab2766e123c7963a3638500.tar.gz
ports-84645c416e8e934e2ab2766e123c7963a3638500.zip
Bring this old-school tool back from the dead.
Assume maintainership of this port.
Notes
Notes: svn path=/head/; revision=281067
Diffstat (limited to 'security/cops')
-rw-r--r--security/cops/Makefile46
-rw-r--r--security/cops/distinfo3
-rw-r--r--security/cops/files/patch-aa32
-rw-r--r--security/cops/files/patch-ab11
-rw-r--r--security/cops/pkg-descr9
-rw-r--r--security/cops/pkg-plist237
6 files changed, 338 insertions, 0 deletions
diff --git a/security/cops/Makefile b/security/cops/Makefile
new file mode 100644
index 000000000000..d975ba494ba4
--- /dev/null
+++ b/security/cops/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: cops
+# Date created: 29 August 1996
+# Whom: oly
+#
+# $FreeBSD$
+#
+
+PORTNAME= cops
+PORTVERSION= 1.04
+CATEGORIES= security
+MASTER_SITES= http://www.fish2.com/cops/ \
+ http://komquats.com/distfiles/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}+
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= A system secureness checker
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION:S/.//g}+
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= reconfig
+MAKEFILE= makefile
+MAKE_ARGS= EXECUTABLE="${EXECUTABLE}" C_SRC="${C_SRC}"
+
+EXECUTABLE= home.chk user.chk is_writable crc crc_check \
+ addto clearfiles filewriters members tilde is_able
+C_SRC= home.chk.c user.chk.c is_able.c is_something.c \
+ addto.c clearfiles.c filewriters.c members.c tilde.c \
+ crc.c crc_check.c
+
+pre-build:
+ ${SED} \
+ -e 's,^SECURE=/usr/foo/bar,SECURE=${PREFIX}/cops,g' \
+ -e '/^$$SECURE\/passwd\.chk.*/d' \
+ -e 's,SECURE_USERS="foo@bar\.edu",SECURE_USERS="root@localhost",g' \
+ -e 's/passwd\.chk pass.chk //g' \
+ ${WRKSRC}/cops > ${WRKSRC}/cops.out
+ ${MV} ${WRKSRC}/cops.out ${WRKSRC}/cops
+
+do-install:
+ ${MKDIR} ${PREFIX}/cops
+ ${TAR} -C ${WRKSRC} --exclude "*.old" -cf - . | \
+ ${TAR} -C ${PREFIX}/cops --unlink -xf -
+ ${CHOWN} -R ${BINOWN}:${BINGRP} ${PREFIX}/cops
+ ${CHMOD} -R go-rwx ${PREFIX}/cops
+
+.include <bsd.port.mk>
diff --git a/security/cops/distinfo b/security/cops/distinfo
new file mode 100644
index 000000000000..3175aa8a6622
--- /dev/null
+++ b/security/cops/distinfo
@@ -0,0 +1,3 @@
+MD5 (cops104+.tar.gz) = d994194c3ee14e4a71b1312e98643606
+SHA256 (cops104+.tar.gz) = 5c673c4868fda0e0c0ac7f7b7aab7f31a2dff8266382b1c24dca94eedfa712b5
+SIZE (cops104+.tar.gz) = 288663
diff --git a/security/cops/files/patch-aa b/security/cops/files/patch-aa
new file mode 100644
index 000000000000..53a8e007bd75
--- /dev/null
+++ b/security/cops/files/patch-aa
@@ -0,0 +1,32 @@
+--- perl/cops.orig Sat Feb 21 19:20:10 1998
++++ perl/cops Sat Feb 21 19:21:06 1998
+@@ -1,8 +1,4 @@
+-#!/bin/sh -- need to mention perl here to avoid recursion
+-'true' || eval 'exec perl -S $0 $argv:q';
+-eval '(exit $?0)' && eval 'exec perl -S $0 ${1+"$@"}'
+-& eval 'exec /usr/local/bin/perl -S $0 $argv:q'
+- if 0;
++#!/usr/bin/perl
+
+ #
+ # Usage: cops [-vx] [-c config file] [-s secure_dir] [architecture]
+@@ -83,7 +79,7 @@
+
+ # Read stuff to do from the config file
+ die "$0: Can't trust $CONFIG to reconfig!\n" if &'is_writable($CONFIG);
+-open CONFIG || die "can't open $CONFIG: $!";
++open (CONFIG) || die "can't open $CONFIG: $!";
+
+ &argh unless -s $CONFIG;
+
+@@ -219,8 +215,8 @@
+ }
+ return 1 if (($FILE2 eq "") || (-s $FILE1 != -s $report));
+
+- open FILE1 || die "can't open $FILE1: $!\n";
+- open FILE2 || die "can't open $FILE2: $!\n";
++ open (FILE1) || die "can't open $FILE1: $!\n";
++ open (FILE2) || die "can't open $FILE2: $!\n";
+
+ for (1..5) {
+ $_ = <FILE1>;
diff --git a/security/cops/files/patch-ab b/security/cops/files/patch-ab
new file mode 100644
index 000000000000..7e02909ab1e8
--- /dev/null
+++ b/security/cops/files/patch-ab
@@ -0,0 +1,11 @@
+--- makefile.orig Tue Mar 9 02:19:18 1993
++++ makefile Tue Jul 11 21:44:29 2000
+@@ -23,7 +23,7 @@
+ # C2 = -DC2
+
+ #
+-CFLAGS = -O $(C2)
++CFLAGS+ = $(C2)
+ # sequents need "-lseq" as well... uncomment this if you're running on one:
+ # SEQFLAGS = -lseq
+
diff --git a/security/cops/pkg-descr b/security/cops/pkg-descr
new file mode 100644
index 000000000000..6e78a75205b2
--- /dev/null
+++ b/security/cops/pkg-descr
@@ -0,0 +1,9 @@
+Cops is a set of programs to check how secure your system is. It
+checks file and directory privileges, SUID programs, etc. It has
+support for checking passwords, but this port doesn't include it
+as it is DES based. This port installs cops in a single directory
+area. The directory has no non-user privileges and cops is meant
+to be run locally to that directory. The perl version of cops is
+also included in a subdirectory.
+
+WWW: http://www.fish2.com/cops/
diff --git a/security/cops/pkg-plist b/security/cops/pkg-plist
new file mode 100644
index 000000000000..92eb7cdaa301
--- /dev/null
+++ b/security/cops/pkg-plist
@@ -0,0 +1,237 @@
+cops/MANIFEST
+cops/README.1
+cops/README.2.pl
+cops/README.2.sh
+cops/README.3
+cops/README.FIRST
+cops/XTRA_CREDIT
+cops/addto
+cops/bug.chk
+cops/bug.chk.aix
+cops/bug.chk.apollo
+cops/bug.chk.dec
+cops/bug.chk.next
+cops/bug.chk.sgi
+cops/bug.chk.sun
+cops/bug.chk.svr4
+cops/bug_cmp
+cops/carp/How2Change
+cops/carp/README
+cops/carp/carp
+cops/carp/carp.1
+cops/carp/carp.anlz
+cops/carp/carp.anlz.1
+cops/carp/carp.awk
+cops/carp/carp.table
+cops/carp/carp2ps
+cops/carp/carp2ps.1
+cops/checkacct/Article
+cops/checkacct/Intro
+cops/checkacct/Makefile
+cops/checkacct/README.FIRST
+cops/checkacct/bsd.m4
+cops/checkacct/ca.src
+cops/checkacct/chkacct.1l
+cops/checkacct/dotwrite
+cops/checkacct/effect.dotwrit
+cops/checkacct/effect.owners
+cops/checkacct/effect.read
+cops/checkacct/effect.rhosts
+cops/checkacct/effect.setuid
+cops/checkacct/effect.write
+cops/checkacct/owners
+cops/checkacct/prm.mm
+cops/checkacct/prompt.help
+cops/checkacct/readable
+cops/checkacct/rhosts
+cops/checkacct/rhosts.pl
+cops/checkacct/setuid
+cops/checkacct/sysV.m4
+cops/checkacct/write
+cops/chk_strings
+cops/clearfiles
+cops/cops
+cops/cops_filter
+cops/cover_letter
+cops/crc
+cops/crc.chk
+cops/crc_check
+cops/crc_list
+cops/cron.chk
+cops/dev.chk
+cops/disclaimer
+cops/docs/COPS.report
+cops/docs/COPS.report.ms
+cops/docs/COPS.tex
+cops/docs/CRC.README
+cops/docs/KUANG.README
+cops/docs/SUID.README
+cops/docs/bug.chk
+cops/docs/bug.chk.1
+cops/docs/cops
+cops/docs/cops.1
+cops/docs/cron.chk
+cops/docs/cron.chk.1
+cops/docs/dev.chk
+cops/docs/dev.chk.1
+cops/docs/ftp.chk
+cops/docs/group.chk
+cops/docs/group.chk.1
+cops/docs/home.chk
+cops/docs/home.chk.1
+cops/docs/is_able
+cops/docs/is_able.1
+cops/docs/is_able.chk
+cops/docs/is_able.chk.1
+cops/docs/is_writable
+cops/docs/is_writable.1
+cops/docs/kuang.1
+cops/docs/kuang.man
+cops/docs/kuang.man.ms
+cops/docs/makefile
+cops/docs/misc.chk
+cops/docs/misc.chk.1
+cops/docs/obligatory.album
+cops/docs/obligatory.joke
+cops/docs/pass.chk
+cops/docs/pass.chk.1
+cops/docs/pass_diff.chk
+cops/docs/pass_diff.chk.1
+cops/docs/passwd.chk
+cops/docs/passwd.chk.1
+cops/docs/rc.chk
+cops/docs/rc.chk.1
+cops/docs/readme.C2
+cops/docs/readme.apollo
+cops/docs/readme.cfilter
+cops/docs/readme.filters
+cops/docs/readme.ibm
+cops/docs/readme.sequent
+cops/docs/readme.shadow
+cops/docs/readme.svr4
+cops/docs/readme.xenix
+cops/docs/readme.yp
+cops/docs/release.notes
+cops/docs/root.chk
+cops/docs/root.chk.1
+cops/docs/suid.man
+cops/docs/suid.man.ms
+cops/docs/tilde
+cops/docs/user.chk
+cops/docs/user.chk.1
+cops/docs/warnings
+cops/extensions/THINGS_2_DO
+cops/extensions/YAR
+cops/extensions/crypto-stuff
+cops/extensions/netstuff
+cops/extensions/passwords
+cops/extensions/questions
+cops/extensions/uucp.hardening
+cops/extensions/writing.suid
+cops/extra_src/README
+cops/extra_src/bad_dir.pl
+cops/extra_src/diff_last.sh
+cops/extra_src/mail.chk
+cops/extra_src/pass.mail
+cops/extra_src/rhosts_sweeper
+cops/extra_src/stop.make
+cops/extra_src/trust.pl
+cops/extra_src/uucp_1.shar
+cops/extra_src/uucp_2.shar
+cops/extra_src/uucp_quick.chk
+cops/file.paths
+cops/filewriters
+cops/ftp.chk
+cops/gen_fix
+cops/group.chk
+cops/home.chk
+cops/init_kuang
+cops/is_able
+cops/is_able.chk
+cops/is_able.lst
+cops/is_writable
+cops/kuang
+cops/kuang.pl.shar
+cops/makefile
+cops/makefile.orig
+cops/members
+cops/misc.chk
+cops/pass.words
+cops/pass_diff.chk
+cops/passwd.chk
+cops/patchlevel.h
+cops/perl/README.kuang
+cops/perl/README.sgi
+cops/perl/chk_strings
+cops/perl/chk_strings.pl
+cops/perl/cops
+cops/perl/cops.cf
+cops/perl/cops.orig
+cops/perl/cron.chk
+cops/perl/dev.chk
+cops/perl/fgrep.pl
+cops/perl/file_mode.pl
+cops/perl/file_owner.pl
+cops/perl/ftp.chk
+cops/perl/get-cf
+cops/perl/getopts.pl
+cops/perl/glob.pl
+cops/perl/group.chk
+cops/perl/hostname.pl
+cops/perl/is_able.chk
+cops/perl/is_able.lst
+cops/perl/is_able.pl
+cops/perl/kuang
+cops/perl/kuang.1
+cops/perl/misc.chk
+cops/perl/pass.cache.pl
+cops/perl/pass.chk
+cops/perl/passwd.chk
+cops/perl/pathconf.pl
+cops/perl/pathconf.sh
+cops/perl/rc.chk
+cops/perl/reconfig.pl
+cops/perl/root.chk
+cops/perl/rules.pl
+cops/perl/shadow.sh
+cops/perl/stat.pl
+cops/perl/suckline.pl
+cops/perl/suid.chk
+cops/perl/suid.stop
+cops/perl/user.chk
+cops/perl/yagrip.pl
+cops/platform
+cops/quick_start
+cops/rc.chk
+cops/reconfig
+cops/res_diff
+cops/root.chk
+cops/src/addto.c
+cops/src/clearfiles.c
+cops/src/conf.h
+cops/src/crack-fcrypt.c
+cops/src/crack-lib.c
+cops/src/crack.h
+cops/src/crc.c
+cops/src/crc_check.c
+cops/src/filewriters.c
+cops/src/home.chk.c
+cops/src/is_able.c
+cops/src/is_something.c
+cops/src/members.c
+cops/src/pass.c
+cops/src/tilde.c
+cops/src/user.chk.c
+cops/suid.chk
+cops/suid.stop
+cops/tilde
+cops/user.chk
+cops/yp_pass.chk
+@dirrm cops/src
+@dirrm cops/perl
+@dirrm cops/extra_src
+@dirrm cops/extensions
+@dirrm cops/docs
+@dirrm cops/checkacct
+@dirrm cops/carp
+@dirrm cops