aboutsummaryrefslogtreecommitdiff
path: root/security/courier-authlib
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-04-30 09:14:47 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-04-30 09:14:47 +0000
commitcf05ce3135490370a2bb41047272e4b1e95ff237 (patch)
treec2043c71ef125d5406fb64363d5f540547eb9db8 /security/courier-authlib
parentbad83e19fdac4bbf92a739d5a32e07939f7e664d (diff)
downloadports-cf05ce3135490370a2bb41047272e4b1e95ff237.tar.gz
ports-cf05ce3135490370a2bb41047272e4b1e95ff237.zip
- Update courier-unicode to 1.2
- Update courier-imap to 4.16.1 - Update maildrop to 2.8.2 - Update sqwebmail to 5.8.2 - Update courier-authlib to 0.66.2 - Some plist and Makefile modernization Approved by: oliver@ (as maintainer of various of these ports) Differential Revision: https://reviews.freebsd.org/D2391
Notes
Notes: svn path=/head/; revision=385029
Diffstat (limited to 'security/courier-authlib')
-rw-r--r--security/courier-authlib/Makefile10
-rw-r--r--security/courier-authlib/distinfo4
-rw-r--r--security/courier-authlib/files/patch-Makefile.in78
-rw-r--r--security/courier-authlib/files/patch-configure27
-rw-r--r--security/courier-authlib/files/patch-liblock__locktest.c81
-rw-r--r--security/courier-authlib/files/patch-libs_liblock_locktest.c38
-rw-r--r--security/courier-authlib/pkg-descr2
-rw-r--r--security/courier-authlib/pkg-plist-base2
8 files changed, 98 insertions, 144 deletions
diff --git a/security/courier-authlib/Makefile b/security/courier-authlib/Makefile
index 3c5e3057d01a..c2c669a0e067 100644
--- a/security/courier-authlib/Makefile
+++ b/security/courier-authlib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= courier-authlib
-PORTVERSION= 0.66.1
+PORTVERSION= 0.66.2
PORTREVISION?= 0
CATEGORIES?= security mail
.if defined(PKGNAMESUFFIX)
@@ -31,7 +31,8 @@ OPTIONS_DEFINE+= GDBM
.else # !defined(PKGNAMESUFFIX)
-LIB_DEPENDS+= libltdl.so:${PORTSDIR}/devel/libltdl
+LIB_DEPENDS+= libltdl.so:${PORTSDIR}/devel/libltdl \
+ libcourier-unicode.so:${PORTSDIR}/devel/courier-unicode
USES= iconv gmake libtool perl5 tar:bzip2
GNU_CONFIGURE= yes
@@ -167,7 +168,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|$$VPOPMAILLIBS|& -lcrypt|g; \
- s|mysql_connect|mysql_real_connect|g' \
+ s|mysql_connect|mysql_real_connect|g; \
+ s|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/*/configure \
${WRKSRC}/configure
.for subdir in ${REMOVE_SUBDIRS}
@@ -186,10 +188,12 @@ pre-configure:
fi
post-install:
+.if !empty(DOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
+.endif
.endif # !defined(PKGNAMESUFFIX)
diff --git a/security/courier-authlib/distinfo b/security/courier-authlib/distinfo
index 189e0d3d0160..90d48555d15c 100644
--- a/security/courier-authlib/distinfo
+++ b/security/courier-authlib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (courier-authlib-0.66.1.tar.bz2) = 8f89166f57c8e59f445fe0135da92b95f1c4417896d01eda5e2e94d8ff878fe8
-SIZE (courier-authlib-0.66.1.tar.bz2) = 2299965
+SHA256 (courier-authlib-0.66.2.tar.bz2) = ed104562b6bc6a2c6212d73b647f5526da68cf262e0c1d2c1ee478182b8f87a9
+SIZE (courier-authlib-0.66.2.tar.bz2) = 2081381
diff --git a/security/courier-authlib/files/patch-Makefile.in b/security/courier-authlib/files/patch-Makefile.in
index 247de27c3a4b..6a9e6cabf8a8 100644
--- a/security/courier-authlib/files/patch-Makefile.in
+++ b/security/courier-authlib/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2013-11-11 19:58:27.000000000 +0100
-+++ Makefile.in 2013-12-30 11:45:33.000000000 +0100
-@@ -85,11 +85,10 @@
+--- Makefile.in.orig 2015-04-25 14:07:07 UTC
++++ Makefile.in
+@@ -85,11 +85,10 @@ PRE_UNINSTALL = :
POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
@@ -13,10 +13,10 @@
+@HAVE_BASE_TRUE@bin_PROGRAMS = courierauthconfig$(EXEEXT)
+@HAVE_BASE_TRUE@noinst_PROGRAMS = authdaemontest$(EXEEXT) authmksock$(EXEEXT) \
+@HAVE_BASE_TRUE@ authdaemondprog$(EXEEXT)
+ @HAVE_SGML_TRUE@am__append_1 = $(GITFILES)
subdir = .
- DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile.am \
- $(top_srcdir)/configure $(am__configure_deps) \
-@@ -218,6 +217,12 @@
+ DIST_COMMON = INSTALL NEWS README AUTHORS ChangeLog \
+@@ -220,6 +219,13 @@ libauthuserdb_la_LINK = $(LIBTOOL) $(AM_
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
$(AM_CFLAGS) $(CFLAGS) $(libauthuserdb_la_LDFLAGS) $(LDFLAGS) \
-o $@
@@ -26,10 +26,11 @@
+libauthvchkpw_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
+ $(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+ $(libauthvchkpw_la_LDFLAGS) $(LDFLAGS) -o $@
++
libcourierauth_la_DEPENDENCIES = libs/libhmac/libhmac.la \
libs/md5/libmd5.la libs/sha1/libsha1.la \
libs/numlib/libnumlib.la libs/random128/librandom128.la \
-@@ -334,6 +339,8 @@
+@@ -336,6 +342,8 @@ SOURCES = $(libauthcustom_la_SOURCES) $(
$(libauthpgsql_la_SOURCES) $(libauthpipe_la_SOURCES) \
$(libauthpwd_la_SOURCES) $(libauthshadow_la_SOURCES) \
$(libauthsqlite_la_SOURCES) $(libauthuserdb_la_SOURCES) \
@@ -38,7 +39,7 @@
$(libcourierauth_la_SOURCES) \
$(libcourierauthcommon_la_SOURCES) \
$(libcourierauthsasl_la_SOURCES) \
-@@ -501,6 +508,7 @@
+@@ -503,6 +511,7 @@ LIBAUTHPWD = @LIBAUTHPWD@
LIBAUTHSHADOW = @LIBAUTHSHADOW@
LIBAUTHSQLITE = @LIBAUTHSQLITE@
LIBAUTHUSERDB = @LIBAUTHUSERDB@
@@ -46,14 +47,14 @@
LIBDB = @LIBDB@
LIBDL = @LIBDL@
LIBGDBM = @LIBGDBM@
-@@ -623,21 +631,27 @@
+@@ -625,21 +634,27 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
userdb = @userdb@
AUTOMAKE_OPTIONS = dist-bzip2
--SUBDIRS = libs/gdbmobj libs/bdbobj libs/md5 libs/sha1 libs/libhmac libs/numlib libs/makedat userdb libs/unicode libs/rfc822 libs/random128 libs/liblock liblog
+-SUBDIRS = libs/gdbmobj libs/bdbobj libs/md5 libs/sha1 libs/libhmac libs/numlib libs/makedat userdb libs/rfc822 libs/random128 libs/liblock liblog
+SUBDIRS = libs/gdbmobj libs/bdbobj libs/md5 libs/sha1 libs/libhmac libs/numlib
+@HAVE_USERDB_TRUE@SUBDIRS+= libs/makedat userdb
-+SUBDIRS += libs/unicode libs/rfc822 libs/random128
++SUBDIRS += libs/rfc822 libs/random128
+@HAVE_BASE_TRUE@SUBDIRS+= libs/liblock liblog
AM_CPPFLAGS = -I liblock $(LTDLINCL)
modules = @LIBAUTHUSERDB@ \
@@ -79,7 +80,7 @@
libauthpgsql.la \
libauthldap.la \
libauthmysql.la \
-@@ -711,6 +725,13 @@
+@@ -713,6 +728,13 @@ libauthshadow_la_DEPENDENCIES = $(common
libauthshadow_la_LIBADD = $(commonlibadd) $(libauthshadow_t)
libauthshadow_la_LDFLAGS = $(commonldflags)
@@ -93,7 +94,7 @@
# The authpgsql module
libauthpgsql_t = @PGSQL_LIBS@ @LIBM@ @NETLIBS@
libauthpgsql_la_SOURCES = authpgsql.c preauthpgsql.c authpgsqllib.c authpgsql.h
-@@ -790,8 +811,8 @@
+@@ -792,8 +814,8 @@ libcourierauthsaslclient_la_SOURCES = co
libcourierauthsaslclient_la_LIBADD = libcourierauth.la
libcourierauthsaslclient_la_LDFLAGS = -export-symbols-regex '^auth_sasl_client$$' -avoid-version
@@ -104,7 +105,7 @@
courierauthconfig_SOURCES = authinfo.c
authpasswd_SOURCES = authpasswd.c
-@@ -832,7 +853,7 @@
+@@ -834,7 +856,7 @@ authmksock_LDADD = @NETLIBS@
man3 = authlib.3 auth_generic.3 auth_login.3 auth_getuserinfo.3 \
auth_enumerate.3 auth_passwd.3 auth_getoption.3 auth_sasl.3
@@ -113,7 +114,7 @@
man_MANS = $(man1) $(man3) auth_sasl_ex.3
BUILT1 = authlib.html authldaprc.h authmysqlrc.h authpgsqlrc.h authpiperc.h \
authdaemonrc.h packageversion.h \
-@@ -989,6 +1010,9 @@
+@@ -993,6 +1015,9 @@ libauthsqlite.la: $(libauthsqlite_la_OBJ
libauthuserdb.la: $(libauthuserdb_la_OBJECTS) $(libauthuserdb_la_DEPENDENCIES) $(EXTRA_libauthuserdb_la_DEPENDENCIES)
$(AM_V_CCLD)$(libauthuserdb_la_LINK) $(libauthuserdb_la_OBJECTS) $(libauthuserdb_la_LIBADD) $(LIBS)
@@ -123,7 +124,7 @@
libcourierauth.la: $(libcourierauth_la_OBJECTS) $(libcourierauth_la_DEPENDENCIES) $(EXTRA_libcourierauth_la_DEPENDENCIES)
$(AM_V_CCLD)$(libcourierauth_la_LINK) -rpath $(pkglibdir) $(libcourierauth_la_OBJECTS) $(libcourierauth_la_LIBADD) $(LIBS)
-@@ -1258,6 +1282,8 @@
+@@ -1262,6 +1287,8 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/authtest.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/authuserdb.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/authuserdbpwd.Plo@am__quote@
@@ -132,7 +133,7 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/checkpassword.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/checkpasswordmd5.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/checkpasswordsha1.Plo@am__quote@
-@@ -1275,6 +1301,7 @@
+@@ -1279,6 +1306,7 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/preauthsqlite.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/preauthuserdb.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/preauthuserdbcommon.Plo@am__quote@
@@ -140,7 +141,7 @@
.c.o:
@am__fastdepCC_TRUE@ $(AM_V_CC)$(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
-@@ -1771,18 +1798,26 @@
+@@ -1782,18 +1810,26 @@ info: info-recursive
info-am:
@@ -175,7 +176,7 @@
install-html: install-html-recursive
install-html-am:
-@@ -1862,14 +1897,20 @@
+@@ -1873,14 +1909,18 @@ uninstall-man: uninstall-man1 uninstall-
uninstall-sbinPROGRAMS uninstall-sbinSCRIPTS
@@ -194,12 +195,10 @@
-@HAVE_AUTHPGSQL_TRUE@ -chown @mailuser@ $(DESTDIR)@authpgsqlrc@.dist
-@HAVE_AUTHPGSQL_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authpgsqlrc@.dist
+@HAVE_AUTHPGSQL_TRUE@ $(DESTDIR)@authpgsqlrc@.sample
-+@HAVE_AUTHPGSQL_TRUE@ -chown @mailuser@ $(DESTDIR)@authpgsqlrc@.sample
-+@HAVE_AUTHPGSQL_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authpgsqlrc@.sample
@HAVE_AUTHPGSQL_TRUE@uninstall-authpgsqlrc:
@HAVE_AUTHPGSQL_TRUE@ rm -f $(DESTDIR)@authpgsqlrc@.dist
-@@ -1888,9 +1929,9 @@
+@@ -1899,9 +1939,7 @@ authldaplib.lo: authldaplib.c authldaprc
@HAVE_LDAP_TRUE@install-authldaprc:
@HAVE_LDAP_TRUE@ $(mkinstalldirs) $(DESTDIR)`dirname @authldaprc@` || :
@HAVE_LDAP_TRUE@ $(INSTALL_DATA) -m 660 $(srcdir)/authldaprc \
@@ -207,12 +206,10 @@
-@HAVE_LDAP_TRUE@ -chown @mailuser@ $(DESTDIR)@authldaprc@.dist
-@HAVE_LDAP_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authldaprc@.dist
+@HAVE_LDAP_TRUE@ $(DESTDIR)@authldaprc@.sample
-+@HAVE_LDAP_TRUE@ -chown @mailuser@ $(DESTDIR)@authldaprc@.sample
-+@HAVE_LDAP_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authldaprc@.sample
@HAVE_LDAP_TRUE@uninstall-authldaprc:
@HAVE_LDAP_TRUE@ rm -f $(DESTDIR)@authldaprc@.dist
-@@ -1901,6 +1942,19 @@
+@@ -1912,6 +1950,18 @@ authldaplib.lo: authldaplib.c authldaprc
@HAVE_LDAP_FALSE@uninstall-authldaprc:
@HAVE_LDAP_FALSE@ @:
@@ -227,12 +224,11 @@
+
+@HAVE_LDAP_FALSE@install-ldapschema:
+@HAVE_LDAP_FALSE@ @:
-+
+
authldaprc.h:
echo "#define AUTHLDAPRC \"@authldaprc@\"" >authldaprc.h
-@@ -1909,9 +1963,9 @@
+@@ -1920,9 +1970,7 @@ authmysqllib.lo: authmysqllib.c authmysq
@HAVE_AUTHMYSQL_TRUE@install-authmysqlrc:
@HAVE_AUTHMYSQL_TRUE@ $(mkinstalldirs) $(DESTDIR)`dirname @authmysqlrc@` || :
@HAVE_AUTHMYSQL_TRUE@ $(INSTALL_DATA) -m 660 $(srcdir)/authmysqlrc \
@@ -240,12 +236,10 @@
-@HAVE_AUTHMYSQL_TRUE@ -chown @mailuser@ $(DESTDIR)@authmysqlrc@.dist
-@HAVE_AUTHMYSQL_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authmysqlrc@.dist
+@HAVE_AUTHMYSQL_TRUE@ $(DESTDIR)@authmysqlrc@.sample
-+@HAVE_AUTHMYSQL_TRUE@ -chown @mailuser@ $(DESTDIR)@authmysqlrc@.sample
-+@HAVE_AUTHMYSQL_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authmysqlrc@.sample
@HAVE_AUTHMYSQL_TRUE@uninstall-authmysqlrc:
@HAVE_AUTHMYSQL_TRUE@ rm -f $(DESTDIR)@authmysqlrc@.dist
-@@ -1930,9 +1984,9 @@
+@@ -1941,9 +1989,7 @@ authsqlitelib.lo: authsqlitelib.c authsq
@HAVE_AUTHSQLITE_TRUE@install-authsqliterc:
@HAVE_AUTHSQLITE_TRUE@ $(mkinstalldirs) $(DESTDIR)`dirname @authsqliterc@` || :
@HAVE_AUTHSQLITE_TRUE@ $(INSTALL_DATA) -m 660 $(srcdir)/authsqliterc \
@@ -253,12 +247,10 @@
-@HAVE_AUTHSQLITE_TRUE@ -chown @mailuser@ $(DESTDIR)@authsqliterc@.dist
-@HAVE_AUTHSQLITE_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authsqliterc@.dist
+@HAVE_AUTHSQLITE_TRUE@ $(DESTDIR)@authsqliterc@.sample
-+@HAVE_AUTHSQLITE_TRUE@ -chown @mailuser@ $(DESTDIR)@authsqliterc@.sample
-+@HAVE_AUTHSQLITE_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authsqliterc@.sample
@HAVE_AUTHSQLITE_TRUE@uninstall-authsqliterc:
@HAVE_AUTHSQLITE_TRUE@ rm -f $(DESTDIR)@authsqliterc@.dist
-@@ -1951,16 +2005,22 @@
+@@ -1962,16 +2008,20 @@ authpipelib.lo: authpipelib.c authpipeli
authpiperc.h:
echo "#define PIPE_PROGRAM \"@authProg@\"" >authpiperc.h
@@ -270,12 +262,10 @@
- -chown @mailuser@ $(DESTDIR)@authdaemonrc@.dist
- -chgrp @mailgroup@ $(DESTDIR)@authdaemonrc@.dist
+@HAVE_BASE_TRUE@install-authdaemonrc:
-+@HAVE_BASE_TRUE@ $(mkinstalldirs) $(DESTDIR)`dirname @authdaemonrc@`
++@HAVE_BASE_TRUE@ $(mkinstalldirs) $(DESTDIR)`dirname @authdaemonrc@` || :
+@HAVE_BASE_TRUE@ sed 's/@ALLMODULES@/$(modules:lib%.la=%)/' <authdaemonrc >authdaemonrc.tmp
+@HAVE_BASE_TRUE@ $(INSTALL_DATA) -m 660 authdaemonrc.tmp $(DESTDIR)@authdaemonrc@.sample
+@HAVE_BASE_TRUE@ rm -f authdaemonrc.tmp
-+@HAVE_BASE_TRUE@ -chown @mailuser@ $(DESTDIR)@authdaemonrc@.sample
-+@HAVE_BASE_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authdaemonrc@.sample
-uninstall-authdaemonrc:
- rm -f $(DESTDIR)@authdaemonrc@.dist
@@ -290,7 +280,7 @@
authdaemonrc.h:
echo "#define AUTHDAEMONRC \"@authdaemonrc@\"" >authdaemonrc.h
-@@ -2003,24 +2063,30 @@
+@@ -2014,24 +2064,24 @@ dist-hook:
# automake still a bit stupid...
install-data-hook: install-authdaemonrc install-authpgsqlrc \
@@ -314,17 +304,11 @@
+@HAVE_BASE_TRUE@ $(mkinstalldirs) $(DESTDIR)$(sbindir) || :
+@HAVE_BASE_TRUE@ $(mkinstalldirs) $(DESTDIR)$(pkglibexecdir) || :
+@HAVE_BASE_TRUE@ chmod 755 $(DESTDIR)$(pkglibexecdir)
-+@HAVE_BASE_TRUE@ -chown @mailuser@ $(DESTDIR)$(pkglibexecdir)
-+@HAVE_BASE_TRUE@ -chgrp @mailgroup@ $(DESTDIR)$(pkglibexecdir)
+@HAVE_USERDB_TRUE@ $(mkinstalldirs) $(DESTDIR)$(pkglibexecdir) || :
+@HAVE_USERDB_TRUE@ chmod 755 $(DESTDIR)$(pkglibexecdir)
-+@HAVE_USERDB_TRUE@ -chown @mailuser@ $(DESTDIR)$(pkglibexecdir)
-+@HAVE_USERDB_TRUE@ -chgrp @mailgroup@ $(DESTDIR)$(pkglibexecdir)
+@HAVE_BASE_TRUE@ $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) authdaemondprog $(DESTDIR)$(pkglibexecdir)/authdaemond
+@HAVE_BASE_TRUE@ $(mkinstalldirs) $(DESTDIR)@authdaemonvar@ || :
+@HAVE_BASE_TRUE@ chmod 750 $(DESTDIR)@authdaemonvar@
-+@HAVE_BASE_TRUE@ -chown @mailuser@ $(DESTDIR)@authdaemonvar@
-+@HAVE_BASE_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authdaemonvar@
test "@LIBAUTHUSERDB@" = "" && exit 0 ;\
$(INSTALL_PROGRAM_ENV) $(INSTALL_PROGRAM) libs/makedat/makedatprog \
$(DESTDIR)$(pkglibexecdir)/makedatprog ; \
@@ -333,7 +317,7 @@
$(INSTALL_SCRIPT) userdb/pw2userdb \
$(DESTDIR)$(sbindir)/pw2userdb ; \
$(INSTALL_SCRIPT) userdb/makeuserdb \
-@@ -2033,9 +2099,10 @@
+@@ -2044,9 +2094,10 @@ install-exec-hook:
$(DESTDIR)$(sbindir)/userdb-test-cram-md5
uninstall-hook: uninstall-authldaprc uninstall-authdaemonrc uninstall-authmysqlrc uninstall-authpgsqlrc uninstall-authsqliterc
@@ -345,12 +329,12 @@
$(DESTDIR)$(sbindir)/pw2userdb \
$(DESTDIR)$(sbindir)/makeuserdb \
$(DESTDIR)$(sbindir)/userdb \
-@@ -2046,7 +2113,7 @@
+@@ -2057,7 +2108,7 @@ authlib.html: authlib.html.in
$(SHELL) ./config.status --file=authlib.html
authlib.3: authlib.3.in
- $(SHELL) ./config.status --file=authlib.3
+@HAVE_BASE_TRUE@ $(SHELL) ./config.status --file=authlib.3
- @HAVE_SGML_TRUE@authpasswd.html: authpasswd.sgml libs/docbook/sgml2html
- @HAVE_SGML_TRUE@ libs/docbook/sgml2html authpasswd.sgml authpasswd.html
+ @HAVE_SGML_TRUE@$(GITFILES): %: %.git
+ @HAVE_SGML_TRUE@ perl -p -e 's/\$$Id:[^\$$]*/\$$Id: '"`git log --pretty=format:\"%H\" -n 1 -- $<`-`date +%Y%m%d%H%M%S`/" <$< >$@.tmp
diff --git a/security/courier-authlib/files/patch-configure b/security/courier-authlib/files/patch-configure
index 9b22d92f48ef..8d88d719720f 100644
--- a/security/courier-authlib/files/patch-configure
+++ b/security/courier-authlib/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2012-10-14 12:45:02.000000000 +0200
-+++ configure 2012-10-14 12:46:15.000000000 +0200
-@@ -622,6 +622,10 @@
+--- configure.orig 2015-04-25 14:07:07 UTC
++++ configure
+@@ -642,6 +642,10 @@ ltdl_LIBOBJS
am__EXEEXT_FALSE
am__EXEEXT_TRUE
LTLIBOBJS
@@ -11,7 +11,7 @@
LIBOBJS
HAVE_SGML_FALSE
HAVE_SGML_TRUE
-@@ -656,6 +660,9 @@
+@@ -676,6 +680,9 @@ LIBAUTHPGSQL
PGSQL_LIBS
PG_CONFIG
authpgsqlrc
@@ -21,7 +21,7 @@
LIBAUTHPWD
LIBAUTHSHADOW
SHADOWLIBS
-@@ -1519,6 +1526,7 @@
+@@ -1546,6 +1553,7 @@ Optional Packages:
--with-authldaprc=filename Expect to find authldaprc here
--without-authpwd Do not include the authpwd module
--without-authshadow Do not include the authshadow module
@@ -29,7 +29,7 @@
--with-authpgsqlrc=filename Expect to find authpgsql here
--without-authpgsql Do not include the authpgsql module
--with-pgsql-libs=DIR Look for pgsql libs in this dir
-@@ -2755,7 +2763,7 @@
+@@ -2795,7 +2803,7 @@ else
fi
fi
@@ -38,7 +38,16 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for a thread-safe mkdir -p" >&5
$as_echo_n "checking for a thread-safe mkdir -p... " >&6; }
-@@ -13532,8 +13540,12 @@
+@@ -13456,7 +13464,7 @@ LIBS="$saveLIBS"
+
+
+ save_LIBS="$LIBS"
+-LIBS="-lcourier-unicode"
++LIBS="-L%%LOCALBASE%%/lib -lcourier-unicode"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -13749,8 +13757,12 @@ fi
if test "$doauthuserdb" = "no"
then
@@ -51,7 +60,7 @@
AUTHUSERDB="authuserdb"
LIBAUTHUSERDB="libauthuserdb.la"
-@@ -13991,6 +14003,20 @@
+@@ -14208,6 +14220,20 @@ else
fi
@@ -72,7 +81,7 @@
if test "$HAVE_LDAP" = 1; then
HAVE_LDAP_TRUE=
-@@ -14209,6 +14235,256 @@
+@@ -14426,6 +14452,256 @@ fi
diff --git a/security/courier-authlib/files/patch-liblock__locktest.c b/security/courier-authlib/files/patch-liblock__locktest.c
deleted file mode 100644
index 3f77f4b30a26..000000000000
--- a/security/courier-authlib/files/patch-liblock__locktest.c
+++ /dev/null
@@ -1,81 +0,0 @@
---- libs/liblock/locktest.c.orig Mon Dec 6 14:18:55 1999
-+++ libs/liblock/locktest.c Sun May 15 08:00:42 2005
-@@ -5,6 +5,7 @@
-
- /* $Id */
-
-+#include <paths.h>
- #include "liblock.h"
- #if USE_FCNTL
- #include "lockfcntl.c"
-@@ -20,11 +21,23 @@
-
- int main()
- {
-+#define FILENAME "courier-authlib.locktest.XXXXX"
- int fd[2];
- pid_t p;
- int s;
- int f;
-
-+ char *name;
-+ const char *tmpdir;
-+ if ((tmpdir = (char *)getenv("TMPDIR")) == NULL)
-+ tmpdir = _PATH_TMP;
-+ (void)asprintf(&name, "%s%s%s", tmpdir,
-+ (tmpdir[strlen(tmpdir) - 1] == '/') ? "" : "/", FILENAME);
-+ if (name == NULL) {
-+ perror("get filename");
-+ exit(1);
-+ }
-+
- signal(SIGCHLD, SIG_DFL);
- if (pipe(fd))
- {
-@@ -32,6 +45,12 @@
- return (1);
- }
-
-+ if ((f=mkstemp(name)) < 0)
-+ {
-+ perror("open");
-+ exit(1);
-+ }
-+
- if ((p=fork()) == (pid_t)-1)
- {
- perror("fork");
-@@ -46,7 +65,7 @@
- read(fd[0], &c, 1);
- close(fd[0]);
-
-- if ((f=open("conftest.lock", O_RDWR|O_CREAT, 0644)) < 0)
-+ if ((f=open(name, O_RDWR)) < 0)
- {
- perror("open");
- exit(1);
-@@ -56,22 +75,18 @@
- if (ll_lockfd(f, ll_writelock, 0, 0))
- {
- close(f);
-+ unlink(name);
- exit(0);
- }
- close(f);
- exit(1);
- }
--
-- if ((f=open("conftest.lock", O_RDWR|O_CREAT, 0644)) < 0)
-- {
-- perror("open");
-- exit(1);
-- }
-
- if (ll_lockfd(f, ll_writelock, 0, 0))
- {
- perror("lock");
- close(f);
-+ unlink(name);
- exit(1);
- }
- close(fd[1]);
diff --git a/security/courier-authlib/files/patch-libs_liblock_locktest.c b/security/courier-authlib/files/patch-libs_liblock_locktest.c
new file mode 100644
index 000000000000..a55b4bcfac39
--- /dev/null
+++ b/security/courier-authlib/files/patch-libs_liblock_locktest.c
@@ -0,0 +1,38 @@
+--- libs/liblock/locktest.c.orig 2014-07-13 13:58:08 UTC
++++ libs/liblock/locktest.c
+@@ -3,6 +3,7 @@
+ ** distribution information.
+ */
+
++#include <paths.h>
+ #include "liblock.h"
+ #if USE_FCNTL
+ #include "lockfcntl.c"
+@@ -20,7 +21,7 @@
+
+ int main()
+ {
+-#define FILENAME "courier-imap.locktest.XXXXXXXXXX"
++#define FILENAME "courier-authlib.locktest.XXXXXXXXXX"
+ int fd[2];
+ pid_t p;
+ int s;
+@@ -29,7 +30,7 @@ int f;
+ char *name;
+ const char *tmpdir;
+ if ((tmpdir = (char *)getenv("TMPDIR")) == NULL || !*tmpdir)
+- tmpdir = "/tmp";
++ tmpdir = _PATH_TMP;
+
+ if ((name=malloc(strlen(tmpdir)+sizeof(FILENAME)+1)) == NULL)
+ {
+@@ -37,7 +38,8 @@ int f;
+ exit(1);
+ }
+
+- (void)sprintf(name, "%s/%s", tmpdir, FILENAME);
++ (void)sprintf(name, "%s%s%s", tmpdir,
++ (tmpdir[strlen(tmpdir) - 1] == '/') ? "" : "/", FILENAME);
+
+ signal(SIGCHLD, SIG_DFL);
+ if (pipe(fd))
diff --git a/security/courier-authlib/pkg-descr b/security/courier-authlib/pkg-descr
index 133bc258b703..7eddea46f47a 100644
--- a/security/courier-authlib/pkg-descr
+++ b/security/courier-authlib/pkg-descr
@@ -6,4 +6,4 @@ for two purposes:
2. Read an account name, and a password. If valid, determine the
account's home directory, system userid, and groupid.
-WWW: http://www.Courier-MTA.org/authlib/
+WWW: http://www.Courier-MTA.org/authlib/
diff --git a/security/courier-authlib/pkg-plist-base b/security/courier-authlib/pkg-plist-base
index 526b822e14ca..2897682d4f9a 100644
--- a/security/courier-authlib/pkg-plist-base
+++ b/security/courier-authlib/pkg-plist-base
@@ -15,7 +15,7 @@ lib/courier-authlib/libauthpipe.so
libexec/courier-authlib/authdaemond
libexec/courier-authlib/authsystem.passwd
man/man1/authtest.1.gz
-man/man1/%%MAILOWN%%logger.1.gz
+man/man1/courierlogger.1.gz
man/man3/auth_enumerate.3.gz
man/man3/auth_generic.3.gz
man/man3/auth_getoption.3.gz