aboutsummaryrefslogtreecommitdiff
path: root/security/cracklib
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-09 08:34:27 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-09 08:34:27 +0000
commit6e0a07b7bd86d4bec01e28dace63fc2f4d332580 (patch)
tree3bfdadfb27c6f23f4df2e6b5117ceedfd779eefa /security/cracklib
parent00e68f0cf2d985fc3aa2fe60f34de29d592cca32 (diff)
downloadports-6e0a07b7bd86d4bec01e28dace63fc2f4d332580.tar.gz
ports-6e0a07b7bd86d4bec01e28dace63fc2f4d332580.zip
- Fix tests for py-cracklib
- Specify PYTHONPATH - Specifying correct dictionary path - Fix configure for py-cracklib by using USES=localbase - Switch to new test framework - Whitespace fix Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=472045
Diffstat (limited to 'security/cracklib')
-rw-r--r--security/cracklib/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/security/cracklib/Makefile b/security/cracklib/Makefile
index 8dc54f9bb84c..76f29a9aabfc 100644
--- a/security/cracklib/Makefile
+++ b/security/cracklib/Makefile
@@ -28,7 +28,7 @@ USES= gettext libtool
USE_LDCONFIG= yes
.if defined(PYTHON_SLAVEPORT)
-USES+= python:2.7
+USES+= python:2.7 #localbase
USE_PYTHON= flavors
CONFIGURE_ARGS+=--with-python
PLIST_FILES= %%PYTHON_SITELIBDIR%%/_cracklib.a \
@@ -101,10 +101,10 @@ PLIST_FILES= include/crack.h \
pre-build:
cd ${WRKSRC}/lib && ${MAKE_CMD} libcrack.la
-regression-test: extract
- @(cd ${BUILD_WKRSRC}; \
- ${PYTHON_CMD} -c \
- "from test_${PORTNAME} import run; run(use_dictpath=\"${DICTFILE}\")")
+do-test:
+ @(cd ${BUILD_WKRSRC} && ${SETENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} \
+ ${PYTHON_CMD} -c \
+ "from test_${PORTNAME} import run; run(use_dictpath=\"${DICTFILE:S|^${PREFIX}/|${LOCALBASE}/|}\")")
.else
post-install:
${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.3 ${STAGEDIR}${MAN3PREFIX}/man/man3/