aboutsummaryrefslogtreecommitdiff
path: root/security/cracklib
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-15 21:52:56 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-15 21:52:56 +0000
commit75ed089359f838dc4ee19d269f91c3f80803ce39 (patch)
tree8f586c4e4e7db758871418b705bf101a5b7447bd /security/cracklib
parent50bbf8528ddbd3042aea680bafff9da4b22b7671 (diff)
downloadports-75ed089359f838dc4ee19d269f91c3f80803ce39.tar.gz
ports-75ed089359f838dc4ee19d269f91c3f80803ce39.zip
Build a shared library. This fixes the build of dependent ports on amd64,
which cannot link non-PIC lib.a code into a lib.so. Also respect CFLAGS while I'm here, and bump PORTREVISION. Reviewed by: maintainer
Notes
Notes: svn path=/head/; revision=104119
Diffstat (limited to 'security/cracklib')
-rw-r--r--security/cracklib/Makefile5
-rw-r--r--security/cracklib/files/patch-Makefile13
-rw-r--r--security/cracklib/files/patch-cracklib::Makefile28
-rw-r--r--security/cracklib/files/patch-util::Makefile11
-rw-r--r--security/cracklib/pkg-plist2
5 files changed, 56 insertions, 3 deletions
diff --git a/security/cracklib/Makefile b/security/cracklib/Makefile
index e250ba724466..bc5238695ed2 100644
--- a/security/cracklib/Makefile
+++ b/security/cracklib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cracklib
PORTVERSION= 2.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.crypticide.org/users/alecm/security/
DISTNAME= ${PORTNAME},${PORTVERSION}
@@ -17,9 +17,12 @@ COMMENT= Password-checking library
MAN3= cracklib.3
MLINKS= cracklib.3 FascistCheck.3
+INSTALLS_SHLIB= yes
pre-install:
${INSTALL_DATA} ${WRKSRC}/cracklib/libcrack.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/cracklib/libcrack.so.1 ${PREFIX}/lib
+ ${LN} -sf libcrack.so.1 ${PREFIX}/lib/libcrack.so
${INSTALL_DATA} ${WRKSRC}/cracklib/packer.h ${PREFIX}/include
${INSTALL_SCRIPT} ${WRKSRC}/util/mkdict ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/util/packer ${PREFIX}/bin
diff --git a/security/cracklib/files/patch-Makefile b/security/cracklib/files/patch-Makefile
index 927ed5c18fba..93d4db588f3c 100644
--- a/security/cracklib/files/patch-Makefile
+++ b/security/cracklib/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sat Apr 22 09:47:37 2000
-+++ Makefile Sat Apr 22 09:48:06 2000
+--- Makefile.orig Wed Dec 31 02:33:53 1997
++++ Makefile Mon Mar 15 04:46:29 2004
@@ -9,12 +9,12 @@
###
# set this to the absolute path (less extn) of compressed dict.
@@ -15,3 +15,12 @@
###
# If you have installed the cracklib-dicts directory, use this
+@@ -24,7 +24,7 @@
+ @echo "you evidently don't know what you're doing. go read the README"
+
+ all:
+- ( cd cracklib && make && exit $$? )
++ ( cd cracklib && make all && exit $$? )
+ ( cd util && make DICTPATH=$(DICTPATH) && exit $$? )
+ ### ( cd passwd && make DICTPATH=$(DICTPATH) passwd && exit $$? )
+ ### touch all
diff --git a/security/cracklib/files/patch-cracklib::Makefile b/security/cracklib/files/patch-cracklib::Makefile
new file mode 100644
index 000000000000..72cdd68f2989
--- /dev/null
+++ b/security/cracklib/files/patch-cracklib::Makefile
@@ -0,0 +1,28 @@
+--- cracklib/Makefile.orig Mon Mar 15 04:45:15 2004
++++ cracklib/Makefile Mon Mar 15 04:45:21 2004
+@@ -7,12 +7,24 @@
+ ###
+
+ LIB= libcrack.a
++SHLIB= libcrack.so.1
+ OBJ= fascist.o packlib.o rules.o stringlib.o
+-CFLAGS= -O -I../cracklib -DIN_CRACKLIB
++SHOBJ= fascist.So packlib.So rules.So stringlib.So
++CFLAGS+=-I../cracklib -DIN_CRACKLIB
++
++.SUFFIXES: .o .So
++
++.c.So:
++ $(CC) $(CFLAGS) -fPIC -o $*.So -c $?
+
+ $(LIB): $(OBJ)
+ ar rv $(LIB) $?
+ -ranlib $(LIB)
++
++$(SHLIB): $(SHOBJ)
++ ld -shared -o ${SHLIB} ${SHOBJ}
++
++all: $(LIB) $(SHLIB)
+
+ clean:
+ -rm -f $(OBJ) $(LIB) *~
diff --git a/security/cracklib/files/patch-util::Makefile b/security/cracklib/files/patch-util::Makefile
new file mode 100644
index 000000000000..29954fbb0d5d
--- /dev/null
+++ b/security/cracklib/files/patch-util::Makefile
@@ -0,0 +1,11 @@
+--- util/Makefile.orig Mon Mar 15 04:47:13 2004
++++ util/Makefile Mon Mar 15 04:47:19 2004
+@@ -14,7 +14,7 @@
+ #SunOS users (and others?) should consider static linking of their passwd binary
+ #CFLAGS= -O -I../cracklib '-DCRACKLIB_DICTPATH="$(DICTPATH)"' -Bstatic
+
+-CFLAGS= -O -I../cracklib '-DCRACKLIB_DICTPATH="$(DICTPATH)"'
++CFLAGS+=-I../cracklib '-DCRACKLIB_DICTPATH="$(DICTPATH)"'
+ LIBS= ../cracklib/libcrack.a
+
+ all: packer unpacker testnum teststr testlib
diff --git a/security/cracklib/pkg-plist b/security/cracklib/pkg-plist
index 2515819b20e0..eb5f30cbfa68 100644
--- a/security/cracklib/pkg-plist
+++ b/security/cracklib/pkg-plist
@@ -6,6 +6,8 @@ bin/teststr
bin/unpacker
include/packer.h
lib/libcrack.a
+lib/libcrack.so
+lib/libcrack.so.1
libdata/cracklib/pw_dict.hwm
libdata/cracklib/pw_dict.pwd
libdata/cracklib/pw_dict.pwi