aboutsummaryrefslogtreecommitdiff
path: root/security/crlfuzz/Makefile
diff options
context:
space:
mode:
authorGabriel Dutra <0xdutra@gmail.com>2021-05-30 21:14:49 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-05-30 21:14:49 +0000
commita98d34a590014e5154a3c44b1e5ddb435b775aad (patch)
tree23d45b564c2e8eb50be7c49de0b773d62626bc9e /security/crlfuzz/Makefile
parent8bee9d3bead6a4d7e57a8893fd76fb294cd4fa04 (diff)
downloadports-a98d34a590014e5154a3c44b1e5ddb435b775aad.tar.gz
ports-a98d34a590014e5154a3c44b1e5ddb435b775aad.zip
Diffstat (limited to 'security/crlfuzz/Makefile')
-rw-r--r--security/crlfuzz/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/security/crlfuzz/Makefile b/security/crlfuzz/Makefile
new file mode 100644
index 000000000000..6b3f68202451
--- /dev/null
+++ b/security/crlfuzz/Makefile
@@ -0,0 +1,26 @@
+# Created by: Gabriel M. Dutra <0xdutra@gmail.com>
+
+PORTNAME= crlfuzz
+PORTVERSION= 1.4.1
+DISTVERSIONPREFIX= v
+CATEGORIES= security
+
+MAINTAINER= 0xdutra@gmail.com
+COMMENT= Fast tool to scan CRLF vulnerability written in Go
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+USE_GITHUB= yes
+GH_ACCOUNT= dwisiswant0
+
+GO_TARGET= ./cmd/crlfuzz
+
+GH_TUPLE= logrusorgru:aurora:e9ef32dff381:logrusorgru_aurora/vendor/github.com/logrusorgru/aurora \
+ projectdiscovery:gologger:v1.0.1:projectdiscovery_gologger/vendor/github.com/projectdiscovery/gologger
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>