aboutsummaryrefslogtreecommitdiff
path: root/security/cryptopp
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 06:02:06 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 06:02:06 +0000
commit13441eac4bb7e0e8a50bd437681b05022e55146b (patch)
treed65b02f7b127a36b4aa96f03448ee021d09b0c58 /security/cryptopp
parent8110f70f5fcd1d3afb2d1d8ceaaf0fe73a23c8d9 (diff)
downloadports-13441eac4bb7e0e8a50bd437681b05022e55146b.tar.gz
ports-13441eac4bb7e0e8a50bd437681b05022e55146b.zip
Remove always-false/true conditions based on OSVERSION 500000
Notes
Notes: svn path=/head/; revision=200791
Diffstat (limited to 'security/cryptopp')
-rw-r--r--security/cryptopp/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 0eea74d368cf..eca2279441f8 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -13,7 +13,6 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.mirrors.wiretapped.net/security/cryptography/libraries/cryptolib/
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= cryptopp${PORTVERSION:S/.//g}
-EXTRACT_SUFX= .zip
MAINTAINER= delphij@FreeBSD.org
COMMENT= A free C++ class library of Cryptographic Primitives
@@ -24,14 +23,9 @@ EXTRACT_BEFORE_ARGS= -aq
USE_GMAKE= yes
MAKEFILE= GNUmakefile
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= Internal compiler error on alpha 4.x
-.endif
-
pre-install:
${STRIP_CMD} ${WRKSRC}/cryptest
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cryptest ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/libcryptopp.a ${PREFIX}/lib
@@ -47,4 +41,4 @@ do-install:
${CP} ${WRKSRC}/License.txt ${PREFIX}/share/doc/cryptopp/License
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>