aboutsummaryrefslogtreecommitdiff
path: root/security/cryptopp
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-09-27 20:35:24 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-09-27 20:35:24 +0000
commit5e0c88b744df3837c927d7521881a2a7aa097722 (patch)
tree445b2c6faea923b98415b7da1c8ec20100784158 /security/cryptopp
parentc6512b0ffb32503f731da739bb2d63e5ab55c8bd (diff)
downloadports-5e0c88b744df3837c927d7521881a2a7aa097722.tar.gz
ports-5e0c88b744df3837c927d7521881a2a7aa097722.zip
Set flags on powerpc64le the same as on powerpc64.
Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=550346
Diffstat (limited to 'security/cryptopp')
-rw-r--r--security/cryptopp/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index e5f9b1cbe610..69af1df44886 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -32,8 +32,9 @@ PLIST_SUB+= SOVERSION=${SOVERSION} \
OPTIONS_DEFINE= DEBUG DOCS FULL_DEBUG TOOLS
OPTIONS_DEFINE_amd64= SIMD
OPTIONS_DEFINE_i386= SIMD
-OPTIONS_DEFINE_powerpc= SIMD
+OPTIONS_DEFINE_powerpc= SIMD
OPTIONS_DEFINE_powerpc64= SIMD
+OPTIONS_DEFINE_powerpc64le= SIMD
OPTIONS_DEFAULT= TOOLS
OPTIONS_SUB= yes
@@ -64,7 +65,7 @@ CXXFLAGS+= -DCRYPTOPP_DISABLE_SSSE3
. if !${MACHINE_CPU:Msse41}
CXXFLAGS+= -DCRYPTOPP_DISABLE_SSE4
. endif
-. elif ${ARCH} == powerpc || ${ARCH} == powerpc64
+. elif ${ARCH} == powerpc || ${ARCH:Mpowerpc64*}
CXXFLAGS+= -DCRYPTOPP_ALTIVEC_AVAILABLE -maltivec -mcrypto -mvsx
. endif
.else