aboutsummaryrefslogtreecommitdiff
path: root/security/cyberchef
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2019-09-09 20:04:39 +0000
committerDan Langille <dvl@FreeBSD.org>2019-09-09 20:04:39 +0000
commit2c3a1c98d3786587f2a013bf163856bcdd7111fb (patch)
treed5cc69cfb62f96ec8eaf59a42a42108982f05a17 /security/cyberchef
parentf39251cfa57612a63806aefe2c06fb5504c83c42 (diff)
downloadports-2c3a1c98d3786587f2a013bf163856bcdd7111fb.tar.gz
ports-2c3a1c98d3786587f2a013bf163856bcdd7111fb.zip
Update to 9.6.0
Committed with some changes. Of note: CyberChef is no longer one single file. See also the images, assets, & modules diretories. PR: 240454 Submitted by: thomas@bsdunix.ch
Notes
Notes: svn path=/head/; revision=511697
Diffstat (limited to 'security/cyberchef')
-rw-r--r--security/cyberchef/Makefile18
-rw-r--r--security/cyberchef/distinfo6
-rw-r--r--security/cyberchef/pkg-plist33
3 files changed, 47 insertions, 10 deletions
diff --git a/security/cyberchef/Makefile b/security/cyberchef/Makefile
index 371c57096993..0ad4abcf3285 100644
--- a/security/cyberchef/Makefile
+++ b/security/cyberchef/Makefile
@@ -2,19 +2,20 @@
# $FreeBSD$
PORTNAME= cyberchef
-PORTVERSION= 8.24.2
-PORTREVISION= 2
+PORTVERSION= 9.6.0
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= security
-DISTFILES= cyberchef.htm
-EXTRACT_ONLY= # none
+MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/${GH_TAGNAME}/
+DISTNAME= CyberChef_v9.6.0
MAINTAINER= dvl@FreeBSD.org
COMMENT= Cyber operations within a web browser
LICENSE= APACHE20
-MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/${GH_TAGNAME}/
+USES= zip
+
USE_GITHUB= nodefault
GH_ACCOUNT= gchq
GH_PROJECT= CyberChef
@@ -23,7 +24,10 @@ NO_BUILD= yes
NO_ARCH= yes
do-install:
- ${MKDIR} ${STAGEDIR}${WWWDIR}
- ${INSTALL} ${DISTDIR}/cyberchef.htm ${STAGEDIR}${WWWDIR}/index.html
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ ${INSTALL} ${WRKDIR}/${DISTNAME}.html ${STAGEDIR}${WWWDIR}/index.html
+ ${CP} -R ${WRKDIR}/images ${STAGEDIR}${WWWDIR}/
+ ${CP} -R ${WRKDIR}/modules ${STAGEDIR}${WWWDIR}/
+ ${CP} -R ${WRKDIR}/assets ${STAGEDIR}${WWWDIR}/
.include <bsd.port.mk>
diff --git a/security/cyberchef/distinfo b/security/cyberchef/distinfo
index 287a5e0ede21..8e9f408911fa 100644
--- a/security/cyberchef/distinfo
+++ b/security/cyberchef/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1551374789
-SHA256 (cyberchef.htm) = cdc1a608d1af21fd9d9b673fd35c603daccaa5ab62fb9ea05617d2c76f6be000
-SIZE (cyberchef.htm) = 11937259
+TIMESTAMP = 1568050222
+SHA256 (CyberChef_v9.6.0.zip) = 7e8b4fb809e2c3856da9ccb465a6ca6092c2c65b325ee01e9a84e97b2e8f448f
+SIZE (CyberChef_v9.6.0.zip) = 16219326
diff --git a/security/cyberchef/pkg-plist b/security/cyberchef/pkg-plist
index 6f232237f9b1..c1985561ef09 100644
--- a/security/cyberchef/pkg-plist
+++ b/security/cyberchef/pkg-plist
@@ -1 +1,34 @@
%%WWWDIR%%/index.html
+%%WWWDIR%%/assets/fonts/Roboto72White.fnt
+%%WWWDIR%%/assets/fonts/Roboto72White.png
+%%WWWDIR%%/assets/fonts/RobotoBlack72White.fnt
+%%WWWDIR%%/assets/fonts/RobotoBlack72White.png
+%%WWWDIR%%/assets/fonts/RobotoMono72White.fnt
+%%WWWDIR%%/assets/fonts/RobotoMono72White.png
+%%WWWDIR%%/assets/fonts/RobotoSlab72White.fnt
+%%WWWDIR%%/assets/fonts/RobotoSlab72White.png
+%%WWWDIR%%/assets/main.css
+%%WWWDIR%%/assets/main.js
+%%WWWDIR%%/images/cook_male-32x32.png
+%%WWWDIR%%/images/cyberchef-128x128.png
+%%WWWDIR%%/images/file-128x128.png
+%%WWWDIR%%/images/file-32x32.png
+%%WWWDIR%%/images/fork_me.png
+%%WWWDIR%%/images/map.png
+%%WWWDIR%%/modules/BSON.js
+%%WWWDIR%%/modules/Charts.js
+%%WWWDIR%%/modules/Ciphers.js
+%%WWWDIR%%/modules/Code.js
+%%WWWDIR%%/modules/Compression.js
+%%WWWDIR%%/modules/Crypto.js
+%%WWWDIR%%/modules/Diff.js
+%%WWWDIR%%/modules/Encodings.js
+%%WWWDIR%%/modules/Hashing.js
+%%WWWDIR%%/modules/Image.js
+%%WWWDIR%%/modules/PGP.js
+%%WWWDIR%%/modules/PublicKey.js
+%%WWWDIR%%/modules/Regex.js
+%%WWWDIR%%/modules/Shellcode.js
+%%WWWDIR%%/modules/URL.js
+%%WWWDIR%%/modules/UserAgent.js
+%%WWWDIR%%/modules/Yara.js