aboutsummaryrefslogtreecommitdiff
path: root/security/cyrus-sasl2/Makefile
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2000-10-24 02:03:09 +0000
committerJames E. Housley <jeh@FreeBSD.org>2000-10-24 02:03:09 +0000
commit94124a586bc589c1fa0ff18159db9a7572aa41d0 (patch)
treeb790880244fc7f3019b89b9e5bf1d4251466483a /security/cyrus-sasl2/Makefile
parent97e6ae70a32c01eb1a7036054f2ed6d276a6b09d (diff)
downloadports-94124a586bc589c1fa0ff18159db9a7572aa41d0.tar.gz
ports-94124a586bc589c1fa0ff18159db9a7572aa41d0.zip
Notes
Diffstat (limited to 'security/cyrus-sasl2/Makefile')
-rw-r--r--security/cyrus-sasl2/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 47a6cedd6e43..5ba8b55ad666 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -43,12 +43,18 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--enable-static \
--enable-login \
--with-pwcheck=/var/pwcheck \
+ --with-dblib=ndbm \
--with-rc4=openssl
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
PREFIX="${PREFIX}" \
TOUCH="${TOUCH}" \
- MKDIR="${MKDIR}"
+ MKDIR="${MKDIR}" \
+ ENABLE_DB3="${ENABLE_DB3}" \
+ ENABLE_MYSQL="${ENABLE_MYSQL}" \
+ ENABLE_LDAP="${ENABLE_LDAP}"
+
+# ENABLE_* variables can be used by depending ports to enable options.
# JavaSASL needs someone to look at to get it to build
#JAVADIR= jdk1.1.8
@@ -65,16 +71,16 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
#.endif
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
-CONFIGURE_ARGS+= --enable-gssapi=${KRB5_HOME}
+CONFIGURE_ARGS+= --enable-gssapi=${KRB5_HOME}
.else
-CONFIGURE_ARGS+= --disable-gssapi
+CONFIGURE_ARGS+= --disable-gssapi
GSSAPI= "@comment "
.endif
.if exists(/usr/lib/libkrb.a)
-CONFIGURE_ARGS+= --enable-krb4
+CONFIGURE_ARGS+= --enable-krb4
.else
-CONFIGURE_ARGS+= --disable-krb4
+CONFIGURE_ARGS+= --disable-krb4
EBONES= "@comment "
.endif