aboutsummaryrefslogtreecommitdiff
path: root/security/distcache
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-09-07 16:25:29 +0000
committerJohn Marino <marino@FreeBSD.org>2014-09-07 16:25:29 +0000
commit3d8e6037d82eecfd94429f26a9f1b618d4da7793 (patch)
tree6cc4815dccf714a1192515d015de6cee42adaa1a /security/distcache
parent7a2fe6c1d3ed0409060cf531e24f34803860a923 (diff)
downloadports-3d8e6037d82eecfd94429f26a9f1b618d4da7793.tar.gz
ports-3d8e6037d82eecfd94429f26a9f1b618d4da7793.zip
Stage security/distcache; Apache24 optionally depends on it
Notes
Notes: svn path=/head/; revision=367566
Diffstat (limited to 'security/distcache')
-rw-r--r--security/distcache/Makefile33
-rw-r--r--security/distcache/pkg-descr4
-rw-r--r--security/distcache/pkg-plist22
3 files changed, 32 insertions, 27 deletions
diff --git a/security/distcache/Makefile b/security/distcache/Makefile
index b2b80c309f92..85f496216fed 100644
--- a/security/distcache/Makefile
+++ b/security/distcache/Makefile
@@ -3,42 +3,31 @@
PORTNAME= distcache
PORTVERSION= 1.4.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security www
MASTER_SITES= SF/${PORTNAME}/2.%20${PORTNAME}-stable/${PORTVERSION} \
http://osdn.dl.sourceforge.net/sourceforge/${PORTNAME}/
-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Distributed OpenSSL session caching tools
-CONFLICTS= distcache-devel-*
-
-USES= tar:bzip2
+USES= libtool tar:bzip2
USE_RC_SUBR= dc_server
-USE_AUTOTOOLS= libtool
USE_OPENSSL= yes
USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-shared
+INSTALL_TARGET= install-strip
SUB_LIST+= NAME=dc_server
-
-.if !defined(NOPORTDOCS)
PORTDOCS= ANNOUNCE BUGS CHANGES FAQ INSTALL LICENSE README
-.endif
-MAN1= dc_client.1 dc_server.1 dc_snoop.1 dc_test.1 sslswamp.1
-MAN2= DC_CTX_new.2 DC_PLUG_new.2 DC_PLUG_read.2 DC_SERVER_new.2 \
- NAL_ADDRESS_new.2 NAL_BUFFER_new.2 NAL_CONNECTION_new.2 \
- NAL_LISTENER_new.2 NAL_SELECTOR_new.2 NAL_decode_uint32.2
-MAN8= distcache.8
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
+ # INSTALL_TARGET=install-strip isn't working! Brute force it
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so
.include <bsd.port.mk>
diff --git a/security/distcache/pkg-descr b/security/distcache/pkg-descr
index 1c0c178f6777..2d3c915ff8fe 100644
--- a/security/distcache/pkg-descr
+++ b/security/distcache/pkg-descr
@@ -1,6 +1,6 @@
Distributed session caching tools and APIs, primarily for SSL/TLS servers
-though perhaps useful for other (non-SSL/TLS) circumstances.
-Also includes a self-contained network abstraction library (libnal), and the
+though perhaps useful for other (non-SSL/TLS) circumstances. This also
+includes a self-contained network abstraction library (libnal), and the
sslswamp SSL/TLS benchmark/test utility.
WWW: http://distcache.sourceforge.net/
diff --git a/security/distcache/pkg-plist b/security/distcache/pkg-plist
index 51a75b9e3464..efe9cabd39f7 100644
--- a/security/distcache/pkg-plist
+++ b/security/distcache/pkg-plist
@@ -11,17 +11,33 @@ include/distcache/dc_server.h
include/libnal/nal.h
include/libnal/nal_devel.h
lib/libdistcache.a
-lib/libdistcache.la
lib/libdistcache.so
lib/libdistcache.so.1
+lib/libdistcache.so.1.0.1
lib/libdistcacheserver.a
-lib/libdistcacheserver.la
lib/libdistcacheserver.so
lib/libdistcacheserver.so.1
+lib/libdistcacheserver.so.1.0.1
lib/libnal.a
-lib/libnal.la
lib/libnal.so
lib/libnal.so.1
+lib/libnal.so.1.0.1
+man/man1/dc_client.1.gz
+man/man1/dc_server.1.gz
+man/man1/dc_snoop.1.gz
+man/man1/dc_test.1.gz
+man/man1/sslswamp.1.gz
+man/man2/DC_CTX_new.2.gz
+man/man2/DC_PLUG_new.2.gz
+man/man2/DC_PLUG_read.2.gz
+man/man2/DC_SERVER_new.2.gz
+man/man2/NAL_ADDRESS_new.2.gz
+man/man2/NAL_BUFFER_new.2.gz
+man/man2/NAL_CONNECTION_new.2.gz
+man/man2/NAL_LISTENER_new.2.gz
+man/man2/NAL_SELECTOR_new.2.gz
+man/man2/NAL_decode_uint32.2.gz
+man/man8/distcache.8.gz
share/swamp/A-client.pem
share/swamp/CA.pem
@dirrm include/distcache