aboutsummaryrefslogtreecommitdiff
path: root/security/dsniff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2016-08-15 11:02:26 +0000
committerBernard Spil <brnrd@FreeBSD.org>2016-08-15 11:02:26 +0000
commit8043e5d1f082ddfb213d61aa7c8b34ea4b3393dc (patch)
treed49c967d4a4c4351688f8da9a7da58c4e824d326 /security/dsniff
parentb4ac49a03ec3ad98c66a9518ea4637352be8563e (diff)
downloadports-8043e5d1f082ddfb213d61aa7c8b34ea4b3393dc.tar.gz
ports-8043e5d1f082ddfb213d61aa7c8b34ea4b3393dc.zip
security/dsniff: Replace deprecated des_ methods and structs
- Replace all des_ methods and structs with DES_ equivalents - Remove openssl/des_old.h include - Register dependencies on OpenSSL, glib20 and gettext Obtained from: OpenBSD ports Reviewed by: sbz (maintainer) Approved by: sbz (maintainer) Differential Revision: D7054
Notes
Notes: svn path=/head/; revision=420225
Diffstat (limited to 'security/dsniff')
-rw-r--r--security/dsniff/Makefile3
-rw-r--r--security/dsniff/files/patch-sshcrypto.c68
2 files changed, 63 insertions, 8 deletions
diff --git a/security/dsniff/Makefile b/security/dsniff/Makefile
index 7e0a2afce4a2..62d8bcf04dd4 100644
--- a/security/dsniff/Makefile
+++ b/security/dsniff/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libnids.a:net/libnids
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libnet=${LOCALBASE}
DESTDIRNAME= install_prefix
-USES= pkgconfig
+USES= gettext pkgconfig ssl
+USE_GNOME= glib20
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/(.*)..$/\1/}
OPTIONS_DEFINE= X11
diff --git a/security/dsniff/files/patch-sshcrypto.c b/security/dsniff/files/patch-sshcrypto.c
index 8e303bbdaca4..f6770c78fc28 100644
--- a/security/dsniff/files/patch-sshcrypto.c
+++ b/security/dsniff/files/patch-sshcrypto.c
@@ -1,12 +1,66 @@
---- ./sshcrypto.c.orig 2001-03-15 09:33:04.000000000 +0100
-+++ ./sshcrypto.c 2014-07-22 13:20:14.000000000 +0200
-@@ -14,6 +14,9 @@
-
+$OpenBSD: patch-sshcrypto_c,v 1.3 2015/05/29 15:57:29 jca Exp $
+--- sshcrypto.c.orig Tue Nov 28 22:23:28 2000
++++ sshcrypto.c Fri May 29 17:56:22 2015
+@@ -15,7 +15,9 @@
#include <sys/types.h>
#include <openssl/ssl.h>
-+#include <openssl/blowfish.h>
-+#include <openssl/des.h>
-+#include <openssl/des_old.h>
++#include <openssl/des.h>
#include <err.h>
++#include <openssl/blowfish.h>
#include <stdio.h>
+ #include <stdlib.h>
+
+@@ -27,8 +29,8 @@ struct blowfish_state {
+ };
+
+ struct des3_state {
+- des_key_schedule k1, k2, k3;
+- des_cblock iv1, iv2, iv3;
++ DES_key_schedule k1, k2, k3;
++ DES_cblock iv1, iv2, iv3;
+ };
+
+ void
+@@ -153,13 +155,13 @@ des3_init(u_char *sesskey, int len)
+ if ((state = malloc(sizeof(*state))) == NULL)
+ err(1, "malloc");
+
+- des_set_key((void *)sesskey, state->k1);
+- des_set_key((void *)(sesskey + 8), state->k2);
++ DES_set_key((void *)sesskey, &state->k1);
++ DES_set_key((void *)(sesskey + 8), &state->k2);
+
+ if (len <= 16)
+- des_set_key((void *)sesskey, state->k3);
++ DES_set_key((void *)sesskey, &state->k3);
+ else
+- des_set_key((void *)(sesskey + 16), state->k3);
++ DES_set_key((void *)(sesskey + 16), &state->k3);
+
+ memset(state->iv1, 0, 8);
+ memset(state->iv2, 0, 8);
+@@ -175,9 +177,9 @@ des3_encrypt(u_char *src, u_char *dst, int len, void *
+ estate = (struct des3_state *)state;
+ memcpy(estate->iv1, estate->iv2, 8);
+
+- des_ncbc_encrypt(src, dst, len, estate->k1, &estate->iv1, DES_ENCRYPT);
+- des_ncbc_encrypt(dst, dst, len, estate->k2, &estate->iv2, DES_DECRYPT);
+- des_ncbc_encrypt(dst, dst, len, estate->k3, &estate->iv3, DES_ENCRYPT);
++ DES_ncbc_encrypt(src, dst, len, &estate->k1, &estate->iv1, DES_ENCRYPT);
++ DES_ncbc_encrypt(dst, dst, len, &estate->k2, &estate->iv2, DES_DECRYPT);
++ DES_ncbc_encrypt(dst, dst, len, &estate->k3, &estate->iv3, DES_ENCRYPT);
+ }
+
+ void
+@@ -188,7 +190,7 @@ des3_decrypt(u_char *src, u_char *dst, int len, void *
+ dstate = (struct des3_state *)state;
+ memcpy(dstate->iv1, dstate->iv2, 8);
+
+- des_ncbc_encrypt(src, dst, len, dstate->k3, &dstate->iv3, DES_DECRYPT);
+- des_ncbc_encrypt(dst, dst, len, dstate->k2, &dstate->iv2, DES_ENCRYPT);
+- des_ncbc_encrypt(dst, dst, len, dstate->k1, &dstate->iv1, DES_DECRYPT);
++ DES_ncbc_encrypt(src, dst, len, &dstate->k3, &dstate->iv3, DES_DECRYPT);
++ DES_ncbc_encrypt(dst, dst, len, &dstate->k2, &dstate->iv2, DES_ENCRYPT);
++ DES_ncbc_encrypt(dst, dst, len, &dstate->k1, &dstate->iv1, DES_DECRYPT);
+ }