aboutsummaryrefslogtreecommitdiff
path: root/security/dsniff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-02-08 07:07:19 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-02-08 07:07:19 +0000
commitb939cb8d44033a2eaa856e1db010c1b1380a5fbc (patch)
tree8969034f875c37dc3a0f49240b18f6a8c6d10a0b /security/dsniff
parent8453a00a4dd506392e0742e73a7db0f8d341a4e4 (diff)
downloadports-b939cb8d44033a2eaa856e1db010c1b1380a5fbc.tar.gz
ports-b939cb8d44033a2eaa856e1db010c1b1380a5fbc.zip
Last attempt to fix dsniff
Reported by: pkg-fallout (again)
Notes
Notes: svn path=/head/; revision=343308
Diffstat (limited to 'security/dsniff')
-rw-r--r--security/dsniff/Makefile3
-rw-r--r--security/dsniff/files/patch-Makefile.in23
2 files changed, 14 insertions, 12 deletions
diff --git a/security/dsniff/Makefile b/security/dsniff/Makefile
index 32d7cebcb8d4..3589c09f51a1 100644
--- a/security/dsniff/Makefile
+++ b/security/dsniff/Makefile
@@ -36,6 +36,7 @@ LIBNET_INC= "`${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`"
LIBNET_LIB= "-L${LOCALBASE}/include/libnet${LIBNET_VERSION} \
${LOCALBASE}/lib/libnet${LIBNET_VERSION}/libnet.a"
+.include <bsd.port.pre.mk>
# If net/libnids has been compiled with the GLIB2 option then this port needs
# the corresponding library and additional linker flags.
LIBNIDS_GLIB2?=
@@ -61,4 +62,4 @@ pre-configure:
${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/dsniff/files/patch-Makefile.in b/security/dsniff/files/patch-Makefile.in
index 21d8750b08e6..1e57a7f917bf 100644
--- a/security/dsniff/files/patch-Makefile.in
+++ b/security/dsniff/files/patch-Makefile.in
@@ -1,5 +1,5 @@
--- ./Makefile.in.orig 2000-12-15 20:03:26.000000000 +0000
-+++ ./Makefile.in 2014-02-03 13:13:21.000000000 +0000
++++ ./Makefile.in 2014-02-08 06:51:17.000000000 +0000
@@ -8,7 +8,6 @@
srcdir = @srcdir@
VPATH = @srcdir@
@@ -40,26 +40,27 @@
- rpcgen -h mount.x -o mount.h
- rpcgen -c mount.x -o mount.c
+ rpcgen -c mount.x -o $@
-+
-+mount.h: mount.x
-+ rpcgen -h mount.x -o $@
-+
-+decode_mountd.c: mount.h
- nfs_prot.c: nfs_prot.x
+-nfs_prot.c: nfs_prot.x
- rpcgen -h nfs_prot.x -o nfs_prot.h
- rpcgen -c nfs_prot.x -o nfs_prot.c
-+ rpcgen -c nfs_prot.x -o $@
++mount.h: mount.x
++ rpcgen -h mount.x -o $@
-$(LIBOBJS):
- $(CC) $(CFLAGS) $(INCS) -c $(srcdir)/missing/$*.c
-+nfs_prot.h: nfs_prot.x
-+ rpcgen -h nfs_prot.x -o $@
++decode_mountd.c: mount.h
-libmissing.a: $(LIBOBJS)
- ar -cr $@ $(LIBOBJS)
- $(RANLIB) $@
-+filesnarf.c: nfs_prot.h nfs_prot.c
++nfs_prot.c: nfs_prot.x nfs_prot.h
++ rpcgen -c nfs_prot.x -o $@
++
++nfs_prot.h: nfs_prot.x
++ rpcgen -h nfs_prot.x -o $@
++
++filesnarf.c: nfs_prot.h
dsniff: $(HDRS) $(SRCS) $(OBJS)
$(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(NIDSLIB) $(PCAPLIB) $(LNETLIB) $(DBLIB) $(SSLLIB)