aboutsummaryrefslogtreecommitdiff
path: root/security/esteidfirefoxplugin
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-10-09 09:06:16 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-10-09 09:06:16 +0000
commitc4e12a20bf902b2ff1532b546a7bb5c1c4b26711 (patch)
tree5c120b9ac36d8cb520383c189bdacdcfd2132d3a /security/esteidfirefoxplugin
parent1c4a7efaa10056ca6ce01dd680649c5cc7e73468 (diff)
downloadports-c4e12a20bf902b2ff1532b546a7bb5c1c4b26711.tar.gz
ports-c4e12a20bf902b2ff1532b546a7bb5c1c4b26711.zip
New port: security/esteidfirefoxplugin
A Firefox plugin that enables in-browser digital signing with Estonian ID cards. PR: 194300 Submitted by: toomas.aas@raad.tartu.ee Reviewed by: marino
Notes
Notes: svn path=/head/; revision=398906
Diffstat (limited to 'security/esteidfirefoxplugin')
-rw-r--r--security/esteidfirefoxplugin/Makefile31
-rw-r--r--security/esteidfirefoxplugin/distinfo2
-rw-r--r--security/esteidfirefoxplugin/files/patch-Makefile15
-rw-r--r--security/esteidfirefoxplugin/pkg-descr4
4 files changed, 52 insertions, 0 deletions
diff --git a/security/esteidfirefoxplugin/Makefile b/security/esteidfirefoxplugin/Makefile
new file mode 100644
index 000000000000..0c5d94b497d1
--- /dev/null
+++ b/security/esteidfirefoxplugin/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= esteidfirefoxplugin
+PORTVERSION= 3.8.0.1115
+CATEGORIES= security
+MASTER_SITES= https://installer.id.ee/media/sources/
+
+MAINTAINER= toomas.aas@raad.tartu.ee
+COMMENT= Digital signing with Estonian ID card in Firefox
+
+LICENSE= LGPL21
+
+RUN_DEPENDS= opensc-tool:${PORTSDIR}/security/opensc \
+ pcscd:${PORTSDIR}/devel/pcsc-lite
+
+USE_OPENSSL= yes
+USE_GNOME= gtk20
+USES= webplugin:gecko pkgconfig
+WEBPLUGIN_DIR= ${PREFIX}/lib
+WEBPLUGIN_FILES= npesteid-firefox-plugin.so
+
+ALL_TARGET= plugin
+
+EXTRACT_AFTER_ARGS= --exclude 'include/openssl'
+
+PLIST_FILES= lib/npesteid-firefox-plugin.so
+
+post-install:
+ ${INSTALL_LIB} ${WRKSRC}/npesteid-firefox-plugin.so ${STAGEDIR}${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/security/esteidfirefoxplugin/distinfo b/security/esteidfirefoxplugin/distinfo
new file mode 100644
index 000000000000..985c8ef3bf47
--- /dev/null
+++ b/security/esteidfirefoxplugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (esteidfirefoxplugin-3.8.0.1115.tar.gz) = 2783d275f08e3addc1e07990656220568477261367b56aa4737a89e14517afef
+SIZE (esteidfirefoxplugin-3.8.0.1115.tar.gz) = 444994
diff --git a/security/esteidfirefoxplugin/files/patch-Makefile b/security/esteidfirefoxplugin/files/patch-Makefile
new file mode 100644
index 000000000000..4f85e42b5efd
--- /dev/null
+++ b/security/esteidfirefoxplugin/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- ./Makefile.orig 2013-04-29 17:49:10.000000000 +0300
++++ ./Makefile 2014-09-10 16:37:31.000000000 +0300
+@@ -1,10 +1,10 @@
+ # EstEID Browser Plugin
+-CC = gcc
++CC = cc
+ COMMON_HEADERS = common/esteid_certinfo.h common/pkcs11_errors.h common/esteid_log.h common/esteid_sign.h common/esteid_timer.h common/esteid_time.h common/l10n.h common/labels.h common/esteid_map.h common/esteid_dialog_common.h
+ COMMON_SOURCES = common/esteid_certinfo.c common/pkcs11_errors.c common/esteid_log.c common/esteid_sign.c common/esteid_timer.c common/esteid_time.c common/l10n.c common/l10n-linux.c common/esteid_map.c common/esteid_dialog_common.c
+ C_FLAGS = -g -O2 -std=gnu99 -Wall $(CPPFLAGS)
+ I_FLAGS = -Iinclude -Icommon `pkg-config --cflags gtk+-2.0`
+-L_FLAGS = -ldl -lcrypto -lpthread `pkg-config --libs gtk+-2.0`
++L_FLAGS = -lcrypto -lpthread `pkg-config --libs gtk+-2.0`
+ D_FLAGS = -DXP_UNIX -DMOZ_X11
+ PLUGIN_HEADERS = firefox/plugin.h firefox/plugin-class.h firefox/cert-class.h
+ PLUGIN_SOURCES = firefox/plugin.c firefox/plugin-class.c firefox/cert-class.c
diff --git a/security/esteidfirefoxplugin/pkg-descr b/security/esteidfirefoxplugin/pkg-descr
new file mode 100644
index 000000000000..f00b7a614dea
--- /dev/null
+++ b/security/esteidfirefoxplugin/pkg-descr
@@ -0,0 +1,4 @@
+A Firefox plugin that enables in-browser digital signing with Estonian ID
+cards.
+
+WWW: http://www.id.ee/