aboutsummaryrefslogtreecommitdiff
path: root/security/fragroute
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-05-27 01:53:33 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-05-27 01:53:33 +0000
commitdf629fd3ded41c895d4a7152702905b362bc62af (patch)
tree6a3308496915395b536c0e6ffa2001c9703233f1 /security/fragroute
parent8afa8d3ea122a2c18e7f143ffc52598aad19c597 (diff)
downloadports-df629fd3ded41c895d4a7152702905b362bc62af.tar.gz
ports-df629fd3ded41c895d4a7152702905b362bc62af.zip
Add fragroute, a tool for intercepting, modifying and rewriting egress
traffic. PR: 38300 Submitted by: Dominic Marks <dominic_marks@btinternet.com>
Notes
Notes: svn path=/head/; revision=60058
Diffstat (limited to 'security/fragroute')
-rw-r--r--security/fragroute/Makefile35
-rw-r--r--security/fragroute/distinfo1
-rw-r--r--security/fragroute/pkg-comment1
-rw-r--r--security/fragroute/pkg-descr16
-rw-r--r--security/fragroute/pkg-plist21
5 files changed, 74 insertions, 0 deletions
diff --git a/security/fragroute/Makefile b/security/fragroute/Makefile
new file mode 100644
index 000000000000..fb91de348463
--- /dev/null
+++ b/security/fragroute/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: fragroute
+# Date created: 19 May 2002
+# Whom: Dominic Marks <dominic_marks@btinternet.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fragroute
+PORTVERSION= 1.2
+CATEGORIES= security net
+MASTER_SITES= http://www.monkey.org/~dugsong/fragroute/
+
+MAINTAINER= dominic_marks@btinternet.com
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet \
+ ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-libdnet=${PREFIX} \
+ --with-libevent=${PREFIX} --with-pcap
+
+MAN8= fragroute.8 fragtest.8
+
+SCRIPTS= README.snort base-1 frag-1 frag-2 frag-3 frag-4 frag-5 \
+ frag-6 frag-7-unix frag-7-win32 ins-2 ins-3 tcbc-2 tcp-3 tcp-5 \
+ tcp-7 tcp-9
+
+pre-install:
+ ${MKDIR} ${PREFIX}/share/${PORTNAME}
+.for FILE in ${SCRIPTS}
+ ${INSTALL_DATA} ${WRKSRC}/scripts/${FILE} \
+ ${PREFIX}/share/${PORTNAME}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/security/fragroute/distinfo b/security/fragroute/distinfo
new file mode 100644
index 000000000000..b79548db2236
--- /dev/null
+++ b/security/fragroute/distinfo
@@ -0,0 +1 @@
+MD5 (fragroute-1.2.tar.gz) = 65edbfc51f8070517f14ceeb8f721075
diff --git a/security/fragroute/pkg-comment b/security/fragroute/pkg-comment
new file mode 100644
index 000000000000..cbd3f50a05f6
--- /dev/null
+++ b/security/fragroute/pkg-comment
@@ -0,0 +1 @@
+A tool for intercepting, modifying and rewriting egress traffic
diff --git a/security/fragroute/pkg-descr b/security/fragroute/pkg-descr
new file mode 100644
index 000000000000..c2c207bc7621
--- /dev/null
+++ b/security/fragroute/pkg-descr
@@ -0,0 +1,16 @@
+"Fragroute intercepts, modifies, and rewrites egress traffic destined
+for a specified host, implementing most of the attacks described in the
+Secure Networks "Insertion, Evasion, and Denial of Service: Eluding
+Network Intrusion Detection" paper of January 1998.
+
+It features a simple ruleset language to delay, duplicate, drop,
+fragment, overlap, print, reorder, segment, source-route, or otherwise
+monkey with all outbound packets destined for a target host, with
+minimal support for randomized or probabilistic behaviour.
+
+This tool was written in good faith to aid in the testing of network
+intrusion detection systems, firewalls, and basic TCP/IP stack
+behaviour. Please do not abuse this software."
+
+WWW: http://www.monkey.org/~dugsong/fragroute/
+- Dominic <dominic_marks@btinternet.com>
diff --git a/security/fragroute/pkg-plist b/security/fragroute/pkg-plist
new file mode 100644
index 000000000000..9602a4d4cb88
--- /dev/null
+++ b/security/fragroute/pkg-plist
@@ -0,0 +1,21 @@
+sbin/fragroute
+sbin/fragtest
+etc/fragroute.conf
+share/fragroute/README.snort
+share/fragroute/base-1
+share/fragroute/frag-1
+share/fragroute/frag-2
+share/fragroute/frag-3
+share/fragroute/frag-4
+share/fragroute/frag-5
+share/fragroute/frag-6
+share/fragroute/frag-7-unix
+share/fragroute/frag-7-win32
+share/fragroute/ins-2
+share/fragroute/ins-3
+share/fragroute/tcbc-2
+share/fragroute/tcp-3
+share/fragroute/tcp-5
+share/fragroute/tcp-7
+share/fragroute/tcp-9
+@dirrm share/fragroute