aboutsummaryrefslogtreecommitdiff
path: root/security/ftimes
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-08-18 06:59:30 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-08-18 06:59:30 +0000
commit25b3f428f23f84fae1d99cd82d9a233c9aa0a699 (patch)
tree819e9928228fba093c6bda99b4b676cf1e215d1c /security/ftimes
parentca4ce4a1cc7a68807331b453a09fd0ba2705dbb6 (diff)
downloadports-25b3f428f23f84fae1d99cd82d9a233c9aa0a699.tar.gz
ports-25b3f428f23f84fae1d99cd82d9a233c9aa0a699.zip
- Update to upstream release 3.11.0
- Fix pkg-plist for all permutations of OPTIONS PR: 192615 Submitted by: klm@uidzero.org (maintainer) Approved by: mentors (implicit)
Notes
Notes: svn path=/head/; revision=365269
Diffstat (limited to 'security/ftimes')
-rw-r--r--security/ftimes/Makefile20
-rw-r--r--security/ftimes/distinfo4
-rw-r--r--security/ftimes/files/patch-configure10
-rw-r--r--security/ftimes/files/patch-etc__xmagic__xmagic.base90
-rw-r--r--security/ftimes/pkg-plist16
5 files changed, 37 insertions, 103 deletions
diff --git a/security/ftimes/Makefile b/security/ftimes/Makefile
index ed9549366d56..0897a3109aa4 100644
--- a/security/ftimes/Makefile
+++ b/security/ftimes/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ftimes
-PORTVERSION= 3.10.0
-PORTREVISION= 1
+PORTVERSION= 3.11.0
CATEGORIES= security sysutils
MASTER_SITES= SF
@@ -15,13 +14,14 @@ LICENSE_COMB= multi
GNU_CONFIGURE= yes
USES= perl5 shebangfix tar:tgz
-USE_PERL5= run build fixpacklist
+USE_PERL5= run build
SHEBANG_FILES= \
${WRKSRC}/tools/dig/ftimes-crv2dbi.pl \
${WRKSRC}/tools/dig/ftimes-crv2raw.pl \
${WRKSRC}/tools/dig/ftimes-dig2ctx.pl \
${WRKSRC}/tools/dig/ftimes-dig2dbi.pl \
${WRKSRC}/tools/dig/hipdig.pl \
+ ${WRKSRC}/tools/ftimes-bimvl/ftimes-bimvl \
${WRKSRC}/tools/ftimes-cmp2diff/ftimes-cmp2diff \
${WRKSRC}/tools/ftimes-dbm-bash/ftimes-dbm-bash \
${WRKSRC}/tools/ftimes-dbm-dump/ftimes-dbm-dump \
@@ -67,6 +67,8 @@ CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}
STRIP_FILES= ${STAGEDIR}${PREFIX}/bin/ftimes
+INSTALL_PERL5_LIBS=
+
.if ${PORT_OPTIONS:MDBM_TOOLS}
PLIST_SUB+= DBM_TOOLS=""
CONFIGURE_ARGS+= --with-dbm-tools
@@ -78,6 +80,7 @@ PLIST_SUB+= DBM_TOOLS="@comment "
PLIST_SUB+= DIG_TOOLS=""
CONFIGURE_ARGS+= --with-dig-tools
RUN_DEPENDS+= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
+INSTALL_PERL5_LIBS= yes
.else
PLIST_SUB+= DIG_TOOLS="@comment "
.endif
@@ -100,6 +103,7 @@ PLIST_SUB+= HASHDIG_TOOLS="@comment "
PLIST_SUB+= MAP_TOOLS=""
CONFIGURE_ARGS+= --with-map-tools
STRIP_FILES+= ${STAGEDIR}${PREFIX}/bin/ftimes-cat ${STAGEDIR}${PREFIX}/bin/ftimes-xpa ${STAGEDIR}${PREFIX}/bin/hashcp ${STAGEDIR}${PREFIX}/bin/tarmap
+INSTALL_PERL5_LIBS= yes
.else
PLIST_SUB+= MAP_TOOLS="@comment "
.endif
@@ -117,10 +121,18 @@ PLIST_SUB+= XMAGIC=""
CONFIGURE_ARGS+= --enable-xmagic
.else
PLIST_SUB+= XMAGIC="@comment "
+CONFIGURE_ARGS+= --disable-xmagic
+.endif
+
+.if ${INSTALL_PERL5_LIBS}
+PLIST_SUB+= FTIMES_PERL5_LIBS=""
+USE_PERL5+= fixpacklist
+.else
+PLIST_SUB+= FTIMES_PERL5_LIBS="@comment "
.endif
post-configure:
- ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' ${WRKSRC}/lib/perl/Makefile
+ if [ "${INSTALL_PERL5_LIBS}" = "yes" ] ; then ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' ${WRKSRC}/lib/perl/Makefile ; fi
post-install:
${STRIP_CMD} ${STRIP_FILES}
diff --git a/security/ftimes/distinfo b/security/ftimes/distinfo
index bac7f2db4036..4fc5ff11660b 100644
--- a/security/ftimes/distinfo
+++ b/security/ftimes/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ftimes-3.10.0.tgz) = 3bd4a66c685e365d0dc4f74edaf220808530d75e78fa0246c7727d5597e95af2
-SIZE (ftimes-3.10.0.tgz) = 643517
+SHA256 (ftimes-3.11.0.tgz) = 70178e80c4ea7a8ce65404dd85a4bf5958a78f6a60c48f1fd06f78741c200f64
+SIZE (ftimes-3.11.0.tgz) = 653540
diff --git a/security/ftimes/files/patch-configure b/security/ftimes/files/patch-configure
new file mode 100644
index 000000000000..9d4c2468c020
--- /dev/null
+++ b/security/ftimes/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig 2014-08-17 13:35:11.932131244 -0400
++++ configure 2014-08-17 13:35:37.032505938 -0400
+@@ -5760,6 +5760,7 @@
+ tests/hipdig/common/dig/Makefile
+ tests/hipdig/common/dig/test_1/Makefile
+ "
++ install_lib_perl="1"
+ else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+ $as_echo "no" >&6; }
diff --git a/security/ftimes/files/patch-etc__xmagic__xmagic.base b/security/ftimes/files/patch-etc__xmagic__xmagic.base
deleted file mode 100644
index c19e01bf0ab2..000000000000
--- a/security/ftimes/files/patch-etc__xmagic__xmagic.base
+++ /dev/null
@@ -1,90 +0,0 @@
---- etc/xmagic/xmagic.base.orig 2013-04-09 13:34:18.000000000 -0400
-+++ etc/xmagic/xmagic.base 2013-04-09 13:38:03.000000000 -0400
-@@ -648,66 +648,66 @@
- 0 string = \x23\x20PaCkAgE\x20DaTaStReAm package/svr4
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- ae script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/ae) script/ae: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/ae) script/ae: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- ash script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/ash) script/ash: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/ash) script/ash: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- awk script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/awk) script/awk: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/awk) script/awk: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- bash script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/bash) script/bash: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/bash) script/bash: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- csh script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/csh) script/csh: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/csh) script/csh: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- env script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/env) script/env: path="%s";
-->&0 regexp =~ ^#![\x20\t]*(?:/(?:opt|usr)(?:/local)?)?/bin/env[\x20\t]+(ae|(?:[ackz]|ba|tcl?|wi)?sh|[gn]?awk|lua|perl|php|python|rc|ruby) interpreter="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/env) script/env: path="%s";
-+>&0 regexp =~ ^\x23![\x20\t]*(?:/(?:opt|usr)(?:/local)?)?/bin/env[\x20\t]+(ae|(?:[ackz]|ba|tcl?|wi)?sh|[gn]?awk|lua|perl|php|python|rc|ruby) interpreter="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- gawk script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/gawk) script/gawk: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/gawk) script/gawk: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- ksh script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/ksh) script/ksh: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/ksh) script/ksh: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- lua script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/lua) script/lua: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/lua) script/lua: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- nawk script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/nawk) script/nawk: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/nawk) script/nawk: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- perl script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/perl) script/perl: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/perl) script/perl: path="%s";
- 0 regexp =~ (?:eval[\x20\t]+["'][(]exit[\x20\t]+[$][?][)][\x20\t]+&&[\x20\t]+)?eval[\x20\t]+["']exec[\x20\t]+((?:(?:/(?:opt|usr)(?:/local)?)?/bin/)?perl)[\x20\t]+ script/perl: path="%s"; eval="yes";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- php script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/php) script/php: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/php) script/php: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- python script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/python) script/python: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/python) script/python: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- rc script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/rc) script/rc: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/rc) script/rc: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- ruby script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/ruby) script/ruby: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/ruby) script/ruby: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- sh script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/sh) script/sh: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/sh) script/sh: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- tclsh script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/tclsh) script/tclsh: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/tclsh) script/tclsh: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- tcsh script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/tcsh) script/tcsh: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/tcsh) script/tcsh: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- wish script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/wish) script/wish: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/wish) script/wish: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- zsh script
--0 regexp =~ ^#![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/zsh) script/zsh: path="%s";
-+0 regexp =~ ^\x23![\x20\t]*((?:/(?:opt|usr)(?:/local)?)?/bin/zsh) script/zsh: path="%s";
- #=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=#
- # XMagic -- btsnoop
- 0 string = btsnoop\0 sniffer/btsnoop:
diff --git a/security/ftimes/pkg-plist b/security/ftimes/pkg-plist
index 0685f1ec598d..772cc986740a 100644
--- a/security/ftimes/pkg-plist
+++ b/security/ftimes/pkg-plist
@@ -20,6 +20,7 @@
%%HASHDIG_TOOLS%%bin/hashdig-resolve-sunsolve.pl
%%HASHDIG_TOOLS%%bin/hashdig-stat.pl
%%HASHDIG_TOOLS%%bin/hashdig-weed.pl
+%%MAP_TOOLS%%bin/ftimes-bimvl
%%MAP_TOOLS%%bin/ftimes-cat
%%MAP_TOOLS%%bin/ftimes-cmp2dbi.pl
%%MAP_TOOLS%%bin/ftimes-cmp2diff
@@ -40,9 +41,9 @@ bin/ftimes
etc/ftimes-dig.cfg.sample
etc/ftimes-get.cfg.sample
etc/ftimes-map.cfg.sample
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/FTimes/.packlist
-%%SITE_PERL%%/FTimes/EadRoutines.pm
-%%SITE_PERL%%/FTimes/Properties.pm
+%%FTIMES_PERL5_LIBS%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/FTimes/.packlist
+%%FTIMES_PERL5_LIBS%%%%SITE_PERL%%/FTimes/EadRoutines.pm
+%%FTIMES_PERL5_LIBS%%%%SITE_PERL%%/FTimes/Properties.pm
man/man1/ftimes.1.gz
%%DBM_TOOLS%%man/man1/ftimes-dbm-bash.1.gz
%%DBM_TOOLS%%man/man1/ftimes-dbm-dump.1.gz
@@ -66,6 +67,7 @@ man/man1/ftimes.1.gz
%%HASHDIG_TOOLS%%man/man1/hashdig-resolve-sunsolve.1.gz
%%HASHDIG_TOOLS%%man/man1/hashdig-stat.1.gz
%%HASHDIG_TOOLS%%man/man1/hashdig-weed.1.gz
+%%MAP_TOOLS%%man/man1/ftimes-bimvl.1.gz
%%MAP_TOOLS%%man/man1/ftimes-cat.1.gz
%%MAP_TOOLS%%man/man1/ftimes-cmp2dbi.1.gz
%%MAP_TOOLS%%man/man1/ftimes-cmp2diff.1.gz
@@ -81,7 +83,7 @@ man/man1/ftimes.1.gz
%%MAP_TOOLS%%man/man1/hashcp.1.gz
%%MAP_TOOLS%%man/man1/tarmap.1.gz
%%MAP_TOOLS%%man/man1/zipmap.1.gz
-man/man3/FTimes::EadRoutines.3.gz
-man/man3/FTimes::Properties.3.gz
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/FTimes
-@dirrm %%SITE_PERL%%/FTimes
+%%FTIMES_PERL5_LIBS%%man/man3/FTimes::EadRoutines.3.gz
+%%FTIMES_PERL5_LIBS%%man/man3/FTimes::Properties.3.gz
+%%FTIMES_PERL5_LIBS%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/FTimes
+%%FTIMES_PERL5_LIBS%%@dirrm %%SITE_PERL%%/FTimes