aboutsummaryrefslogtreecommitdiff
path: root/security/fuzzdb
diff options
context:
space:
mode:
authorNiels Heinen <niels@FreeBSD.org>2010-04-19 11:12:11 +0000
committerNiels Heinen <niels@FreeBSD.org>2010-04-19 11:12:11 +0000
commit91a851bfd71617df4ba477d7cd93cc6779c25291 (patch)
tree17ca622e1afb23063d21414ff484b96b35bc58f0 /security/fuzzdb
parentcf6cee91ef51b5c7130430c3929b477b93c47446 (diff)
New port: Fuzzdb is a comprehensive set of fuzzing patterns that
can be used during discovery or security testing of web applications. WWW: http://code.google.com/p/fuzzdb/ Approved by: itetcu (mentor)
Notes
Notes: svn path=/head/; revision=252908
Diffstat (limited to 'security/fuzzdb')
-rw-r--r--security/fuzzdb/Makefile31
-rw-r--r--security/fuzzdb/distinfo3
-rw-r--r--security/fuzzdb/pkg-descr4
-rw-r--r--security/fuzzdb/pkg-plist113
4 files changed, 151 insertions, 0 deletions
diff --git a/security/fuzzdb/Makefile b/security/fuzzdb/Makefile
new file mode 100644
index 000000000000..0aefdad6fb6e
--- /dev/null
+++ b/security/fuzzdb/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: fuzzdb
+# Date created: 2010-04-14
+# Whom: Niels Heinen
+#
+# $FreeBSD$
+#
+
+PORTNAME= fuzzdb
+PORTVERSION= 1.01
+CATEGORIES= security www
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= niels@FreeBSD.org
+COMMENT= A comprehensive set of fuzzing patterns
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude .svn
+PORTDOCS= copyright.txt
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ( cd ${WRKSRC} && ${COPYTREE_SHARE} . ${DATADIR} "! -name ${PORTDOCS}" )
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/fuzzdb/distinfo b/security/fuzzdb/distinfo
new file mode 100644
index 000000000000..34d99c640e95
--- /dev/null
+++ b/security/fuzzdb/distinfo
@@ -0,0 +1,3 @@
+MD5 (fuzzdb-1.01.tgz) = e5f0d12a81809c65326e45ccb3f462b4
+SHA256 (fuzzdb-1.01.tgz) = 52fda37dce12b677b8022800a6614cd3132a5ffc2c0ca84260ea3d4137bdd5fc
+SIZE (fuzzdb-1.01.tgz) = 286897
diff --git a/security/fuzzdb/pkg-descr b/security/fuzzdb/pkg-descr
new file mode 100644
index 000000000000..43ad4dfe815e
--- /dev/null
+++ b/security/fuzzdb/pkg-descr
@@ -0,0 +1,4 @@
+Fuzzdb is a comprehensive set of fuzzing patterns that can be used
+during discovery or security testing of web applications.
+
+WWW: http://code.google.com/p/fuzzdb/
diff --git a/security/fuzzdb/pkg-plist b/security/fuzzdb/pkg-plist
new file mode 100644
index 000000000000..ae8b7e3c9bc1
--- /dev/null
+++ b/security/fuzzdb/pkg-plist
@@ -0,0 +1,113 @@
+%%DATADIR%%/c
+%%DATADIR%%/common-unix-httpd-log-locations.txt
+%%DATADIR%%/discovery/backdoors-php.txt
+%%DATADIR%%/discovery/cgi-HTTP-POST-reqd.txt
+%%DATADIR%%/discovery/cgi-microsoft.txt
+%%DATADIR%%/discovery/cgi-x-platform.txt
+%%DATADIR%%/discovery/copy_of.txt
+%%DATADIR%%/discovery/file-extensions-backup-files.txt
+%%DATADIR%%/discovery/file-extensions-common-datafile-types.txt
+%%DATADIR%%/discovery/file-extensions-compressed-filetypes.txt
+%%DATADIR%%/discovery/file-extensions-mostcommon.txt
+%%DATADIR%%/discovery/file-extensions-skipfish.txt
+%%DATADIR%%/discovery/interesting-dirs-kitchensink.txt
+%%DATADIR%%/discovery/interesting-files-apache-tomcat.txt
+%%DATADIR%%/discovery/interesting-files-apache.txt
+%%DATADIR%%/discovery/interesting-files-coldfusion.txt
+%%DATADIR%%/discovery/interesting-files-dotfiles.txt
+%%DATADIR%%/discovery/interesting-files-hyperion.txt
+%%DATADIR%%/discovery/interesting-files-iplanet.txt
+%%DATADIR%%/discovery/interesting-files-lotus-notes.txt
+%%DATADIR%%/discovery/interesting-files-microsoft-iis-http-post.txt
+%%DATADIR%%/discovery/interesting-files-microsoft-iis.txt
+%%DATADIR%%/discovery/interesting-files-microsoft-sharepoint.txt
+%%DATADIR%%/discovery/interesting-files-netware.txt
+%%DATADIR%%/discovery/interesting-files-oracle-application-server.txt
+%%DATADIR%%/discovery/interesting-files-random.txt
+%%DATADIR%%/discovery/interesting-files-sun-app-server.txt
+%%DATADIR%%/discovery/interesting-files-websphere.txt
+%%DATADIR%%/discovery/interesting-metacharacters.txt
+%%DATADIR%%/discovery/tftp.txt
+%%DATADIR%%/discovery/wordlist-skipfish.txt
+%%DATADIR%%/file upload/alt-extensions-asp.txt
+%%DATADIR%%/file upload/alt-extensions-coldfusion.txt
+%%DATADIR%%/file upload/alt-extensions-jsp.txt
+%%DATADIR%%/file upload/alt-extensions-perl.txt
+%%DATADIR%%/file upload/alt-extensions-php.txt
+%%DATADIR%%/file upload/alt-extensions.credits.txt
+%%DATADIR%%/file upload/file-ul-filter-bypass-commonly-writable-directories.txt
+%%DATADIR%%/file upload/file-ul-filter-bypass-microsoft-asp.txt
+%%DATADIR%%/file upload/file-ul-filter-bypass-ms-php.txt
+%%DATADIR%%/file upload/file-ul-filter-bypass-x-platform-generic.txt
+%%DATADIR%%/file upload/file-ul-filter-bypass-x-platform-php.txt
+%%DATADIR%%/file upload/file-ul-filter-bypass.readme
+%%DATADIR%%/format strings/format-strings.txt
+%%DATADIR%%/http protocol/http-header-cache-poison.txt
+%%DATADIR%%/http protocol/http-protocol-methods.txt
+%%DATADIR%%/http protocol/user-agents.txt
+%%DATADIR%%/integer overflow/integer-overflows.txt
+%%DATADIR%%/ldap/ldap-injection.txt
+%%DATADIR%%/misc - payloads/all-attacks-wfuzz.txt
+%%DATADIR%%/misc - wordlists/wordlist-alphanumeric-case.txt
+%%DATADIR%%/misc - wordlists/wordlist-common-snmp-community-strings.txt
+%%DATADIR%%/misc - wordlists/wordlist-dna.txt
+%%DATADIR%%/os command execution/command-execution-unix.txt
+%%DATADIR%%/os directory indexing/directory-indexing.txt
+%%DATADIR%%/path traversal/path-traversal-windows.txt
+%%DATADIR%%/path traversal/traversals-8-deep-exotic-encoding.txt
+%%DATADIR%%/readme.txt
+%%DATADIR%%/rfi/rfi.txt
+%%DATADIR%%/server side includes/server-side-includes-generic.txt
+%%DATADIR%%/source disclosure/source-disclosure-microsoft.txt
+%%DATADIR%%/sql injection/sql-injection-active.txt
+%%DATADIR%%/sql injection/sql-injection-ms-sql-blind-ninja.txt
+%%DATADIR%%/sql injection/sql-injection-ms-sql.txt
+%%DATADIR%%/sql injection/sql-injection-mysql-ms-sql.txt
+%%DATADIR%%/sql injection/sql-injection-mysql.txt
+%%DATADIR%%/sql injection/sql-injection-oracle.txt
+%%DATADIR%%/sql injection/sql-injection-passive.txt
+%%DATADIR%%/sql injection/sql-injection.txt
+%%DATADIR%%/usernames and passwords/_hci_oracle_passwords.txt
+%%DATADIR%%/usernames and passwords/_oracle_default_passwords.txt
+%%DATADIR%%/usernames and passwords/db2_default_pass.txt
+%%DATADIR%%/usernames and passwords/db2_default_user.txt
+%%DATADIR%%/usernames and passwords/db2_default_userpass.txt
+%%DATADIR%%/usernames and passwords/http_default_pass.txt
+%%DATADIR%%/usernames and passwords/http_default_userpass.txt
+%%DATADIR%%/usernames and passwords/http_default_users.txt
+%%DATADIR%%/usernames and passwords/namelist.txt
+%%DATADIR%%/usernames and passwords/postgres_default_pass.txt
+%%DATADIR%%/usernames and passwords/postgres_default_user.txt
+%%DATADIR%%/usernames and passwords/postgres_default_userpass.txt
+%%DATADIR%%/usernames and passwords/tomcat_mgr_default_pass.txt
+%%DATADIR%%/usernames and passwords/tomcat_mgr_default_userpass.txt
+%%DATADIR%%/usernames and passwords/tomcat_mgr_default_users.txt
+%%DATADIR%%/usernames and passwords/unix_passwords.txt
+%%DATADIR%%/usernames and passwords/unix_users.txt
+%%DATADIR%%/usernames and passwords/wordlist-passwords-weaksauce.txt
+%%DATADIR%%/xml/xml-attacks.txt
+%%DATADIR%%/xpath/xpath-injection.txt
+%%DATADIR%%/xss/xss-rsnake.txt
+%%DATADIR%%/xss/xss-uri.txt
+@dirrm %%DATADIR%%/xss
+@dirrm %%DATADIR%%/xpath
+@dirrm %%DATADIR%%/xml
+@dirrm %%DATADIR%%/usernames and passwords
+@dirrm %%DATADIR%%/sql injection
+@dirrm %%DATADIR%%/source disclosure
+@dirrm %%DATADIR%%/server side includes
+@dirrm %%DATADIR%%/rfi
+@dirrm %%DATADIR%%/path traversal
+@dirrm %%DATADIR%%/os directory indexing
+@dirrm %%DATADIR%%/os command execution
+@dirrm %%DATADIR%%/misc - wordlists
+@dirrm %%DATADIR%%/misc - payloads
+@dirrm %%DATADIR%%/lfi
+@dirrm %%DATADIR%%/ldap
+@dirrm %%DATADIR%%/integer overflow
+@dirrm %%DATADIR%%/http protocol
+@dirrm %%DATADIR%%/format strings
+@dirrm %%DATADIR%%/file upload
+@dirrm %%DATADIR%%/docs
+@dirrm %%DATADIR%%/discovery
+@dirrm %%DATADIR%%