aboutsummaryrefslogtreecommitdiff
path: root/security/fwbuilder
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-08-04 19:25:45 +0000
committerJohn Marino <marino@FreeBSD.org>2016-08-04 19:25:45 +0000
commit044e3a6784cf0d12471cea824721c13bc1677e29 (patch)
treef7fcc6061fc011f222f3eeb97809d94089bcc868 /security/fwbuilder
parentd2bb45f9b3079090307793f4e70e07ee7f2054d7 (diff)
downloadports-044e3a6784cf0d12471cea824721c13bc1677e29.tar.gz
ports-044e3a6784cf0d12471cea824721c13bc1677e29.zip
security/fwbuilder: Fix bad RUN_DEPENDS specification for rcs
The fwbuilder makefile specifies devel/rcs as a run dependency for FreeBSD 10 and later, but the specification is ignored on a stock FreeBSD 10.3 installed from an ISO. At some point rcs was removed before FreeBSD-10 release, but it seems to have been put back and controlled with a build knob, so it may or may not be present on FreeBSD 10 or later. Change the test from checking OSVERSION to checking for the existence of /usr/bin/rcs. It's a better chek and it fixes a potential dependency mismatch issue between the port and the built package. While here, change RUN_DEPENDS= to RUN_DEPENDS+= to avoid a potential overwrite of existing values. Approved by: infrastructure blanket (redundant deps work)
Notes
Notes: svn path=/head/; revision=419652
Diffstat (limited to 'security/fwbuilder')
-rw-r--r--security/fwbuilder/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/security/fwbuilder/Makefile b/security/fwbuilder/Makefile
index b901a1a16365..f8c14e2e8bde 100644
--- a/security/fwbuilder/Makefile
+++ b/security/fwbuilder/Makefile
@@ -4,7 +4,7 @@
PORTNAME= fwbuilder
DISTVERSION= 5.1.0
PORTVERSION= ${DISTVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
BUILD= 3599
# XXX in developement version of this port: PKGNAMESUFFIX= -devel
@@ -66,9 +66,9 @@ PORTDOCS= *
.include <bsd.port.options.mk>
-.if ${OSVERSION} >= 1000055
+.if !exists (/usr/bin/rcs)
# IMPORTANT: Newer versions of rcs will NOT work with fwbuilder.
-RUN_DEPENDS= rcs:devel/rcs57
+RUN_DEPENDS+= rcs:devel/rcs57
.endif
.if empty(PORT_OPTIONS:MDOCS)