aboutsummaryrefslogtreecommitdiff
path: root/security/fwknop
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-11-23 06:20:46 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-11-23 06:20:46 +0000
commit3743fadb61b225cc6436e84313abca7ca4207fe8 (patch)
tree887cacb5f525fbb1054eb54ab322c7b939579528 /security/fwknop
parentd84f10514cfa90c89f99e87a996d58d3cf48b713 (diff)
downloadports-3743fadb61b225cc6436e84313abca7ca4207fe8.tar.gz
ports-3743fadb61b225cc6436e84313abca7ca4207fe8.zip
Allow to select pf instead of default ipfw for firewall backend
PR: 204334 Submitted by: jan0sch@mykolab.com Reviewed by: sean.greven@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=402259
Diffstat (limited to 'security/fwknop')
-rw-r--r--security/fwknop/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/security/fwknop/Makefile b/security/fwknop/Makefile
index e41e78f918d6..067fd1a6e976 100644
--- a/security/fwknop/Makefile
+++ b/security/fwknop/Makefile
@@ -13,9 +13,16 @@ LICENSE= GPLv2
CPE_VENDOR= cipherdyne
-OPTIONS_DEFINE= GPGME
-OPTIONS_DEFAULT= GPGME
+OPTIONS_DEFINE= GPGME
+OPTIONS_SINGLE= FW
+OPTIONS_SINGLE_FW= IPFW PF
+
+OPTIONS_DEFAULT= GPGME IPFW
+
+FW_DESC= Firewall Backend
+IPFW_DESC= Use the IPFW firewall
+PF_DESC= Use the PF firewall.
GPGME_DESC= Build support for gpgme
USES= cpe libtool
@@ -27,6 +34,10 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
INFO= libfko
+IPFW_CONFIGURE_WITH= ipfw=/sbin/ipfw
+
+PF_CONFIGURE_WITH= pf=/sbin/pfctl
+
GPGME_LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme
GPGME_CONFIGURE_WITH= gpgme