aboutsummaryrefslogtreecommitdiff
path: root/security/fwlogwatch
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-06-23 20:39:23 +0000
committerPatrick Li <pat@FreeBSD.org>2002-06-23 20:39:23 +0000
commit3429beb3d69bf05cc09137cac5b420f8e26b86db (patch)
tree4affc92982e244cfbe7e05e3bdd22240b4c28520 /security/fwlogwatch
parentec8028156e7ada0e0867358c46bf5af20c16fec3 (diff)
downloadports-3429beb3d69bf05cc09137cac5b420f8e26b86db.tar.gz
ports-3429beb3d69bf05cc09137cac5b420f8e26b86db.zip
PERL -> REINPLACE_CMD
PR: ports/39729, ports/39727, ports/39726, ports/39724 PR: ports/39722, ports/39721, ports/39720, ports/39719, ports/39718 Submitted by: Scott Flatman <sf@dsinw.com>
Notes
Notes: svn path=/head/; revision=61839
Diffstat (limited to 'security/fwlogwatch')
-rw-r--r--security/fwlogwatch/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/fwlogwatch/Makefile b/security/fwlogwatch/Makefile
index 024ccfe06100..9c61f8ff6793 100644
--- a/security/fwlogwatch/Makefile
+++ b/security/fwlogwatch/Makefile
@@ -16,18 +16,19 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
+USE_REINPLACE= yes
INSTALL_TARGET= install install-config install-i18n
MANCOMPRESSES= no
MAN8= fwlogwatch.8
MAKE_ENV= MKDIR="${MKDIR}"
post-patch:
- @${PERL} -pi -e 's,/etc,${PREFIX}/etc,g; \
+ @${REINPLACE_CMD} -e 's,/etc,${PREFIX}/etc,g; \
s,/usr/local,${PREFIX},g; \
s,/usr/share,${PREFIX}/share,g; \
s,%%LOCALBASE%%,${LOCALBASE},g' \
${WRKSRC}/Makefile ${WRKSRC}/main.h
- @${PERL} -pi -e "s,/etc,${PREFIX}/etc,g" ${WRKSRC}/${MAN8}
+ @${REINPLACE_CMD} -e "s,/etc,${PREFIX}/etc,g" ${WRKSRC}/${MAN8}
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/fwlogwatch.sh.sample ${PREFIX}/etc/rc.d