aboutsummaryrefslogtreecommitdiff
path: root/security/fwlogwatch
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-07-08 19:57:36 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-07-08 19:57:36 +0000
commitdcff96bf89e0a3b906eb587481d3093eca41f2b2 (patch)
treec41217a430318a2389416992c4a1a89491e30e31 /security/fwlogwatch
parentcff1e60a5ee80e64012f62deedc085b18ba1919c (diff)
downloadports-dcff96bf89e0a3b906eb587481d3093eca41f2b2.tar.gz
ports-dcff96bf89e0a3b906eb587481d3093eca41f2b2.zip
- Add staging support
- Convert to USES=tar:bzip2
Notes
Notes: svn path=/head/; revision=361285
Diffstat (limited to 'security/fwlogwatch')
-rw-r--r--security/fwlogwatch/Makefile13
-rw-r--r--security/fwlogwatch/files/patch-Makefile12
-rw-r--r--security/fwlogwatch/pkg-plist1
3 files changed, 12 insertions, 14 deletions
diff --git a/security/fwlogwatch/Makefile b/security/fwlogwatch/Makefile
index 9e31f2133b5b..08e6aec6eff0 100644
--- a/security/fwlogwatch/Makefile
+++ b/security/fwlogwatch/Makefile
@@ -7,21 +7,18 @@ PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.kybs.de/boris/sw/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Packet filter and firewall log analyzer
-USES= gettext
-USE_BZIP2= yes
+USES= gettext tar:bzip2
MAKE_ENV= MKDIR="${MKDIR}"
INSTALL_TARGET= install install-config install-i18n
-MAN8= fwlogwatch.8
-
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e "s,/etc,${PREFIX}/etc,g" ${WRKSRC}/${MAN8}
+ @${REINPLACE_CMD} -e "s,/etc,${PREFIX}/etc,g" ${WRKSRC}/fwlogwatch.8
post-install:
- @${INSTALL_SCRIPT} ${FILESDIR}/fwlogwatch.sh.sample ${PREFIX}/etc/rc.d
+ ${INSTALL_SCRIPT} ${FILESDIR}/fwlogwatch.sh.sample \
+ ${STAGEDIR}${PREFIX}/etc/rc.d
.include <bsd.port.mk>
diff --git a/security/fwlogwatch/files/patch-Makefile b/security/fwlogwatch/files/patch-Makefile
index d232ceb179c7..e467f1b5c666 100644
--- a/security/fwlogwatch/files/patch-Makefile
+++ b/security/fwlogwatch/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Wed Mar 8 20:36:02 2006
-+++ Makefile Sat Oct 21 20:44:00 2006
+--- Makefile.orig 2006-03-08 20:36:02.000000000 +0100
++++ Makefile 2014-07-08 21:18:54.475126894 +0200
@@ -2,10 +2,10 @@
# $Id: Makefile,v 1.76 2006/03/08 19:36:02 bw Exp $
@@ -21,9 +21,9 @@
#LIBS = -L/usr/local/lib -lcrypt -lz -lintl
+CC ?= gcc
+CFLAGS += -DHAVE_ZLIB -DHAVE_GETTEXT -I${LOCALBASE}/include \
-+ -DINSTALL_DIR=\"${INSTALL_DIR}\" \
-+ -DCONF_DIR=\"${CONF_DIR}\" \
-+ -DLOCALE_DIR=\"${LOCALE_DIR}\"
++ -DINSTALL_DIR=\"${PREFIX}\" \
++ -DCONF_DIR=\"${PREFIX}/etc\" \
++ -DLOCALE_DIR=\"${PREFIX}\"
+LIBS = -L${LOCALBASE}/lib -lcrypt -lz -lintl
# You might want to add -DSHORT_NAMES to CFLAGS if you only intend to analyze
@@ -47,7 +47,7 @@
+INSTALL_PROGRAM = ${BSD_INSTALL_PROGRAM}
+INSTALL_SCRIPT = ${BSD_INSTALL_SCRIPT}
+INSTALL_DATA = ${BSD_INSTALL_DATA}
-+INSTALL_DIR = ${PREFIX}
++INSTALL_DIR = ${DESTDIR}${PREFIX}
+CONF_DIR = ${INSTALL_DIR}/etc
+LOCALE_DIR = ${INSTALL_DIR}
diff --git a/security/fwlogwatch/pkg-plist b/security/fwlogwatch/pkg-plist
index 3910a17bc4fa..8d2fc649ab69 100644
--- a/security/fwlogwatch/pkg-plist
+++ b/security/fwlogwatch/pkg-plist
@@ -1,6 +1,7 @@
etc/fwlogwatch.config
etc/fwlogwatch.template
etc/rc.d/fwlogwatch.sh.sample
+man/man8/fwlogwatch.8.gz
sbin/fwlogwatch
sbin/fwlw_notify
sbin/fwlw_respond