aboutsummaryrefslogtreecommitdiff
path: root/security/gcr
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /security/gcr
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.
Gnome 3.14.1 and Cinnamon 2.2.16 are supported on FreeBSD 9.3-RELEASE and up. This commit removes the old GNOME 2 desktop, bindings and some ports that can't be compiled. A few ports where updated to more recent versions to allow them to compile with this update. Apart from updating ports to newer versions GDM is more integrated with gnome-shell now, and handles several things for the GNOME desktop such as screen locking. If you want to use GNOME 3 via startx, you will have to add your own lock screen/screensaver. For example xscreensaver can be used for sessions started without GDM. Shell Extensions can be installed via https://extensions.gnome.org/ , we have ported a few that can't be installed via this way. The old gnome-utils and gnome-games ports where split up into single ports and where converted to meta-ports. gnome-terminal requires a UTF-8 locale to run, gdm handles this already, but if you use startx you need to do this yourself. Upgrade instructions: Delete the old and conflicting packages: # pkg delete clutter gnome-utils gnome-panel gnome-keyring vala-vapigen \ guile gcalctool gnome-media libgnomekbd # pkg delete gnome-screensaver gnome-applets bug-buddy evolution-exchange \ evolution-webcal gnome-system-tools seahorse-plugins gnome-control-center For package users the following lines will be enough: # pkg upgrade # pkg install gnome3 For ports users should do the following: # portmaster -a # portmaster x11/gnome3 We are currently aware of two issues. The first issue is a bug in the file monitoring code in the glib20 port. This bug causes glib programs to crash when files in a monitored directory are added or removed. Upstream is aware of the problem, but since the problem is quite complex there is no solution yet. This problem isn't restricted to BSD. The second issue is that on certain video cards totem will display a purple/pink overlay on the video. It not clear yet where the issues comes from. Major thanks goes to Gustau Perez for being a driving force behind getting GNOME 3 up to speed again. Also thanks to Antoine Brodin for running the exp-runs. This update was also made possible by: Joe Maloney Kris Moore Beeblebrox Ryan Lortie Antoine Jacoutot and everyone I missed
Notes
Notes: svn path=/head/; revision=372768
Diffstat (limited to 'security/gcr')
-rw-r--r--security/gcr/Makefile32
-rw-r--r--security/gcr/distinfo2
-rw-r--r--security/gcr/files/patch-Makefile.in23
-rw-r--r--security/gcr/pkg-descr5
-rw-r--r--security/gcr/pkg-plist297
5 files changed, 359 insertions, 0 deletions
diff --git a/security/gcr/Makefile b/security/gcr/Makefile
new file mode 100644
index 000000000000..98ef57abc4e4
--- /dev/null
+++ b/security/gcr/Makefile
@@ -0,0 +1,32 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/trunk/security/gcr/Makefile 20031 2014-11-02 21:47:55Z kwm $
+
+PORTNAME= gcr
+PORTVERSION= 3.14.0
+CATEGORIES= security gnome
+MASTER_SITES= GNOME
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Library for bits of crypto UI and parsing
+
+BUILD_DEPENDS= gtk-doc>0:${PORTSDIR}/textproc/gtk-doc \
+ vapigen:${PORTSDIR}/lang/vala
+LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
+ libtasn1.so:${PORTSDIR}/security/libtasn1 \
+ libp11-kit.so:${PORTSDIR}/security/p11-kit \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt
+
+CONFLICTS= gnome-keyring-2.[0-9]*
+
+USE_GNOME= gtk30 intlhack introspection:build
+USES= desktop-file-utils gettext gmake libtool pathfix \
+ pkgconfig shared-mime-info tar:xz
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+INSTALLS_ICONS= yes
+INSTALL_TARGET= install-strip
+
+GLIB_SCHEMAS= org.gnome.crypto.pgp.gschema.xml
+
+.include <bsd.port.mk>
diff --git a/security/gcr/distinfo b/security/gcr/distinfo
new file mode 100644
index 000000000000..99f2f79ddc34
--- /dev/null
+++ b/security/gcr/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gcr-3.14.0.tar.xz) = 2a2231147a01e2061f57fa9ca77557ff97bc6ceab028cee5528079f4b2fca63d
+SIZE (gcr-3.14.0.tar.xz) = 1340764
diff --git a/security/gcr/files/patch-Makefile.in b/security/gcr/files/patch-Makefile.in
new file mode 100644
index 000000000000..a4f5075229b9
--- /dev/null
+++ b/security/gcr/files/patch-Makefile.in
@@ -0,0 +1,23 @@
+From 58de2d787a31175b26687b9a228da0fb1cea5809 Mon Sep 17 00:00:00 2001
+From: Andreas Henriksson <andreas@fatal.se>
+Date: Mon, 29 Sep 2014 20:28:00 +0000
+Subject: gcr: Fix race building gdbus-codegen header and source
+
+https://bugzilla.gnome.org/show_bug.cgi?id=737622
+
+--- Makefile.in.orig 2014-11-05 22:45:22.870507566 +0100
++++ Makefile.in 2014-11-05 22:46:28.243502553 +0100
+@@ -6314,11 +6314,12 @@
+ gcr/gcr-dbus-generated.c > gcr/gcr-dbus-generated.c.tmp && \
+ mv gcr/gcr-dbus-generated.c.tmp gcr/gcr-dbus-generated.c
+
+-gcr/gcr-dbus-generated.h: gcr/gcr-dbus-generated.c
+ $(AM_V_GEN) sed -e 's/gcr_dbus/_gcr_dbus/g' \
+ gcr/gcr-dbus-generated.h > gcr/gcr-dbus-generated.h.tmp && \
+ mv gcr/gcr-dbus-generated.h.tmp gcr/gcr-dbus-generated.h
+
++gcr/gcr-dbus-generated.h: gcr/gcr-dbus-generated.c
++
+ gcr-base-$(GCR_MAJOR).pc: gcr/gcr-base.pc
+ $(AM_V_GEN) cp gcr/gcr-base.pc gcr-base-$(GCR_MAJOR).pc
+
diff --git a/security/gcr/pkg-descr b/security/gcr/pkg-descr
new file mode 100644
index 000000000000..5560b6690c45
--- /dev/null
+++ b/security/gcr/pkg-descr
@@ -0,0 +1,5 @@
+Gcr is a library for bits of crypto and security UI, parsing etc. It used
+to be part of gnome-keyring. It also provides a viewer and importer for
+certificates and private keys.
+
+WWW: https://live.gnome.org/GnomeKeyring
diff --git a/security/gcr/pkg-plist b/security/gcr/pkg-plist
new file mode 100644
index 000000000000..2c3681d4c02f
--- /dev/null
+++ b/security/gcr/pkg-plist
@@ -0,0 +1,297 @@
+bin/gcr-viewer
+include/gck-1/gck/gck-deprecated.h
+include/gck-1/gck/gck-enum-types.h
+include/gck-1/gck/gck-version.h
+include/gck-1/gck/gck.h
+include/gck-1/gck/pkcs11.h
+include/gck-1/gck/pkcs11n.h
+include/gck-1/gck/pkcs11x.h
+include/gcr-3/gcr/gcr-base.h
+include/gcr-3/gcr/gcr-certificate-chain.h
+include/gcr-3/gcr/gcr-certificate-request.h
+include/gcr-3/gcr/gcr-certificate.h
+include/gcr-3/gcr/gcr-collection.h
+include/gcr-3/gcr/gcr-column.h
+include/gcr-3/gcr/gcr-comparable.h
+include/gcr-3/gcr/gcr-deprecated-base.h
+include/gcr-3/gcr/gcr-enum-types-base.h
+include/gcr-3/gcr/gcr-filter-collection.h
+include/gcr-3/gcr/gcr-fingerprint.h
+include/gcr-3/gcr/gcr-icons.h
+include/gcr-3/gcr/gcr-import-interaction.h
+include/gcr-3/gcr/gcr-importer.h
+include/gcr-3/gcr/gcr-library.h
+include/gcr-3/gcr/gcr-mock-prompter.h
+include/gcr-3/gcr/gcr-parser.h
+include/gcr-3/gcr/gcr-pkcs11-certificate.h
+include/gcr-3/gcr/gcr-prompt.h
+include/gcr-3/gcr/gcr-secret-exchange.h
+include/gcr-3/gcr/gcr-secure-memory.h
+include/gcr-3/gcr/gcr-simple-certificate.h
+include/gcr-3/gcr/gcr-simple-collection.h
+include/gcr-3/gcr/gcr-system-prompt.h
+include/gcr-3/gcr/gcr-system-prompter.h
+include/gcr-3/gcr/gcr-trust.h
+include/gcr-3/gcr/gcr-types.h
+include/gcr-3/gcr/gcr-union-collection.h
+include/gcr-3/gcr/gcr-unlock-options.h
+include/gcr-3/gcr/gcr-version.h
+include/gcr-3/gcr/gcr.h
+include/gcr-3/ui/gcr-certificate-basics-widget.h
+include/gcr-3/ui/gcr-certificate-details-widget.h
+include/gcr-3/ui/gcr-certificate-renderer.h
+include/gcr-3/ui/gcr-certificate-widget.h
+include/gcr-3/ui/gcr-collection-model.h
+include/gcr-3/ui/gcr-combo-selector.h
+include/gcr-3/ui/gcr-deprecated.h
+include/gcr-3/ui/gcr-enum-types.h
+include/gcr-3/ui/gcr-failure-renderer.h
+include/gcr-3/ui/gcr-import-button.h
+include/gcr-3/ui/gcr-key-renderer.h
+include/gcr-3/ui/gcr-key-widget.h
+include/gcr-3/ui/gcr-list-selector.h
+include/gcr-3/ui/gcr-prompt-dialog.h
+include/gcr-3/ui/gcr-renderer.h
+include/gcr-3/ui/gcr-secure-entry-buffer.h
+include/gcr-3/ui/gcr-tree-selector.h
+include/gcr-3/ui/gcr-ui.h
+include/gcr-3/ui/gcr-unlock-options-widget.h
+include/gcr-3/ui/gcr-viewer-widget.h
+include/gcr-3/ui/gcr-viewer.h
+lib/girepository-1.0/Gck-1.typelib
+lib/girepository-1.0/Gcr-3.typelib
+lib/girepository-1.0/GcrUi-3.typelib
+lib/libgck-1.so
+lib/libgck-1.so.0
+lib/libgck-1.so.0.0.0
+lib/libgcr-3.so
+lib/libgcr-3.so.1
+lib/libgcr-3.so.1.0.0
+lib/libgcr-base-3.so
+lib/libgcr-base-3.so.1
+lib/libgcr-base-3.so.1.0.0
+lib/libgcr-ui-3.so
+lib/libgcr-ui-3.so.1
+lib/libgcr-ui-3.so.1.0.0
+libdata/pkgconfig/gck-1.pc
+libdata/pkgconfig/gcr-3.pc
+libdata/pkgconfig/gcr-base-3.pc
+libdata/pkgconfig/gcr-ui-3.pc
+libexec/gcr-prompter
+share/GConf/gsettings/org.gnome.crypto.pgp.convert
+share/GConf/gsettings/org.gnome.crypto.pgp_keyservers.convert
+share/applications/gcr-prompter.desktop
+share/applications/gcr-viewer.desktop
+share/dbus-1/services/org.gnome.keyring.PrivatePrompter.service
+share/dbus-1/services/org.gnome.keyring.SystemPrompter.service
+share/gcr-3/ui/gcr-pkcs11-import-dialog.ui
+share/gcr-3/ui/gcr-unlock-options-widget.ui
+share/gir-1.0/Gck-1.gir
+share/gir-1.0/Gcr-3.gir
+share/gir-1.0/GcrUi-3.gir
+share/gtk-doc/html/gck/GckAttributes.html
+share/gtk-doc/html/gck/GckEnumerator.html
+share/gtk-doc/html/gck/GckModule.html
+share/gtk-doc/html/gck/GckObject.html
+share/gtk-doc/html/gck/GckObjectCache.html
+share/gtk-doc/html/gck/GckSession.html
+share/gtk-doc/html/gck/GckSlot.html
+share/gtk-doc/html/gck/annotation-glossary.html
+share/gtk-doc/html/gck/gck-Errors.html
+share/gtk-doc/html/gck/gck-GckAttribute.html
+share/gtk-doc/html/gck/gck-GckModule-lists.html
+share/gtk-doc/html/gck/gck-Library-Utilities.html
+share/gtk-doc/html/gck/gck-Miscellaneous-Functions.html
+share/gtk-doc/html/gck/gck-PKCS11-URIs.html
+share/gtk-doc/html/gck/gck.devhelp2
+share/gtk-doc/html/gck/home.png
+share/gtk-doc/html/gck/index.html
+share/gtk-doc/html/gck/index.sgml
+share/gtk-doc/html/gck/left-insensitive.png
+share/gtk-doc/html/gck/left.png
+share/gtk-doc/html/gck/pkcs11-links.html
+share/gtk-doc/html/gck/reference.html
+share/gtk-doc/html/gck/right-insensitive.png
+share/gtk-doc/html/gck/right.png
+share/gtk-doc/html/gck/style.css
+share/gtk-doc/html/gck/up-insensitive.png
+share/gtk-doc/html/gck/up.png
+share/gtk-doc/html/gcr-3/GcrCertificate.html
+share/gtk-doc/html/gcr-3/GcrCertificateChain.html
+share/gtk-doc/html/gcr-3/GcrCertificateWidget.html
+share/gtk-doc/html/gcr-3/GcrCollection.html
+share/gtk-doc/html/gcr-3/GcrCollectionModel.html
+share/gtk-doc/html/gcr-3/GcrComboSelector.html
+share/gtk-doc/html/gcr-3/GcrComparable.html
+share/gtk-doc/html/gcr-3/GcrImportButton.html
+share/gtk-doc/html/gcr-3/GcrImporter.html
+share/gtk-doc/html/gcr-3/GcrKeyWidget.html
+share/gtk-doc/html/gcr-3/GcrListSelector.html
+share/gtk-doc/html/gcr-3/GcrParser.html
+share/gtk-doc/html/gcr-3/GcrPkcs11Certificate.html
+share/gtk-doc/html/gcr-3/GcrPrompt.html
+share/gtk-doc/html/gcr-3/GcrPromptDialog.html
+share/gtk-doc/html/gcr-3/GcrRenderer.html
+share/gtk-doc/html/gcr-3/GcrSecretExchange.html
+share/gtk-doc/html/gcr-3/GcrSecureEntryBuffer.html
+share/gtk-doc/html/gcr-3/GcrSimpleCertificate.html
+share/gtk-doc/html/gcr-3/GcrSimpleCollection.html
+share/gtk-doc/html/gcr-3/GcrSystemPrompt.html
+share/gtk-doc/html/gcr-3/GcrSystemPrompter.html
+share/gtk-doc/html/gcr-3/GcrTreeSelector.html
+share/gtk-doc/html/gcr-3/GcrViewer.html
+share/gtk-doc/html/gcr-3/GcrViewerWidget.html
+share/gtk-doc/html/gcr-3/annotation-glossary.html
+share/gtk-doc/html/gcr-3/certificate-widget.png
+share/gtk-doc/html/gcr-3/certificates.html
+share/gtk-doc/html/gcr-3/ch01.html
+share/gtk-doc/html/gcr-3/collections.html
+share/gtk-doc/html/gcr-3/combo-selector.png
+share/gtk-doc/html/gcr-3/gcr-3.devhelp2
+share/gtk-doc/html/gcr-3/gcr-GcrCertificateRequest.html
+share/gtk-doc/html/gcr-3/gcr-GcrColumn.html
+share/gtk-doc/html/gcr-3/gcr-GcrImportInteraction.html
+share/gtk-doc/html/gcr-3/gcr-Key-Fingerprints.html
+share/gtk-doc/html/gcr-3/gcr-Library-PKCS#11.html
+share/gtk-doc/html/gcr-3/gcr-Library-Utilities.html
+share/gtk-doc/html/gcr-3/gcr-Non-pageable-Memory.html
+share/gtk-doc/html/gcr-3/gcr-Trust-Storage-and-Lookups.html
+share/gtk-doc/html/gcr-3/home.png
+share/gtk-doc/html/gcr-3/import-button.png
+share/gtk-doc/html/gcr-3/index.html
+share/gtk-doc/html/gcr-3/index.sgml
+share/gtk-doc/html/gcr-3/key-widget.png
+share/gtk-doc/html/gcr-3/left-insensitive.png
+share/gtk-doc/html/gcr-3/left.png
+share/gtk-doc/html/gcr-3/list-selector.png
+share/gtk-doc/html/gcr-3/misc.html
+share/gtk-doc/html/gcr-3/prompts.html
+share/gtk-doc/html/gcr-3/right-insensitive.png
+share/gtk-doc/html/gcr-3/right.png
+share/gtk-doc/html/gcr-3/storage.html
+share/gtk-doc/html/gcr-3/style.css
+share/gtk-doc/html/gcr-3/tree-selector.png
+share/gtk-doc/html/gcr-3/up-insensitive.png
+share/gtk-doc/html/gcr-3/up.png
+share/gtk-doc/html/gcr-3/viewer-widget.png
+share/gtk-doc/html/gcr-3/widgets.html
+share/icons/hicolor/16x16/apps/gcr-gnupg.png
+share/icons/hicolor/16x16/apps/gcr-key-pair.png
+share/icons/hicolor/16x16/apps/gcr-key.png
+share/icons/hicolor/16x16/apps/gcr-password.png
+share/icons/hicolor/16x16/apps/gcr-smart-card.png
+share/icons/hicolor/22x22/apps/gcr-gnupg.png
+share/icons/hicolor/22x22/apps/gcr-key-pair.png
+share/icons/hicolor/22x22/apps/gcr-key.png
+share/icons/hicolor/22x22/apps/gcr-password.png
+share/icons/hicolor/22x22/apps/gcr-smart-card.png
+share/icons/hicolor/24x24/apps/gcr-gnupg.png
+share/icons/hicolor/24x24/apps/gcr-key-pair.png
+share/icons/hicolor/24x24/apps/gcr-key.png
+share/icons/hicolor/24x24/apps/gcr-password.png
+share/icons/hicolor/24x24/apps/gcr-smart-card.png
+share/icons/hicolor/256x256/apps/gcr-gnupg.png
+share/icons/hicolor/256x256/apps/gcr-password.png
+share/icons/hicolor/256x256/apps/gcr-smart-card.png
+share/icons/hicolor/32x32/apps/gcr-gnupg.png
+share/icons/hicolor/32x32/apps/gcr-key-pair.png
+share/icons/hicolor/32x32/apps/gcr-key.png
+share/icons/hicolor/32x32/apps/gcr-password.png
+share/icons/hicolor/32x32/apps/gcr-smart-card.png
+share/icons/hicolor/48x48/apps/gcr-gnupg.png
+share/icons/hicolor/48x48/apps/gcr-key-pair.png
+share/icons/hicolor/48x48/apps/gcr-key.png
+share/icons/hicolor/48x48/apps/gcr-password.png
+share/icons/hicolor/48x48/apps/gcr-smart-card.png
+share/locale/af/LC_MESSAGES/gcr.mo
+share/locale/ar/LC_MESSAGES/gcr.mo
+share/locale/as/LC_MESSAGES/gcr.mo
+share/locale/ast/LC_MESSAGES/gcr.mo
+share/locale/az/LC_MESSAGES/gcr.mo
+share/locale/be/LC_MESSAGES/gcr.mo
+share/locale/be@latin/LC_MESSAGES/gcr.mo
+share/locale/bg/LC_MESSAGES/gcr.mo
+share/locale/bn/LC_MESSAGES/gcr.mo
+share/locale/bn_IN/LC_MESSAGES/gcr.mo
+share/locale/bs/LC_MESSAGES/gcr.mo
+share/locale/ca/LC_MESSAGES/gcr.mo
+share/locale/ca@valencia/LC_MESSAGES/gcr.mo
+share/locale/cs/LC_MESSAGES/gcr.mo
+share/locale/cy/LC_MESSAGES/gcr.mo
+share/locale/da/LC_MESSAGES/gcr.mo
+share/locale/de/LC_MESSAGES/gcr.mo
+share/locale/dz/LC_MESSAGES/gcr.mo
+share/locale/el/LC_MESSAGES/gcr.mo
+share/locale/en@shaw/LC_MESSAGES/gcr.mo
+share/locale/en_CA/LC_MESSAGES/gcr.mo
+share/locale/en_GB/LC_MESSAGES/gcr.mo
+share/locale/eo/LC_MESSAGES/gcr.mo
+share/locale/es/LC_MESSAGES/gcr.mo
+share/locale/et/LC_MESSAGES/gcr.mo
+share/locale/eu/LC_MESSAGES/gcr.mo
+share/locale/fa/LC_MESSAGES/gcr.mo
+share/locale/fi/LC_MESSAGES/gcr.mo
+share/locale/fr/LC_MESSAGES/gcr.mo
+share/locale/ga/LC_MESSAGES/gcr.mo
+share/locale/gl/LC_MESSAGES/gcr.mo
+share/locale/gu/LC_MESSAGES/gcr.mo
+share/locale/he/LC_MESSAGES/gcr.mo
+share/locale/hi/LC_MESSAGES/gcr.mo
+share/locale/hr/LC_MESSAGES/gcr.mo
+share/locale/hu/LC_MESSAGES/gcr.mo
+share/locale/id/LC_MESSAGES/gcr.mo
+share/locale/is/LC_MESSAGES/gcr.mo
+share/locale/it/LC_MESSAGES/gcr.mo
+share/locale/ja/LC_MESSAGES/gcr.mo
+share/locale/ka/LC_MESSAGES/gcr.mo
+share/locale/kn/LC_MESSAGES/gcr.mo
+share/locale/ko/LC_MESSAGES/gcr.mo
+share/locale/lt/LC_MESSAGES/gcr.mo
+share/locale/lv/LC_MESSAGES/gcr.mo
+share/locale/mai/LC_MESSAGES/gcr.mo
+share/locale/mg/LC_MESSAGES/gcr.mo
+share/locale/mk/LC_MESSAGES/gcr.mo
+share/locale/ml/LC_MESSAGES/gcr.mo
+share/locale/mn/LC_MESSAGES/gcr.mo
+share/locale/mr/LC_MESSAGES/gcr.mo
+share/locale/ms/LC_MESSAGES/gcr.mo
+share/locale/nb/LC_MESSAGES/gcr.mo
+share/locale/ne/LC_MESSAGES/gcr.mo
+share/locale/nl/LC_MESSAGES/gcr.mo
+share/locale/nn/LC_MESSAGES/gcr.mo
+share/locale/oc/LC_MESSAGES/gcr.mo
+share/locale/or/LC_MESSAGES/gcr.mo
+share/locale/pa/LC_MESSAGES/gcr.mo
+share/locale/pl/LC_MESSAGES/gcr.mo
+share/locale/pt/LC_MESSAGES/gcr.mo
+share/locale/pt_BR/LC_MESSAGES/gcr.mo
+share/locale/ro/LC_MESSAGES/gcr.mo
+share/locale/ru/LC_MESSAGES/gcr.mo
+share/locale/rw/LC_MESSAGES/gcr.mo
+share/locale/si/LC_MESSAGES/gcr.mo
+share/locale/sk/LC_MESSAGES/gcr.mo
+share/locale/sl/LC_MESSAGES/gcr.mo
+share/locale/sq/LC_MESSAGES/gcr.mo
+share/locale/sr/LC_MESSAGES/gcr.mo
+share/locale/sr@latin/LC_MESSAGES/gcr.mo
+share/locale/sv/LC_MESSAGES/gcr.mo
+share/locale/ta/LC_MESSAGES/gcr.mo
+share/locale/te/LC_MESSAGES/gcr.mo
+share/locale/th/LC_MESSAGES/gcr.mo
+share/locale/tg/LC_MESSAGES/gcr.mo
+share/locale/tr/LC_MESSAGES/gcr.mo
+share/locale/ug/LC_MESSAGES/gcr.mo
+share/locale/uk/LC_MESSAGES/gcr.mo
+share/locale/vi/LC_MESSAGES/gcr.mo
+share/locale/xh/LC_MESSAGES/gcr.mo
+share/locale/zh_CN/LC_MESSAGES/gcr.mo
+share/locale/zh_HK/LC_MESSAGES/gcr.mo
+share/locale/zh_TW/LC_MESSAGES/gcr.mo
+share/mime/packages/gcr-crypto-types.xml
+share/vala/vapi/gck-1.deps
+share/vala/vapi/gck-1.vapi
+share/vala/vapi/gcr-3.deps
+share/vala/vapi/gcr-3.vapi
+share/vala/vapi/gcr-ui-3.deps
+share/vala/vapi/gcr-ui-3.vapi
+share/vala/vapi/pkcs11.vapi