aboutsummaryrefslogtreecommitdiff
path: root/security/gnomint
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-07-23 09:54:02 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-07-23 09:54:02 +0000
commit3ab1b8443ec60e4983c4666f0e84cedab20e81d2 (patch)
treed13723a66084b6936010f3cea6404da7bbcf103b /security/gnomint
parent63d0ab27e8fc88df6e11d9fb8b37620420285dd1 (diff)
downloadports-3ab1b8443ec60e4983c4666f0e84cedab20e81d2.tar.gz
ports-3ab1b8443ec60e4983c4666f0e84cedab20e81d2.zip
- Replace security/gnutls with security/gnutls3 and update to 3.2.15
- Bump PORTREVISION on all ports that depend on security/gnutls and adjust all ports that depend on security/gnutls3 - Update mail/anubis to version 4.2 which supports gnutls 3.x - Update mail/libvmime to a development snapshot (recommended by upstream developers) PR: 191274 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=362645
Diffstat (limited to 'security/gnomint')
-rw-r--r--security/gnomint/Makefile5
-rw-r--r--security/gnomint/files/patch-src__import.c29
2 files changed, 32 insertions, 2 deletions
diff --git a/security/gnomint/Makefile b/security/gnomint/Makefile
index 76a12cc403ad..fce89b2521a4 100644
--- a/security/gnomint/Makefile
+++ b/security/gnomint/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnomint
PORTVERSION= 1.2.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security
MASTER_SITES= SF
@@ -23,7 +23,8 @@ GNU_CONFIGURE= yes
USES= gmake perl5 pkgconfig readline
USE_GNOME= gconf2 gdkpixbuf2 glib20 gtk20
-CFLAGS:= ${CFLAGS:C/-Werror//}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
diff --git a/security/gnomint/files/patch-src__import.c b/security/gnomint/files/patch-src__import.c
new file mode 100644
index 000000000000..9b980148722b
--- /dev/null
+++ b/security/gnomint/files/patch-src__import.c
@@ -0,0 +1,29 @@
+--- src/import.c.orig 2010-05-31 23:01:37.000000000 +0200
++++ src/import.c 2014-07-22 16:11:44.000000000 +0200
+@@ -695,7 +695,7 @@
+
+ // After having all the parts unencrypted, we import all certificates first.
+ for (i=0; i<n_bags; i++) {
+- gnutls_pkcs12_bag * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
++ gnutls_pkcs12_bag_t * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
+ guint num_elements_in_bag = gnutls_pkcs12_bag_get_count (*pkcs12_bag);
+
+ for (i=0; i < num_elements_in_bag; i++) {
+@@ -722,7 +722,7 @@
+
+ // Then, we import all PKCS8 private keys.
+ for (i=0; i<n_bags; i++) {
+- gnutls_pkcs12_bag * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
++ gnutls_pkcs12_bag_t * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
+ guint num_elements_in_bag = gnutls_pkcs12_bag_get_count (*pkcs12_bag);
+
+ for (i=0; i < num_elements_in_bag; i++) {
+@@ -796,7 +796,7 @@
+ // Then we import the CRLs
+
+ for (i=0; i<n_bags; i++) {
+- gnutls_pkcs12_bag * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
++ gnutls_pkcs12_bag_t * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
+ guint num_elements_in_bag = gnutls_pkcs12_bag_get_count (*pkcs12_bag);
+
+ for (i=0; i < num_elements_in_bag; i++) {