aboutsummaryrefslogtreecommitdiff
path: root/security/gnupg1/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
commit0b881b0ecebc9440a559f1c2b27758488a1188fa (patch)
tree933fd11da647dda8c169bc24693094174bdc0355 /security/gnupg1/Makefile
parent928d434bd206738b7213dd9b5802c680794a9b10 (diff)
downloadports-0b881b0ecebc9440a559f1c2b27758488a1188fa.tar.gz
ports-0b881b0ecebc9440a559f1c2b27758488a1188fa.zip
Notes
Diffstat (limited to 'security/gnupg1/Makefile')
-rw-r--r--security/gnupg1/Makefile35
1 files changed, 16 insertions, 19 deletions
diff --git a/security/gnupg1/Makefile b/security/gnupg1/Makefile
index 828ce2806e28..3d120fe1c0bc 100644
--- a/security/gnupg1/Makefile
+++ b/security/gnupg1/Makefile
@@ -1,5 +1,4 @@
# $FreeBSD$
-# Created by: kuriyama@FreeBSD.org
PORTNAME= gnupg
PORTVERSION= 1.4.13
@@ -28,14 +27,15 @@ LATEST_LINK= gnupg1
PORTDOCS= *
-OPTIONS= LDAP "LDAP keyserver interface" off \
- LIBICONV "use libiconv" off \
- LIBUSB "use libusb" off \
- SUID_GPG "install GPG with suid" off \
- NLS "Native Language Support" on \
- CURL "use libcurl for the keyserver interface" on
+OPTIONS_DEFINE= LDAP LIBICONV LIBUSB SUID_GPG NLS CURL DOCS
+OPTIONS_DEFAULT= CURL
+LDAP_DESC= LDAP keyserver interface
+LIBICONV_DESC= use libiconv
+LIBUSB_DESC= use libusb
+SUID_GPG_DESC= install GPG with suid
+CURL_DESC= use libcurl for the keyserver interface
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${CC} == "clang" || ${OSVERSION} >= 1000024
CFLAGS:= ${CFLAGS:S/$/ -std=c89/}
@@ -44,22 +44,19 @@ CFLAGS:= ${CFLAGS:S/$/ -fheinous-gnu-extensions/}
.endif
.endif
-.if defined(WITH_LIBICONV)
+.if ${PORT_OPTIONS:MLIBICONV}
USES+= iconv
.else
CONFIGURE_ARGS+= --without-libiconv-prefix
.endif
-.if defined(WITH_LIBUSB)
+.if ${PORT_OPTIONS:MLIBUSB}
CONFIGURE_ARGS+= --with-libusb=${LOCALBASE}
-. if ${OSVERSION} < 800069
-LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
-. endif
.else
CONFIGURE_ARGS+= --without-libusb
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
PLIST_SUB+= WITH_LDAP=""
CONFIGURE_ARGS+= --with-ldap=${LOCALBASE}
@@ -69,7 +66,7 @@ PLIST_SUB+= WITH_LDAP="@comment "
CONFIGURE_ARGS+= --disable-ldap
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= YES
PLIST_SUB+= NLS=""
.else
@@ -77,7 +74,7 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if !defined(WITHOUT_CURL)
+.if ${PORT_OPTIONS:MCURL}
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+=--with-libcurl=${LOCALBASE}
# Work around a GnuPG configure buglet
@@ -87,7 +84,7 @@ CONFIGURE_ARGS+=--without-libcurl
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for i in DETAILS FAQ HACKING OpenPGP
${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}
@@ -97,11 +94,11 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
-.if defined(WITH_SUID_GPG)
+.if ${PORT_OPTIONS:MSUID_GPG}
${CHMOD} u+s ${PREFIX}/bin/gpg
.endif
check:
(cd ${WRKSRC}; ${MAKE} check)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>