aboutsummaryrefslogtreecommitdiff
path: root/security/go-cve-dictionary
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2019-09-29 22:31:57 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2019-09-29 22:31:57 +0000
commit67c4b925b7fd606361a2152563b80da493232dfb (patch)
tree16884a4188ae95c6d4b3c8e73cfaf24404fd28e8 /security/go-cve-dictionary
parent34156e93e84fe00711fac9dbf19e33534dc665f9 (diff)
downloadports-67c4b925b7fd606361a2152563b80da493232dfb.tar.gz
ports-67c4b925b7fd606361a2152563b80da493232dfb.zip
Go ports: cleanup, finish transition to USES=go started with r505321 (cat. misc-shells)
- Remove custom build/install targets left in place after r505321 - Switch to the new GO_TARGET tuple syntax introduced in r512001 - Switch to go:modules when upstream already uses them Reviewed by: tobik Approved by: araujo (mentor), portmgr (adamw) Differential Revision: https://reviews.freebsd.org/D21743
Notes
Notes: svn path=/head/; revision=513275
Diffstat (limited to 'security/go-cve-dictionary')
-rw-r--r--security/go-cve-dictionary/Makefile75
1 files changed, 35 insertions, 40 deletions
diff --git a/security/go-cve-dictionary/Makefile b/security/go-cve-dictionary/Makefile
index a48853951a49..27887eba3893 100644
--- a/security/go-cve-dictionary/Makefile
+++ b/security/go-cve-dictionary/Makefile
@@ -20,34 +20,36 @@ USE_GITHUB= yes
GH_ACCOUNT= kotakanbe
GH_SUBDIR= src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}
-GH_TUPLE+= VividCortex:ewma:v1.1.1:ewma/src/gopkg.in/VividCortex/ewma.v1
-GH_TUPLE+= asaskevich:govalidator:v9:govalidator/src/github.com/asaskevich/govalidator
-GH_TUPLE+= cheggaaa:pb:v2.0.6:pb/src/gopkg.in/cheggaaa/pb.v2
-GH_TUPLE+= dgrijalva:jwt-go:v3.2.0:jwtgo/src/github.com/dgrijalva/jwt-go
-GH_TUPLE+= fatih:color:v1.7.0:colorv1/src/github.com/fatih/color
-GH_TUPLE+= go-redis:redis:v6.13.2:redis/src/github.com/go-redis/redis
-GH_TUPLE+= go-sql-driver:mysql:v1.4.0:mysql/src/github.com/go-sql-driver/mysql
-GH_TUPLE+= go-stack:stack:v1.7.0:gostack/src/github.com/go-stack/stack
-GH_TUPLE+= golang:crypto:f027049:golangcrypto/src/golang.org/x/crypto
-GH_TUPLE+= golang:sys:acbc56f:golangsys/src/golang.org/x/sys
-GH_TUPLE+= google:subcommands:5bae204:subcommands/src/github.com/google/subcommands
-GH_TUPLE+= hashicorp:go-version:270f2f7:goversion/src/github.com/hashicorp/go-version
-GH_TUPLE+= inconshreveable:log15:v2.13:log15/src/github.com/inconshreveable/log15
-GH_TUPLE+= jinzhu:gorm:v1.9.1:gorm/src/github.com/jinzhu/gorm
-GH_TUPLE+= jinzhu:inflection:0414036:inflection/src/github.com/jinzhu/inflection
-GH_TUPLE+= k0kubun:pp:v2.3.0:pp/src/github.com/k0kubun/pp
-GH_TUPLE+= knqyf263:go-cpe:659663f:gocpe/src/github.com/knqyf263/go-cpe
-GH_TUPLE+= htcat:htcat:v1.0.2:htcat/src/github.com/htcat/htcat
-GH_TUPLE+= labstack:echo:6d227df:echo/src/github.com/labstack/echo
-GH_TUPLE+= labstack:gommon:0.2.6:gommon/src/github.com/labstack/gommon
-GH_TUPLE+= lib:pq:90697d6:pq/src/github.com/lib/pq
-GH_TUPLE+= mattn:go-colorable:v0.0.9:gocolorable/src/github.com/mattn/go-colorable
-GH_TUPLE+= mattn:go-isatty:v0.0.3:goisatty/src/github.com/mattn/go-isatty
-GH_TUPLE+= mattn:go-runewidth:v0.0.2:gorunewidth/src/github.com/mattn/go-runewidth
-GH_TUPLE+= mattn:go-sqlite3:v1.9.0:gosqlite3/src/github.com/mattn/go-sqlite3
-GH_TUPLE+= olekukonko:tablewriter:d4647c9:tablewriter/src/github.com/olekukonko/tablewriter
-GH_TUPLE+= pkg:errors:v0.8.0:pkgerrors/src/github.com/pkg/errors
-GH_TUPLE+= valyala:fasttemplate:dcecefd:fasttemplate/src/github.com/valyala/fasttemplate
+GH_TUPLE+= VividCortex:ewma:v1.1.1:ewma/vendor/gopkg.in/VividCortex/ewma.v1
+GH_TUPLE+= asaskevich:govalidator:v9:govalidator/vendor/github.com/asaskevich/govalidator
+GH_TUPLE+= cheggaaa:pb:v2.0.6:pb/vendor/gopkg.in/cheggaaa/pb.v2
+GH_TUPLE+= dgrijalva:jwt-go:v3.2.0:jwtgo/vendor/github.com/dgrijalva/jwt-go
+GH_TUPLE+= fatih:color:v1.7.0:colorv1/vendor/github.com/fatih/color
+GH_TUPLE+= go-redis:redis:v6.13.2:redis/vendor/github.com/go-redis/redis
+GH_TUPLE+= go-sql-driver:mysql:v1.4.0:mysql/vendor/github.com/go-sql-driver/mysql
+GH_TUPLE+= go-stack:stack:v1.7.0:gostack/vendor/github.com/go-stack/stack
+GH_TUPLE+= golang:crypto:f027049:golangcrypto/vendor/golang.org/x/crypto
+GH_TUPLE+= golang:sys:acbc56f:golangsys/vendor/golang.org/x/sys
+GH_TUPLE+= google:subcommands:5bae204:subcommands/vendor/github.com/google/subcommands
+GH_TUPLE+= hashicorp:go-version:270f2f7:goversion/vendor/github.com/hashicorp/go-version
+GH_TUPLE+= inconshreveable:log15:v2.13:log15/vendor/github.com/inconshreveable/log15
+GH_TUPLE+= jinzhu:gorm:v1.9.1:gorm/vendor/github.com/jinzhu/gorm
+GH_TUPLE+= jinzhu:inflection:0414036:inflection/vendor/github.com/jinzhu/inflection
+GH_TUPLE+= k0kubun:pp:v2.3.0:pp/vendor/github.com/k0kubun/pp
+GH_TUPLE+= knqyf263:go-cpe:659663f:gocpe/vendor/github.com/knqyf263/go-cpe
+GH_TUPLE+= htcat:htcat:v1.0.2:htcat/vendor/github.com/htcat/htcat
+GH_TUPLE+= labstack:echo:6d227df:echo/vendor/github.com/labstack/echo
+GH_TUPLE+= labstack:gommon:0.2.6:gommon/vendor/github.com/labstack/gommon
+GH_TUPLE+= lib:pq:90697d6:pq/vendor/github.com/lib/pq
+GH_TUPLE+= mattn:go-colorable:v0.0.9:gocolorable/vendor/github.com/mattn/go-colorable
+GH_TUPLE+= mattn:go-isatty:v0.0.3:goisatty/vendor/github.com/mattn/go-isatty
+GH_TUPLE+= mattn:go-runewidth:v0.0.2:gorunewidth/vendor/github.com/mattn/go-runewidth
+GH_TUPLE+= mattn:go-sqlite3:v1.9.0:gosqlite3/vendor/github.com/mattn/go-sqlite3
+GH_TUPLE+= olekukonko:tablewriter:d4647c9:tablewriter/vendor/github.com/olekukonko/tablewriter
+GH_TUPLE+= pkg:errors:v0.8.0:pkgerrors/vendor/github.com/pkg/errors
+GH_TUPLE+= valyala:fasttemplate:dcecefd:fasttemplate/vendor/github.com/valyala/fasttemplate
+
+GO_BUILDFLAGS= -ldflags "-X main.version=${PORTVERSION}"
USERS= vuls
GROUPS= vuls
@@ -60,22 +62,15 @@ post-patch:
${WRKSRC}/db/rdb.go \
${WRKSRC}/db/redis.go
@${REINPLACE_CMD} -e 's|gopkg.in/mattn/go-runewidth.v0|github.com/mattn/go-runewidth|' \
- ${WRKSRC}/src/gopkg.in/cheggaaa/pb.v2/util.go
+ ${WRKSRC}/vendor/gopkg.in/cheggaaa/pb.v2/util.go
@${REINPLACE_CMD} -e 's|gopkg.in/mattn/go-colorable.v0|github.com/mattn/go-colorable|' \
- ${WRKSRC}/src/gopkg.in/cheggaaa/pb.v2/pb.go
+ ${WRKSRC}/vendor/gopkg.in/cheggaaa/pb.v2/pb.go
@${REINPLACE_CMD} -e 's|gopkg.in/mattn/go-isatty.v0|github.com/mattn/go-isatty|' \
- ${WRKSRC}/src/gopkg.in/cheggaaa/pb.v2/pb.go
+ ${WRKSRC}/vendor/gopkg.in/cheggaaa/pb.v2/pb.go
@${REINPLACE_CMD} -e 's|gopkg.in/fatih/color.v1|github.com/fatih/color|' \
- ${WRKSRC}/src/gopkg.in/cheggaaa/pb.v2/template.go
-
-do-build:
- @cd ${GO_WRKSRC} && \
- ${SETENV} ${MAKE_ENV} ${GO_ENV} GOPATH=${WRKSRC} \
- ${GO_CMD} build -v -x -ldflags "-X main.version=${PORTVERSION}" \
- -o ${WRKSRC}/${PORTNAME}
+ ${WRKSRC}/vendor/gopkg.in/cheggaaa/pb.v2/template.go
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+post-install:
${MKDIR} ${STAGEDIR}/var/db/vuls
${MKDIR} ${STAGEDIR}/var/log/vuls