aboutsummaryrefslogtreecommitdiff
path: root/security/go.crypto/Makefile
diff options
context:
space:
mode:
authorJulien Laffaye <jlaffaye@FreeBSD.org>2012-05-14 22:07:50 +0000
committerJulien Laffaye <jlaffaye@FreeBSD.org>2012-05-14 22:07:50 +0000
commit5bbc442ee2212835e09afa36884d83ef074ba991 (patch)
treed5fa5a07b9612748745d9073939f466223ae1a08 /security/go.crypto/Makefile
parent0870d6a0ec1c49b4a82d61c950819056826ac6b0 (diff)
downloadports-5bbc442ee2212835e09afa36884d83ef074ba991.tar.gz
ports-5bbc442ee2212835e09afa36884d83ef074ba991.zip
Notes
Diffstat (limited to 'security/go.crypto/Makefile')
-rw-r--r--security/go.crypto/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/security/go.crypto/Makefile b/security/go.crypto/Makefile
new file mode 100644
index 000000000000..d3fcedf9b8e7
--- /dev/null
+++ b/security/go.crypto/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: go.crypto
+# Date created: 2012-05-03
+# Whom: Julien Laffaye <jlaffaye@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= go.crypto
+PORTVERSION= 20120503
+CATEGORIES= security devel
+MASTER_SITES= http://jlaffaye.net/ LOCAL/jlaffaye
+
+MAINTAINER= jlaffaye@FreeBSD.org
+COMMENT= Additional cryptography packages for Go
+
+GO_PKGNAME= code.google.com/p/go.crypto
+GO_TARGET= ${GO_PKGNAME}/bcrypt \
+ ${GO_PKGNAME}/blowfish \
+ ${GO_PKGNAME}/cast5 \
+ ${GO_PKGNAME}/curve25519 \
+ ${GO_PKGNAME}/md4 \
+ ${GO_PKGNAME}/ocsp \
+ ${GO_PKGNAME}/openpgp \
+ ${GO_PKGNAME}/pbkdf2 \
+ ${GO_PKGNAME}/ripemd160 \
+ ${GO_PKGNAME}/ssh \
+ ${GO_PKGNAME}/twofish \
+ ${GO_PKGNAME}/xtea
+
+do-install:
+ ${MKDIR} ${GO_LOCAL_LIBDIR}/${GO_PKGNAME}
+.for t in ${GO_TARGET}
+ ${INSTALL_DATA} ${GO_WRKDIR_PKG}/${t}.a \
+ ${GO_LOCAL_LIBDIR}/${GO_PKGNAME}
+ ${MKDIR} ${GO_LOCAL_SRCDIR}/${t}
+ (cd ${GO_WRKDIR_SRC}/${t}/ && ${COPYTREE_SHARE} \* \
+ ${GO_LOCAL_SRCDIR}/${t})
+.endfor
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>