aboutsummaryrefslogtreecommitdiff
path: root/security/gokey/Makefile
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2022-12-27 03:36:06 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2022-12-27 03:36:06 +0000
commitaeccccd1cfe5936c2505bc0e3bf8071ff4394b39 (patch)
tree07521a2dcf2ddc4f20a446208865bebf79a18264 /security/gokey/Makefile
parent153d3db0667476bdd46f552a437f1130bce0e68f (diff)
Diffstat (limited to 'security/gokey/Makefile')
-rw-r--r--security/gokey/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/security/gokey/Makefile b/security/gokey/Makefile
new file mode 100644
index 000000000000..6ff956ac043d
--- /dev/null
+++ b/security/gokey/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= gokey
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.2
+CATEGORIES= security
+
+MAINTAINER= 0xdutra@gmail.com
+COMMENT= Simple password manager write in Go
+WWW= https://github.com/cloudflare/gokey
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+GO_MODULE= github.com/cloudflare/gokey
+GO_TARGET= ./cmd/gokey
+
+PLIST_FILES= bin/${PORTNAME}
+
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>