aboutsummaryrefslogtreecommitdiff
path: root/security/gonepass/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-26 11:37:22 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-26 11:37:22 +0000
commit39926c33529b9b64fc5cf6e4e1a5962b202bc25b (patch)
tree92e5be78674339c78659179c553e81f483e5be7e /security/gonepass/Makefile
parent096eab59ce93afe3b747e94e40ef27fd75b82c9e (diff)
downloadports-39926c33529b9b64fc5cf6e4e1a5962b202bc25b.tar.gz
ports-39926c33529b9b64fc5cf6e4e1a5962b202bc25b.zip
Notes
Diffstat (limited to 'security/gonepass/Makefile')
-rw-r--r--security/gonepass/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/gonepass/Makefile b/security/gonepass/Makefile
new file mode 100644
index 000000000000..cdb2e89d73a2
--- /dev/null
+++ b/security/gonepass/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= gonepass
+DISTVERSION= g20181221
+CATEGORIES= security
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= GTK+ 1Password reader
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake compiler:c++11-lang gnome pkgconfig ssl
+USE_GITHUB= yes
+GH_ACCOUNT= jbreams
+GH_TAGNAME= 3da5cfa120
+USE_GNOME= gtk30 gtkmm30
+
+INSTALLS_ICONS= yes
+
+PLIST_FILES= bin/gonepass \
+ share/applications/gonepass.desktop \
+ share/pixmaps/gonepass.png
+
+.include <bsd.port.mk>