aboutsummaryrefslogtreecommitdiff
path: root/security/gorilla
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2006-10-03 08:55:22 +0000
committerStefan Walter <stefan@FreeBSD.org>2006-10-03 08:55:22 +0000
commitb29ff65765c2f5d1d084b983570253eaab776d7d (patch)
tree78fc1570c03a3c5be6bf1cd1556f33ac447f58d4 /security/gorilla
parent85655a80c5d8daa6cd9c74c265df85c622738460 (diff)
downloadports-b29ff65765c2f5d1d084b983570253eaab776d7d.tar.gz
ports-b29ff65765c2f5d1d084b983570253eaab776d7d.zip
Fix file permissions to make the program usable again.
PR: 102896 Noticed by: George L. Yermunlik <yz@yz.kiev.ua> Patch by: maintainer
Notes
Notes: svn path=/head/; revision=174356
Diffstat (limited to 'security/gorilla')
-rw-r--r--security/gorilla/Makefile12
-rw-r--r--security/gorilla/pkg-plist4
2 files changed, 12 insertions, 4 deletions
diff --git a/security/gorilla/Makefile b/security/gorilla/Makefile
index 86fc5d59b1ba..b5b8c34166ef 100644
--- a/security/gorilla/Makefile
+++ b/security/gorilla/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gorilla
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.fpx.de/fp/Software/Gorilla/download/
@@ -24,13 +25,16 @@ NO_BUILD= yes
do-install:
@${MKDIR} ${PREFIX}/lib/gorilla
- @${INSTALL_DATA} ${WRKSRC}/*.tcl ${PREFIX}/lib/gorilla
- ${TAR} -C ${WRKSRC} -cf - blowfish pics pwsafe twofish | \
+ @${INSTALL_SCRIPT} ${WRKSRC}/*.tcl ${PREFIX}/lib/gorilla
+ ${TAR} -C ${WRKSRC} -cf - blowfish pics pwsafe twofish sha1 | \
${TAR} -C ${PREFIX}/lib/gorilla --unlink -xf -
- @${INSTALL_DATA} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
post-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/lib/gorilla
- @${CHMOD} ugo+x ${PREFIX}/bin/gorilla
+ @${CHMOD} ugo+rx ${PREFIX}/lib/gorilla/blowfish/*.tcl
+ @${CHMOD} ugo+rx ${PREFIX}/lib/gorilla/pwsafe/*.tcl
+ @${CHMOD} ugo+rx ${PREFIX}/lib/gorilla/twofish/*.tcl
+ @${CHMOD} ugo+rx ${PREFIX}/lib/gorilla/sha1/*.tcl
.include <bsd.port.mk>
diff --git a/security/gorilla/pkg-plist b/security/gorilla/pkg-plist
index c6b5eec35836..ecb949bbb984 100644
--- a/security/gorilla/pkg-plist
+++ b/security/gorilla/pkg-plist
@@ -22,6 +22,9 @@ lib/gorilla/pwsafe/pwsafe.tcl
lib/gorilla/pwsafe/pwtest.tcl
lib/gorilla/pwsafe/pwsafe-v2.tcl
lib/gorilla/pwsafe/pwsafe-v3.tcl
+lib/gorilla/sha1/LICENSE.txt
+lib/gorilla/sha1/pkgIndex.tcl
+lib/gorilla/sha1/sha256.tcl
lib/gorilla/twofish/twofish.tcl
lib/gorilla/twofish/twotest.tcl
lib/gorilla/twofish/pkgIndex.tcl
@@ -30,4 +33,5 @@ lib/gorilla/twofish/LICENSE.txt
@dirrm lib/gorilla/pics
@dirrm lib/gorilla/twofish
@dirrm lib/gorilla/pwsafe
+@dirrm lib/gorilla/sha1
@dirrm lib/gorilla