aboutsummaryrefslogtreecommitdiff
path: root/security/gpgme-qt5
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2016-10-18 19:45:23 +0000
committerJason E. Hale <jhale@FreeBSD.org>2016-10-18 19:45:23 +0000
commit4949249b82858916d2e6374d9593e06faa243a23 (patch)
tree367e2fb538e00ce1597c5e5ba3f7e53ac7e5c11e /security/gpgme-qt5
parentd67136b3037411d110bf943f1f0c9c3cf3ba7708 (diff)
downloadports-4949249b82858916d2e6374d9593e06faa243a23.tar.gz
ports-4949249b82858916d2e6374d9593e06faa243a23.zip
- Update security/gpgme to 1.7.0
- Convert to master port and add several slave ports for the newly added c++, Qt5, and python bindings (security/gpgme-cpp, security/gpgme-qt5, and security/py-gpgme, respectively) - The Qt bindings currently provided by deskutils/kdepimlibs4 cannot currently coexist with these new bindings, but will be phased out in the future - The python bindings are an updated version of the ones provided by security/py-pyme and are now being maintained as part of the gpgme project. They work with both python 2.x and 3.x. PR: 212886
Notes
Notes: svn path=/head/; revision=424209
Diffstat (limited to 'security/gpgme-qt5')
-rw-r--r--security/gpgme-qt5/Makefile17
-rw-r--r--security/gpgme-qt5/pkg-plist71
2 files changed, 88 insertions, 0 deletions
diff --git a/security/gpgme-qt5/Makefile b/security/gpgme-qt5/Makefile
new file mode 100644
index 000000000000..8bd755d000a0
--- /dev/null
+++ b/security/gpgme-qt5/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -${SLAVEPORT}
+
+MAINTAINER= jhale@FreeBSD.org
+COMMENT= Gpgme Qt5 bindings
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+MASTERDIR= ${.CURDIR}/../../security/gpgme
+SLAVEPORT= qt5
+BINDING_NAME= qt
+PLIST= ${.CURDIR}/pkg-plist
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/gpgme-qt5/pkg-plist b/security/gpgme-qt5/pkg-plist
new file mode 100644
index 000000000000..eaf5cb5e4ed3
--- /dev/null
+++ b/security/gpgme-qt5/pkg-plist
@@ -0,0 +1,71 @@
+include/QGpgME/AddUserIDJob
+include/QGpgME/ChangeExpiryJob
+include/QGpgME/ChangeOwnerTrustJob
+include/QGpgME/ChangePasswdJob
+include/QGpgME/CryptoConfig
+include/QGpgME/DataProvider
+include/QGpgME/DecryptJob
+include/QGpgME/DecryptVerifyJob
+include/QGpgME/DefaultKeyGenerationJob
+include/QGpgME/DeleteJob
+include/QGpgME/DownloadJob
+include/QGpgME/EncryptJob
+include/QGpgME/ExportJob
+include/QGpgME/HierarchicalKeyKistJob
+include/QGpgME/ImportFromKeyserverJob
+include/QGpgME/ImportJob
+include/QGpgME/Job
+include/QGpgME/KeyForMailboxJob
+include/QGpgME/KeyGenerationJob
+include/QGpgME/KeyListJob
+include/QGpgME/ListAllKeysJob
+include/QGpgME/MultiDeleteJob
+include/QGpgME/Protocol
+include/QGpgME/QGpgMENewCryptoConfig
+include/QGpgME/RefreshKeysJob
+include/QGpgME/SignEncryptJob
+include/QGpgME/SignJob
+include/QGpgME/SignKeyJob
+include/QGpgME/TofuPolicyJob
+include/QGpgME/VerifyDetachedJob
+include/QGpgME/VerifyOpaqueJob
+include/QGpgME/WKSPublishJob
+include/qgpgme/adduseridjob.h
+include/qgpgme/changeexpiryjob.h
+include/qgpgme/changeownertrustjob.h
+include/qgpgme/changepasswdjob.h
+include/qgpgme/cryptoconfig.h
+include/qgpgme/dataprovider.h
+include/qgpgme/decryptjob.h
+include/qgpgme/decryptverifyjob.h
+include/qgpgme/defaultkeygenerationjob.h
+include/qgpgme/deletejob.h
+include/qgpgme/downloadjob.h
+include/qgpgme/encryptjob.h
+include/qgpgme/exportjob.h
+include/qgpgme/hierarchicalkeylistjob.h
+include/qgpgme/importfromkeyserverjob.h
+include/qgpgme/importjob.h
+include/qgpgme/job.h
+include/qgpgme/keyformailboxjob.h
+include/qgpgme/keygenerationjob.h
+include/qgpgme/keylistjob.h
+include/qgpgme/listallkeysjob.h
+include/qgpgme/multideletejob.h
+include/qgpgme/protocol.h
+include/qgpgme/qgpgme_export.h
+include/qgpgme/qgpgmenewcryptoconfig.h
+include/qgpgme/refreshkeysjob.h
+include/qgpgme/signencryptjob.h
+include/qgpgme/signjob.h
+include/qgpgme/signkeyjob.h
+include/qgpgme/tofupolicyjob.h
+include/qgpgme/verifydetachedjob.h
+include/qgpgme/verifyopaquejob.h
+include/qgpgme/wkspublishjob.h
+include/qgpgme_version.h
+lib/cmake/Gpgmepp/QGpgmeConfig.cmake
+lib/cmake/Gpgmepp/QGpgmeConfigVersion.cmake
+lib/libqgpgme.so
+lib/libqgpgme.so.6
+lib/libqgpgme.so.6.0.1