aboutsummaryrefslogtreecommitdiff
path: root/security/gpgme-qt5
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2016-10-22 07:33:17 +0000
committerJason E. Hale <jhale@FreeBSD.org>2016-10-22 07:33:17 +0000
commit5640bb9654dc00e2021393a49abbfd470ae7a4f8 (patch)
treeea763b5b59b955918a0dd2ee46cf57816b666a00 /security/gpgme-qt5
parent18086dd2dfcdc0db79db33f88c1d06615d7d5525 (diff)
downloadports-5640bb9654dc00e2021393a49abbfd470ae7a4f8.tar.gz
ports-5640bb9654dc00e2021393a49abbfd470ae7a4f8.zip
Fix build of the Qt interface on FreeBSD 10.2 and 10.3. On FreeBSD 10.1, it
builds without issue (and thats what I originally tested this on and assumed it would work on later releases), but there seems to be a regression in the c++ headers that appears to have happend in r278724, so use libc++ from ports. libtool: compile: c++ -std=c++11 -DHAVE_CONFIG_H -I. -I../../.. -I../../../lang/cpp/src -I../../../src -I/usr/local/include/qt5/QtCore -I/usr/local/include/qt5 -fpic -I/usr/local/include -I/usr/local/include -DBUILDING_QGPGME -isystem /usr/local/include -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing -isystem /usr/local/include -MT qgpgmeencryptjob.lo -MD -MP -MF .deps/qgpgmeencryptjob.Tpo -c qgpgmeencryptjob.cpp -fPIC -DPIC -o .libs/qgpgmeencryptjob.o qgpgmeencryptjob.cpp:133:9: error: no matching function for call to 'bind' run(std::bind(&encrypt, ^~~~~~~~~ /usr/include/c++/v1/functional:2184:1: note: candidate template ignored: couldn't infer template argument '_Fp' bind(_Fp&& __f, _BoundArgs&&... __bound_args) ^ /usr/include/c++/v1/functional:2193:1: note: candidate template ignored: couldn't infer template argument '_Rp' bind(_Fp&& __f, _BoundArgs&&... __bound_args) ^ 1 error generated. gmake[4]: *** [Makefile:801: qgpgmeencryptjob.lo] Error 1 Also, link to libgpgmepp already installed instead of rebuilding it.
Notes
Notes: svn path=/head/; revision=424451
Diffstat (limited to 'security/gpgme-qt5')
-rw-r--r--security/gpgme-qt5/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/security/gpgme-qt5/Makefile b/security/gpgme-qt5/Makefile
index 8bd755d000a0..a616cb9626ee 100644
--- a/security/gpgme-qt5/Makefile
+++ b/security/gpgme-qt5/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
PKGNAMESUFFIX= -${SLAVEPORT}
MAINTAINER= jhale@FreeBSD.org