aboutsummaryrefslogtreecommitdiff
path: root/security/gpgme
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2016-10-21 00:05:57 +0000
committerJason E. Hale <jhale@FreeBSD.org>2016-10-21 00:05:57 +0000
commitfef85d18be522fab1d79b8faf4908c2f888c8bfb (patch)
tree05719c2c2294baa3d13455ae36144ab9f10443f2 /security/gpgme
parent38b820c87c98f164c6059eac1106c948bc3a01c6 (diff)
downloadports-fef85d18be522fab1d79b8faf4908c2f888c8bfb.tar.gz
ports-fef85d18be522fab1d79b8faf4908c2f888c8bfb.zip
Really fix build on 9.x for the c++ and Qt5 bindings;
require libc++.
Notes
Notes: svn path=/head/; revision=424365
Diffstat (limited to 'security/gpgme')
-rw-r--r--security/gpgme/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index e40ed1c50fcd..d69c811fec0d 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -87,6 +87,12 @@ CONFLICTS_INSTALL= py*-pyme-[0-9]*
.include <bsd.port.pre.mk>
.if defined(SLAVEPORT)
+. if (${SLAVEPORT} == "cpp" || ${SLAVEPORT} == "qt5")
+. if ${OPSYS} == FreeBSD && ${OSVERSION} < 1001000
+BUILD_DEPENDS+= ${LOCALBASE}/lib/c++/libstdc++.so:devel/libc++
+CXXFLAGS+= -stdlib=libc++ -I${LOCALBASE}/include/c++/v1
+. endif
+. endif
. if ${SLAVEPORT} == "python"
. if ${PYTHON_REL} >= 3000
CONFIGURE_ARGS+=--enable-languages="python3"