aboutsummaryrefslogtreecommitdiff
path: root/security/gringotts
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-11 09:01:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-11 09:01:29 +0000
commitc1a733d7c2b0cc002ee2b816b91319bae5556097 (patch)
tree1a2d335e72e4b556881c4a474416ed129e2c5882 /security/gringotts
parent10315247c8348caa33db16dd69f57d509d65234e (diff)
downloadports-c1a733d7c2b0cc002ee2b816b91319bae5556097.tar.gz
ports-c1a733d7c2b0cc002ee2b816b91319bae5556097.zip
Notes
Diffstat (limited to 'security/gringotts')
-rw-r--r--security/gringotts/Makefile10
-rw-r--r--security/gringotts/files/patch-src_grg__safe.c (renamed from security/gringotts/files/patch-grg_safe.c)8
2 files changed, 10 insertions, 8 deletions
diff --git a/security/gringotts/Makefile b/security/gringotts/Makefile
index 769ae195de0b..13004563804e 100644
--- a/security/gringotts/Makefile
+++ b/security/gringotts/Makefile
@@ -10,16 +10,16 @@ MASTER_SITES= BERLIOS
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK application to securely store sensitive data
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libpopt.so:devel/popt \
libgringotts.so:security/libgringotts
-USES= gettext pkgconfig
+USES= gettext localbase pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-
OPTIONS_DEFINE= DOCS
post-patch:
@@ -32,6 +32,8 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in AUTHORS BUGS ChangeLog FAQ NEWS README TODO
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
diff --git a/security/gringotts/files/patch-grg_safe.c b/security/gringotts/files/patch-src_grg__safe.c
index 1b8b273ca9f7..ed9ad6323df1 100644
--- a/security/gringotts/files/patch-grg_safe.c
+++ b/security/gringotts/files/patch-src_grg__safe.c
@@ -1,5 +1,5 @@
---- src/grg_safe.c.orig 2008-01-04 22:08:43.000000000 +0900
-+++ src/grg_safe.c 2009-12-22 04:53:36.000000000 +0900
+--- src/grg_safe.c.orig 2008-01-04 13:08:43 UTC
++++ src/grg_safe.c
@@ -33,6 +33,7 @@
#include <stdlib.h>
@@ -16,7 +16,7 @@
#include <sys/resource.h>
#ifdef linux
#include <sys/utsname.h>
-@@ -96,9 +96,6 @@
+@@ -96,9 +96,6 @@ gboolean
grg_mlockall_and_drop_root_privileges(void)
{
/* drop eventual group root privileges */
@@ -26,7 +26,7 @@
#ifdef HAVE_SYS_FSUID_H
setfsgid(getgid());
setfsgid(getgid());
-@@ -148,8 +145,6 @@
+@@ -148,8 +145,6 @@ grg_mlockall_and_drop_root_privileges(vo
#endif
/* drop root privileges */