aboutsummaryrefslogtreecommitdiff
path: root/security/gringotts
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2003-05-14 02:57:40 +0000
committerAnders Nordby <anders@FreeBSD.org>2003-05-14 02:57:40 +0000
commitd8ab968b85b39448d5af259d55023cf55fa9a47b (patch)
tree0d17d7ec3edab3ebb9f3cf250dff888e6f913ea4 /security/gringotts
parent634d1568b4e999854944585e7cf34d8afbb83360 (diff)
downloadports-d8ab968b85b39448d5af259d55023cf55fa9a47b.tar.gz
ports-d8ab968b85b39448d5af259d55023cf55fa9a47b.zip
Update to version 1.2.7.
Notes
Notes: svn path=/head/; revision=80951
Diffstat (limited to 'security/gringotts')
-rw-r--r--security/gringotts/Makefile2
-rw-r--r--security/gringotts/distinfo2
-rw-r--r--security/gringotts/files/patch-grg_safe.c32
-rw-r--r--security/gringotts/files/patch-po-Makefile.in.in11
4 files changed, 29 insertions, 18 deletions
diff --git a/security/gringotts/Makefile b/security/gringotts/Makefile
index 4ea83e233434..b394e1800fee 100644
--- a/security/gringotts/Makefile
+++ b/security/gringotts/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gringotts
-PORTVERSION= 1.2.3
+PORTVERSION= 1.2.7
CATEGORIES= security
MASTER_SITES= http://devel.pluto.linux.it/projects/Gringotts/current/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
diff --git a/security/gringotts/distinfo b/security/gringotts/distinfo
index 75cef8570dc1..bf522d628624 100644
--- a/security/gringotts/distinfo
+++ b/security/gringotts/distinfo
@@ -1 +1 @@
-MD5 (gringotts-1.2.3.tar.bz2) = 272977f4ab002c19ab3700aa219c4cf9
+MD5 (gringotts-1.2.7.tar.bz2) = 24b00b9249128c32288b6739e8cb99ff
diff --git a/security/gringotts/files/patch-grg_safe.c b/security/gringotts/files/patch-grg_safe.c
index c2231ce70bc6..22053cc8fa0f 100644
--- a/security/gringotts/files/patch-grg_safe.c
+++ b/security/gringotts/files/patch-grg_safe.c
@@ -1,5 +1,5 @@
---- src/grg_safe.c.orig Tue Feb 18 22:04:29 2003
-+++ src/grg_safe.c Tue Feb 18 22:05:27 2003
+--- src/grg_safe.c.orig Wed May 14 02:02:13 2003
++++ src/grg_safe.c Wed May 14 02:03:43 2003
@@ -33,6 +33,7 @@
#include <stdlib.h>
@@ -14,23 +14,23 @@
#include <sys/time.h>
-#include <sys/types.h>
#include <sys/resource.h>
+ #include <sys/stat.h>
- #define GRG_SAFE 0
-@@ -57,8 +57,6 @@
- grg_mlockall_and_drop_root_privileges (void)
+@@ -59,8 +59,6 @@
+ grg_mlockall_and_drop_root_privileges(void)
{
- //drop eventual group root privileges
-- setgid (getgid ());
-- setgid (getgid ()); //twice for counter "saved IDs", cfr. Secure Programming HowTo
+ // drop eventual group root privileges
+- setgid(getgid());
+- setgid(getgid()); // twice for counter "saved IDs", cfr.
+ // Secure Programming HowTo
#ifdef HAVE_SYS_FSUID_H
- setfsgid (getgid ());
- setfsgid (getgid ());
-@@ -82,8 +80,6 @@
+ setfsgid(getgid());
+@@ -84,8 +82,6 @@
#endif
- //drop root privileges
-- setuid (getuid ());
-- setuid (getuid ());
+ // drop root privileges
+- setuid(getuid());
+- setuid(getuid());
#ifdef HAVE_SYS_FSUID_H
- setfsuid (getuid ());
- setfsuid (getuid ());
+ setfsuid(getuid());
+ setfsuid(getuid());
diff --git a/security/gringotts/files/patch-po-Makefile.in.in b/security/gringotts/files/patch-po-Makefile.in.in
new file mode 100644
index 000000000000..08e7d77f80d6
--- /dev/null
+++ b/security/gringotts/files/patch-po-Makefile.in.in
@@ -0,0 +1,11 @@
+--- po/Makefile.in.in.orig Wed May 14 02:32:06 2003
++++ po/Makefile.in.in Wed May 14 02:32:22 2003
+@@ -106,7 +106,7 @@
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
++ lang=`echo $$cat | sed 's/\.mo$$//'`; \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+ $(mkinstalldirs) $(DESTDIR)$$dir; \
+ if test -r $$cat; then \