aboutsummaryrefslogtreecommitdiff
path: root/security/gringotts
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2003-02-18 23:14:16 +0000
committerAnders Nordby <anders@FreeBSD.org>2003-02-18 23:14:16 +0000
commitff9bc27d716836343c0a6483503c29022e820525 (patch)
treeb6b65e454d8526ead65f7cb4931fe67eabd352f0 /security/gringotts
parent0d447d676d97b2cc81c31d198ca2039fe2c6c26d (diff)
downloadports-ff9bc27d716836343c0a6483503c29022e820525.tar.gz
ports-ff9bc27d716836343c0a6483503c29022e820525.zip
Update to 1.2.3.
Notes
Notes: svn path=/head/; revision=75824
Diffstat (limited to 'security/gringotts')
-rw-r--r--security/gringotts/Makefile6
-rw-r--r--security/gringotts/distinfo2
-rw-r--r--security/gringotts/files/patch-grg_safe.c31
-rw-r--r--security/gringotts/files/patch-src-Makefile.in8
4 files changed, 9 insertions, 38 deletions
diff --git a/security/gringotts/Makefile b/security/gringotts/Makefile
index ee4870be0477..a80cfcbb5af4 100644
--- a/security/gringotts/Makefile
+++ b/security/gringotts/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gringotts
-PORTVERSION= 1.2.2
-PORTREVISION= 1
+PORTVERSION= 1.2.3
CATEGORIES= security
MASTER_SITES= http://devel.pluto.linux.it/projects/Gringotts/current/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
@@ -37,8 +36,7 @@ PLIST_SUB+= GNOMEHIER='@comment '
.endif
post-patch:
- ${REINPLACE_CMD} -e "s|mlock|mlockall|g" ${WRKSRC}/configure
- ${REINPLACE_CMD} -E -e "s|^(gringottsdocdir =).*|gringottsdocdir = $$\(datadir\)/doc/gringotts|;s|md5sum|md5|g" ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -E -e "s|^(gringottsdocdir =).*|\1 $$\(datadir\)/doc/gringotts|;s|md5sum|md5|g" ${WRKSRC}/Makefile.in
.if defined(NOPORTDOCS)
${REINPLACE_CMD} -E -e "s|^(install-data-am:.*)install-gringottsdocDATA|\1|" ${WRKSRC}/Makefile.in
.endif
diff --git a/security/gringotts/distinfo b/security/gringotts/distinfo
index 61166acb1c87..75cef8570dc1 100644
--- a/security/gringotts/distinfo
+++ b/security/gringotts/distinfo
@@ -1 +1 @@
-MD5 (gringotts-1.2.2.tar.bz2) = 2f4f77392384336d5930825b5ea3ebf1
+MD5 (gringotts-1.2.3.tar.bz2) = 272977f4ab002c19ab3700aa219c4cf9
diff --git a/security/gringotts/files/patch-grg_safe.c b/security/gringotts/files/patch-grg_safe.c
index 5ce852a3254b..c2231ce70bc6 100644
--- a/security/gringotts/files/patch-grg_safe.c
+++ b/security/gringotts/files/patch-grg_safe.c
@@ -1,5 +1,5 @@
---- src/grg_safe.c.orig Thu Dec 5 15:10:07 2002
-+++ src/grg_safe.c Sat Jan 4 19:53:18 2003
+--- src/grg_safe.c.orig Tue Feb 18 22:04:29 2003
++++ src/grg_safe.c Tue Feb 18 22:05:27 2003
@@ -33,6 +33,7 @@
#include <stdlib.h>
@@ -25,15 +25,6 @@
#ifdef HAVE_SYS_FSUID_H
setfsgid (getgid ());
setfsgid (getgid ());
-@@ -67,7 +65,7 @@
- if (!geteuid ())
- //the process is (ev. SUID) root. I can mlockall() the memory in order to avoid swapping.
- {
--#ifdef HAVE_MLOCK
-+#ifdef HAVE_MLOCKALL
- gint res = mlockall (MCL_CURRENT | MCL_FUTURE);
-
- if (res)
@@ -82,8 +80,6 @@
#endif
@@ -43,21 +34,3 @@
#ifdef HAVE_SYS_FSUID_H
setfsuid (getuid ());
setfsuid (getuid ());
-@@ -243,7 +239,7 @@
- if (!(geteuid () && getegid () && getuid () && getgid ()))
- change_sec_level (GRG_UNSAFE);
-
--#ifdef HAVE_MLOCK
-+#ifdef HAVE_MLOCKALL
- if (!mem_safe)
- change_sec_level (GRG_UNSAFE);
- #endif
-@@ -347,7 +343,7 @@
- ADD_INDICATOR (GTK_DIALOG (dialog)->vbox,
- _("Memory protection from core dumps"), green) g_free (rl);
-
--#ifdef HAVE_MLOCK
-+#ifdef HAVE_MLOCKALL
- if (mem_safe)
- ADD_INDICATOR (GTK_DIALOG (dialog)->vbox,
- _("Memory protection from swap writings"), green)
diff --git a/security/gringotts/files/patch-src-Makefile.in b/security/gringotts/files/patch-src-Makefile.in
index 982edb5b2882..61285e201593 100644
--- a/security/gringotts/files/patch-src-Makefile.in
+++ b/security/gringotts/files/patch-src-Makefile.in
@@ -1,10 +1,10 @@
---- src/Makefile.in.orig Sat Oct 26 14:16:10 2002
-+++ src/Makefile.in Sat Oct 26 14:16:17 2002
-@@ -404,7 +404,6 @@
+--- src/Makefile.in.orig Tue Feb 18 22:06:05 2003
++++ src/Makefile.in Tue Feb 18 22:06:33 2003
+@@ -399,7 +399,6 @@
install-exec-local:
strip $(DESTDIR)$(bindir)/gringotts
- chmod u+s $(DESTDIR)$(bindir)/gringotts
-
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT: