aboutsummaryrefslogtreecommitdiff
path: root/security/gvm-libs/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-02-08 10:50:40 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-02-08 10:53:56 +0000
commit6e1233be229212a0496f42d611bd40f3e3a628da (patch)
tree7be6239b98a0dff1d377ec09f371b55fb10dd508 /security/gvm-libs/Makefile
parent77a73a3ae570d10c718a0adcdb1b373c2d6dd8fc (diff)
downloadports-6e1233be229212a0496f42d611bd40f3e3a628da.tar.gz
ports-6e1233be229212a0496f42d611bd40f3e3a628da.zip
Mk/**ldap.mk: Convert USE_LDAP to USES=ldap
Convert the USE_LDAP=yes to USES=ldap and adds the following features: - Adds the argument USES=ldap:server to add openldap2{4|5|6}-server as RUN_DEPENDS - Adds the argument USES=ldap<version> and replaces WANT_OPENLDAP_VER - Adds OPENLDAP versions in bsd.default-versions.mk - Adds USE_OPENLDAP/WANT_OPENLDAP_VER in Mk/bsd.sanity.mk - Changes consumers to use the features Reviewed by: delphij Approved by: portmgr Differential Revision: https://reviews.freebsd.org/D38233
Diffstat (limited to 'security/gvm-libs/Makefile')
-rw-r--r--security/gvm-libs/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/security/gvm-libs/Makefile b/security/gvm-libs/Makefile
index 4efd4d4408b5..d62927b15a91 100644
--- a/security/gvm-libs/Makefile
+++ b/security/gvm-libs/Makefile
@@ -34,7 +34,7 @@ OPTIONS_DEFINE= LDAP RADIUS
LDAP_CMAKE_ON= -DBUILD_WITH_LDAP=1
LDAP_CMAKE_OFF= -DBUILD_WITH_LDAP=0
-LDAP_USE= OPENLDAP=yes
+LDAP_USES= ldap
RADIUS_CMAKE_ON= -DBUILD_WITH_RADIUS=1
RADIUS_CMAKE_OFF= -DBUILD_WITH_RADIUS=0
RADIUS_LIB_DEPENDS= libfreeradius-client.so:net/freeradius-client