aboutsummaryrefslogtreecommitdiff
path: root/security/heimdal
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2015-03-04 12:54:02 +0000
committerHiroki Sato <hrs@FreeBSD.org>2015-03-04 12:54:02 +0000
commitf32fe9bdf3add4a74d54c5b8af76b0c35386c43f (patch)
tree684df5460af76fd542260e1d7a44079f0572534c /security/heimdal
parentcf7d685f16c097e5ba97cfc07e51acfb7f9e1120 (diff)
downloadports-f32fe9bdf3add4a74d54c5b8af76b0c35386c43f.tar.gz
ports-f32fe9bdf3add4a74d54c5b8af76b0c35386c43f.zip
- Remove an orphaned directory [1].
- Fix USE_LDCONFIG [2]. Spotted by: sunpoet [1] and bdrewery [2]
Notes
Notes: svn path=/head/; revision=380434
Diffstat (limited to 'security/heimdal')
-rw-r--r--security/heimdal/Makefile8
-rw-r--r--security/heimdal/files/patch-lib-roken-Makefile.in41
2 files changed, 45 insertions, 4 deletions
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index a4d6de2d5913..19703ed3b47e 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -3,7 +3,7 @@
PORTNAME= heimdal
PORTVERSION= 1.5.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security ipv6
MASTER_SITES= http://www.h5l.org/dist/src/ \
http://ftp.pdc.kth.se/pub/heimdal/src/ \
@@ -21,7 +21,7 @@ CONFLICTS= krb4-[0-9]* krb5-[0-9]* krb5-maint-[0-9]* srp-[0-9]* \
USES= gettext gssapi:bootstrap,heimdal libtool pathfix pkgconfig \
readline makeinfo
-USE_LDCONFIG= yes
+USE_LDCONFIG= ${GSSAPILIBDIR}
USE_OPENSSL= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
@@ -30,8 +30,8 @@ CONFIGURE_ENV= ac_cv_header_fnmatch_h=yes \
CONFIGURE_ARGS= --with-libintl \
--with-libintl-include="${LOCALBASE}/include" \
--with-libintl-lib="${LOCALBASE}/lib" \
- --libdir="${PREFIX}/lib/${PORTNAME}" \
- --includedir="${PREFIX}/include/${PORTNAME}" \
+ --libdir="${GSSAPILIBDIR}" \
+ --includedir="${GSSAPIINCDIR}" \
--with-kcm \
--with-openssl \
--with-openssl-include="${OPENSSLINC}" \
diff --git a/security/heimdal/files/patch-lib-roken-Makefile.in b/security/heimdal/files/patch-lib-roken-Makefile.in
new file mode 100644
index 000000000000..823a45631105
--- /dev/null
+++ b/security/heimdal/files/patch-lib-roken-Makefile.in
@@ -0,0 +1,41 @@
+--- lib/roken/Makefile.in.orig 2012-12-10 07:09:39.000000000 +0900
++++ lib/roken/Makefile.in 2015-03-04 21:35:04.000000000 +0900
+@@ -150,8 +150,7 @@
+ sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
+ sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
+ am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(man3dir)" \
+- "$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)" \
+- "$(DESTDIR)$(rokenincludedir)"
++ "$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)"
+ LTLIBRARIES = $(lib_LTLIBRARIES) $(noinst_LTLIBRARIES)
+ am__DEPENDENCIES_1 =
+ libroken_la_DEPENDENCIES = @LTLIBOBJS@ $(am__DEPENDENCIES_1)
+@@ -305,8 +304,7 @@
+ am__dist_include_HEADERS_DIST = base64.h getarg.h hex.h parse_bytes.h \
+ parse_time.h parse_units.h resolve.h roken-common.h rtbl.h \
+ xdbm.h socket_wrapper.h
+-HEADERS = $(dist_include_HEADERS) $(nodist_include_HEADERS) \
+- $(nodist_rokeninclude_HEADERS)
++HEADERS = $(dist_include_HEADERS) $(nodist_include_HEADERS)
+ ETAGS = etags
+ CTAGS = ctags
+ am__tty_colors = \
+@@ -1721,7 +1719,7 @@
+ all-am: Makefile $(LTLIBRARIES) $(PROGRAMS) $(MANS) $(HEADERS) \
+ all-local
+ installdirs:
+- for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(man3dir)" "$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)" "$(DESTDIR)$(rokenincludedir)"; do \
++ for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(man3dir)" "$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)"; do \
+ test -z "$$dir" || $(MKDIR_P) "$$dir"; \
+ done
+ install: $(BUILT_SOURCES)
+@@ -1777,8 +1775,7 @@
+ info-am:
+
+ install-data-am: install-dist_includeHEADERS install-man \
+- install-nodist_includeHEADERS \
+- install-nodist_rokenincludeHEADERS
++ install-nodist_includeHEADERS
+ @$(NORMAL_INSTALL)
+ $(MAKE) $(AM_MAKEFLAGS) install-data-hook
+ install-dvi: install-dvi-am