aboutsummaryrefslogtreecommitdiff
path: root/security/helib
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-07-07 08:58:22 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-07-07 08:58:22 +0000
commitf89602260d39d382f05aa7a2d70dfbad029f5f16 (patch)
tree07047b4a0f3b56c250dc37c7beee0054b6ec2ac8 /security/helib
parent0ac63c88d7b51a89f2c955e99b615ff19e0526d5 (diff)
downloadports-f89602260d39d382f05aa7a2d70dfbad029f5f16.tar.gz
ports-f89602260d39d382f05aa7a2d70dfbad029f5f16.zip
ecurity/helib: Update 1.0.1 -> 1.0.2
Reported by: portscout
Notes
Notes: svn path=/head/; revision=541393
Diffstat (limited to 'security/helib')
-rw-r--r--security/helib/Makefile3
-rw-r--r--security/helib/distinfo6
-rw-r--r--security/helib/files/patch-src_timing.cpp10
3 files changed, 9 insertions, 10 deletions
diff --git a/security/helib/Makefile b/security/helib/Makefile
index 311e005b19b4..7444f61b0c6b 100644
--- a/security/helib/Makefile
+++ b/security/helib/Makefile
@@ -2,14 +2,13 @@
PORTNAME= helib
DISTVERSIONPREFIX= v
-DISTVERSION= 1.0.1
+DISTVERSION= 1.0.2
CATEGORIES= security
MAINTAINER= yuri@FreeBSD.org
COMMENT= Implementation of homomorphic encryption
LICENSE= APACHE20
-LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_i386= no matching function for call to 'assertEq', see https://github.com/homenc/HElib/issues/342
diff --git a/security/helib/distinfo b/security/helib/distinfo
index d018cb55c5f7..8911e009a912 100644
--- a/security/helib/distinfo
+++ b/security/helib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588816237
-SHA256 (homenc-HElib-v1.0.1_GH0.tar.gz) = 428b61075cfe313071bb59ccd07736dae07244a065c2001662c9c3d3988ab349
-SIZE (homenc-HElib-v1.0.1_GH0.tar.gz) = 1579853
+TIMESTAMP = 1594111687
+SHA256 (homenc-HElib-v1.0.2_GH0.tar.gz) = b907eaa8381af3d001d7fb8383273f4c652415b3320c11d5be2ad8f19757c998
+SIZE (homenc-HElib-v1.0.2_GH0.tar.gz) = 621205
diff --git a/security/helib/files/patch-src_timing.cpp b/security/helib/files/patch-src_timing.cpp
index 289c71c05166..c4f21204b97d 100644
--- a/security/helib/files/patch-src_timing.cpp
+++ b/security/helib/files/patch-src_timing.cpp
@@ -1,11 +1,11 @@
---- src/timing.cpp.orig 2020-01-16 05:36:23 UTC
+--- src/timing.cpp.orig 2020-07-06 09:01:51 UTC
+++ src/timing.cpp
-@@ -23,7 +23,7 @@ unsigned long GetTimerClock()
+@@ -22,7 +22,7 @@ unsigned long GetTimerClock()
+ {
timespec ts;
-
- clock_gettime(CLOCK_MONOTONIC_RAW, &ts);
+ clock_gettime(CLOCK_MONOTONIC, &ts);
- //clock_gettime(CLOCK_PROCESS_CPUTIME_ID, &ts);
- //clock_gettime(CLOCK_THREAD_CPUTIME_ID, &ts);
+ // clock_gettime(CLOCK_PROCESS_CPUTIME_ID, &ts);
+ // clock_gettime(CLOCK_THREAD_CPUTIME_ID, &ts);