aboutsummaryrefslogtreecommitdiff
path: root/security/hitch
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2017-11-07 23:42:06 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2017-11-07 23:42:06 +0000
commit2e8487b25343b80231fa34c55fe4205d1694edfb (patch)
tree228ed840584116cd275735da98335cf669aebe1d /security/hitch
parent6785bce3b70c7c48798354689b36cabc23b4ae93 (diff)
downloadports-2e8487b25343b80231fa34c55fe4205d1694edfb.tar.gz
ports-2e8487b25343b80231fa34c55fe4205d1694edfb.zip
- Update to 1.4.6
PR: 221565 Reported by: Christopher Beppler
Notes
Notes: svn path=/head/; revision=453712
Diffstat (limited to 'security/hitch')
-rw-r--r--security/hitch/Makefile2
-rw-r--r--security/hitch/distinfo6
-rw-r--r--security/hitch/files/patch-configure.ac10
-rw-r--r--security/hitch/files/patch-src_hitch.c22
4 files changed, 14 insertions, 26 deletions
diff --git a/security/hitch/Makefile b/security/hitch/Makefile
index 989adbf540bd..c332d11d3aff 100644
--- a/security/hitch/Makefile
+++ b/security/hitch/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hitch
-PORTVERSION= 1.4.4
+PORTVERSION= 1.4.6
DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= security
diff --git a/security/hitch/distinfo b/security/hitch/distinfo
index 6ccb45912412..01b94c6c146f 100644
--- a/security/hitch/distinfo
+++ b/security/hitch/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1485636726
-SHA256 (varnish-hitch-hitch-1.4.4_GH0.tar.gz) = 3c889637e1bc66010b8243fc91b9e26e134f6be77f38a770773dbbbb4dacdefc
-SIZE (varnish-hitch-hitch-1.4.4_GH0.tar.gz) = 125074
+TIMESTAMP = 1501945009
+SHA256 (varnish-hitch-hitch-1.4.6_GH0.tar.gz) = fecc0604a2574e50e99573536eade96769b3435aa787d2095ed9115434a6f003
+SIZE (varnish-hitch-hitch-1.4.6_GH0.tar.gz) = 126223
diff --git a/security/hitch/files/patch-configure.ac b/security/hitch/files/patch-configure.ac
new file mode 100644
index 000000000000..c62502e01c11
--- /dev/null
+++ b/security/hitch/files/patch-configure.ac
@@ -0,0 +1,10 @@
+--- configure.ac.orig 2017-11-07 23:38:47 UTC
++++ configure.ac
+@@ -40,6 +40,7 @@ AM_CONDITIONAL([FOUND_RST2MAN], [test "x
+ AM_MAINTAINER_MODE([disable])
+
+ # Checks for libraries.
++m4_include([hitch.m4])
+ PKG_CHECK_EXISTS([libev], [
+ PKG_CHECK_MODULES([EV], [libev])], [
+ HITCH_SEARCH_LIBS([EV], [ev], [ev_default_loop],
diff --git a/security/hitch/files/patch-src_hitch.c b/security/hitch/files/patch-src_hitch.c
deleted file mode 100644
index dd237048b64c..000000000000
--- a/security/hitch/files/patch-src_hitch.c
+++ /dev/null
@@ -1,22 +0,0 @@
-From cc92c25a5fcbc1d3e4ebb8771fe87d961f2079bf Mon Sep 17 00:00:00 2001
-From: Vanilla Hsu <vanilla@fatpipi.com>
-Date: Sat, 14 Jan 2017 09:36:57 +0800
-Subject: [PATCH] Fix building with libressl.
-
----
- src/hitch.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/hitch.c b/src/hitch.c
-index 5b48680..03b4580 100644
---- src/hitch.c.orig 2016-12-22 13:48:49 UTC
-+++ src/hitch.c
-@@ -683,7 +683,7 @@ load_privatekey(SSL_CTX *ctx, const char
- return NULL;
- }
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- #define SSL_CTX_get_default_passwd_cb(ctx) (ctx->default_passwd_callback)
- #define SSL_CTX_get_default_passwd_cb_userdata(ctx) (ctx->default_passwd_callback_userdata)
- #endif