aboutsummaryrefslogtreecommitdiff
path: root/security/hlfl
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-03 16:34:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-03 16:34:37 +0000
commitac75853206b09f08f935b7ceb41b17c2f3951dc6 (patch)
tree91763ac853d7f3aa4920fa5cf4812e015c95b221 /security/hlfl
parentd562c67d0594819c59dbf12f9f297d8383796a83 (diff)
downloadports-ac75853206b09f08f935b7ceb41b17c2f3951dc6.tar.gz
ports-ac75853206b09f08f935b7ceb41b17c2f3951dc6.zip
- Remove unneeded CONFIGURE_ARGS
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=410055
Diffstat (limited to 'security/hlfl')
-rw-r--r--security/hlfl/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/security/hlfl/Makefile b/security/hlfl/Makefile
index 45d31473b01f..c3598757f9f9 100644
--- a/security/hlfl/Makefile
+++ b/security/hlfl/Makefile
@@ -14,14 +14,17 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --datadir=${LOCALBASE}/share/doc
+
PORTDOCS= services.hlfl sample_1.hlfl sample_2.hlfl test.hlfl syntax.txt
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
+
OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/hlfl ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/doc/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/doc/${i} ${STAGEDIR}${DOCSDIR}