aboutsummaryrefslogtreecommitdiff
path: root/security/hmap
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-28 12:48:52 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-28 12:48:52 +0000
commit09e628db4401a67c194e1a5ae29ac1c6e92aee9c (patch)
tree8c1437d1d17cccb7021275cc998ae62af689a15a /security/hmap
parent81a5e4e9248f1c4fd2bcc7b8b65c1c6b949fe1ca (diff)
downloadports-09e628db4401a67c194e1a5ae29ac1c6e92aee9c.tar.gz
ports-09e628db4401a67c194e1a5ae29ac1c6e92aee9c.zip
Notes
Diffstat (limited to 'security/hmap')
-rw-r--r--security/hmap/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/security/hmap/Makefile b/security/hmap/Makefile
index f92c3b5d5f29..92ff7c70b9af 100644
--- a/security/hmap/Makefile
+++ b/security/hmap/Makefile
@@ -20,19 +20,18 @@ USE_PYTHON= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
${REINPLACE_CMD} -e 's|DATADIR|${DATADIR}|' ${WRKSRC}/hmap.py
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/hmap.py ${PREFIX}/bin/
- ${MKDIR} ${DATADIR}
- (cd ${WRKSRC}/known.servers/ && ${COPYTREE_SHARE} \* ${DATADIR})
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/hmap.py ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC}/known.servers/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${DATADIR})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in README BUGS FAQS HIDING_GUIDE KNOWN_TESTS
- ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/$i ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>