aboutsummaryrefslogtreecommitdiff
path: root/security/hpenc/Makefile
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2015-03-22 16:32:26 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2015-03-22 16:32:26 +0000
commitbbb87bd1e285191d7800801bb415d9a474b39a0c (patch)
treeaaea7446f18768e6abfdf00358032fbe219da382 /security/hpenc/Makefile
parenta8e090d5787d7600d4b31ad2917391e5d48e6617 (diff)
downloadports-bbb87bd1e285191d7800801bb415d9a474b39a0c.tar.gz
ports-bbb87bd1e285191d7800801bb415d9a474b39a0c.zip
Notes
Diffstat (limited to 'security/hpenc/Makefile')
-rw-r--r--security/hpenc/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/security/hpenc/Makefile b/security/hpenc/Makefile
index e0148a64d503..5bb8a0eecf17 100644
--- a/security/hpenc/Makefile
+++ b/security/hpenc/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= hpenc
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 2.0
CATEGORIES= security
MASTER_SITES= http://highsecure.ru/distfiles/
@@ -17,9 +16,10 @@ PLIST_FILES= bin/hpenc
MAKE_ARGS+= "ARCH=${ARCH:S/amd64/x86/:S/i386/x86/}"
CXXFLAGS+= -std=c++11 \
- -I${WRKSRC}/chacha-opt/app/include \
- -I${WRKSRC}/poly1305-opt/app/include
-LDFLAGS+= -pthread -lcrypto
+ -I${WRKSRC}/chacha-opt/app/include \
+ -I${WRKSRC}/poly1305-opt/app/include \
+ -I${OPENSSLINC}
+LDFLAGS+= -pthread -lcrypto -L${OPENSSLLIB}
.include <bsd.port.pre.mk>