aboutsummaryrefslogtreecommitdiff
path: root/security/hpn-ssh
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2004-11-17 22:36:17 +0000
committerBrooks Davis <brooks@FreeBSD.org>2004-11-17 22:36:17 +0000
commitb5b1ffb36974416b213a5750993700245875e041 (patch)
tree7f62e673b5331e828f831e460c8efee09e29e52d /security/hpn-ssh
parent0f4cc5dfdfc3e2a3806220664d423ddf84d6381e (diff)
downloadports-b5b1ffb36974416b213a5750993700245875e041.tar.gz
ports-b5b1ffb36974416b213a5750993700245875e041.zip
Notes
Diffstat (limited to 'security/hpn-ssh')
-rw-r--r--security/hpn-ssh/Makefile38
-rw-r--r--security/hpn-ssh/distinfo4
-rw-r--r--security/hpn-ssh/pkg-descr23
3 files changed, 30 insertions, 35 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index fdfacae51a29..da4122372ea0 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -5,33 +5,27 @@
# $FreeBSD$
#
-PORTNAME= openssh
+PORTNAME= hpn-ssh
PORTVERSION= 3.9.0.1
-.if defined(OPENSSH_SNAPSHOT)
-PORTREVISION!= date -v-1d +%Y%m%d
-.endif
PORTEPOCH= 1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%SUBDIR%/ \
ftp://carroll.cac.psu.edu/pub/OpenBSD/OpenSSH/portable/%SUBDIR%/
-PKGNAMESUFFIX?= ${PORTABLE_SUFFIX}${GSSAPI_SUFFIX}${BASE_SUFFIX}${PKGNAMESUFFIX2}
-MASTER_SITE_SUBDIR= ${MASTER_SITE_SUBDIR2}
-DISTNAME= ${DISTNAME2}
+PKGNAMESUFFIX?= ${GSSAPI_SUFFIX}${BASE_SUFFIX}
+DISTNAME= openssh-${OPENSSHVERSION}
+.if defined(WITH_NONE_CIPHER)
+PATCHFILES= openssh-${OPENSSHVERSION}-hpn-none.diff
+.else
+PATCHFILES= openssh-${OPENSSHVERSION}-hpn.diff
+.endif
+PATCH_SITES= http://www.psc.edu/networking/projects/hpn-ssh/
+PATCH_DIST_STRIP=-p1
-MAINTAINER= ports@FreeBSD.org
-COMMENT= The portable version of OpenBSD's OpenSSH
+MAINTAINER= brooks@FreeBSD.org
+COMMENT= High Performance Enabled SSH/SCP
OPENSSHVERSION= 3.9p1
-.if defined(OPENSSH_SNAPSHOT)
-MASTER_SITE_SUBDIR2= snapshot/
-DISTNAME2= ${PORTNAME}-SNAP-${PORTREVISION}
-NO_CHECKSUM= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
-.else
-MASTER_SITE_SUBDIR2=
-DISTNAME2= ${PORTNAME}-${OPENSSHVERSION}
-WRKSRC= ${WRKDIR}/${PORTNAME}-${OPENSSHVERSION}
-.endif
+WRKSRC= ${WRKDIR}/openssh-${OPENSSHVERSION}
MAN1= sftp.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh-keyscan.1 scp.1 ssh.1
MLINKS= ssh.1 slogin.1
@@ -50,7 +44,6 @@ PRECIOUS= ssh_config sshd_config \
ssh_host_rsa_key ssh_host_rsa_key.pub \
ssh_host_dsa_key ssh_host_dsa_key.pub
ETCOLD= ${PREFIX}/etc
-PORTABLE_SUFFIX= -portable
.if exists(/usr/include/security/pam_modules.h)
CONFIGURE_ARGS+= --with-pam
@@ -64,13 +57,12 @@ CONFIGURE_ARGS+= --with-tcp-wrappers
CONFIGURE_ARGS+= --disable-suid-ssh
.endif
+CONFLICTS+= openssh-*
+
.if defined(KRB5_HOME) && exists(${KRB5_HOME}) || defined(WITH_GSSAPI)
-PORTABLE_SUFFIX=
GSSAPI_SUFFIX= -gssapi
-CONFLICTS+= openssh-portable-*
CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
.else
-CONFLICTS+= openssh-gssapi-*
.if !defined(WITHOUT_KERBEROS) && exists(/usr/include/krb5.h)
CONFIGURE_ARGS+= --with-kerberos5
EXTRA_PATCHES+= ${FILESDIR}/gss-serv.c.patch
diff --git a/security/hpn-ssh/distinfo b/security/hpn-ssh/distinfo
index f65062a93be4..f58a9b12f822 100644
--- a/security/hpn-ssh/distinfo
+++ b/security/hpn-ssh/distinfo
@@ -1,2 +1,6 @@
MD5 (openssh-3.9p1.tar.gz) = 8e1774d0b52aff08f817f3987442a16e
SIZE (openssh-3.9p1.tar.gz) = 854027
+MD5 (openssh-3.9p1-hpn.diff) = e6a3ea869739e1725d2580a4ef9889c2
+SIZE (openssh-3.9p1-hpn.diff) = 8387
+MD5 (openssh-3.9p1-hpn-none.diff) = f738de8dea04b87cea7811e996f9eb2b
+SIZE (openssh-3.9p1-hpn-none.diff) = 18971
diff --git a/security/hpn-ssh/pkg-descr b/security/hpn-ssh/pkg-descr
index 99ac07bfd209..b63506daa5fb 100644
--- a/security/hpn-ssh/pkg-descr
+++ b/security/hpn-ssh/pkg-descr
@@ -1,15 +1,14 @@
-OpenBSD's OpenSSH portable version
+High Performance Enabled SSH/SCP
+from the Pittsburgh Supercomputing Center
-Normal OpenSSH development produces a very small, secure, and easy to maintain
-version for the OpenBSD project. The OpenSSH Portability Team takes that pure
-version and adds portability code so that OpenSSH can run on many other
-operating systems (Unfortunately, in particular since OpenSSH does
-authentication, it runs into a *lot* of differences between Unix operating
-systems).
+hpn-ssh is a version of OpenSSH modified to support high-performance
+bulk transfers (such as with scp or rsync). These modifications are
+required because:
-The portable OpenSSH follows development of the official version, but releases
-are not synchronized. Portable releases are marked with a 'p' (e.g. 3.1p1).
-The official OpenBSD source will never use the 'p' suffix, but will instead
-increment the version number when they hit 'stable spots' in their development.
+ SCP and the underlying SSH protocol is network performance limited by
+ statically defined internal flow control buffers. These buffers often
+ end up acting as a brake on the network throughput of SCP especially
+ on long and wide paths. Modifying the ssh code to allow the flow
+ control buffers to be defined at run time eliminates this bottleneck.
-WWW: http://www.openssh.com/portable.html
+WWW: http://www.psc.edu/networking/projects/hpn-ssh/