aboutsummaryrefslogtreecommitdiff
path: root/security/hydra
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-05-29 21:20:17 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-05-29 21:20:17 +0000
commit386f02beb1e5950c84054c1d4b9980f0144d4138 (patch)
tree67ed467fb089874ca2f219b717815d3d5cde7446 /security/hydra
parent99b06f2bb5186382838b530174ef1bda840477ec (diff)
downloadports-386f02beb1e5950c84054c1d4b9980f0144d4138.tar.gz
ports-386f02beb1e5950c84054c1d4b9980f0144d4138.zip
- update to 7.3
- add some tabs into Makefile header - drop EXTRACT_SUFX, WRKSRC, LICENSE_FILE - they are not needed anymore - drop library versions in LIB_DEPENDS - convert to optionsNG - use bsd.port.options.mk instead of bsd.port.pre.mk - use BUILD/RUN_DEPENDS instead of LIB_ to depend on security/libssh: this library will not be installed if misc/compat7x in installed
Notes
Notes: svn path=/head/; revision=297710
Diffstat (limited to 'security/hydra')
-rw-r--r--security/hydra/Makefile46
-rw-r--r--security/hydra/distinfo4
-rw-r--r--security/hydra/pkg-descr7
3 files changed, 27 insertions, 30 deletions
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
index df5db1d00f1c..3d6d79175baa 100644
--- a/security/hydra/Makefile
+++ b/security/hydra/Makefile
@@ -1,28 +1,25 @@
# ex:ts=8
-# Ports collection makefile for: hydra
-# Date created: Tue Oct 08, 2002
-# Whom: Laurent LEVIER (llevier@argosnet.com)
+# Ports collection makefile for: hydra
+# Date created: Tue Oct 08, 2002
+# Whom: Laurent LEVIER (llevier@argosnet.com)
#
# $FreeBSD$
#
PORTNAME= hydra
-PORTVERSION= 7.2
-PORTREVISION= 1
+PORTVERSION= 7.3
CATEGORIES= security
MASTER_SITES= http://freeworld.thc.org/releases/ \
PACKETSTORM/groups/thc/
-EXTRACT_SUFX= -src.tar.gz
MAINTAINER= rm@FreeBSD.org
COMMENT= Brute force attack utility working on multiple network services
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= idn:${PORTSDIR}/dns/libidn \
- pcre.1:${PORTSDIR}/devel/pcre \
- sasl2.2:${PORTSDIR}/security/cyrus-sasl2
+ pcre:${PORTSDIR}/devel/pcre \
+ sasl2:${PORTSDIR}/security/cyrus-sasl2
NO_LATEST_LINK= yes
PLIST_FILES= bin/hydra bin/pw-inspector bin/dpl4hydra.sh
@@ -31,29 +28,32 @@ USE_GMAKE= yes
USE_OPENSSL= yes
WANT_GNOME= yes
MAKE_JOBS_SAFE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
MAN1= hydra.1 pw-inspector.1
-OPTIONS= FIREBIRD "Enable firebird support" off \
- SSH "Enable ssh support" off \
- SVN "Enable subversion support" off \
- X11 "Install xhydra" off
+OPTIONS_DEFINE= FIREBIRD SSH SVN X11
+FIREBIRD_DESC= Enable firebird support
+SSH_DESC= Enable ssh support
+SVN_DESC= Enable subversion support
+OPTIONS_EXCLUDE=NLS DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_FIREBIRD)
-LIB_DEPENDS+= fbclient.2:${PORTSDIR}/databases/firebird20-client
+.if ${PORT_OPTIONS:MFIREBIRD}
+LIB_DEPENDS+= fbclient:${PORTSDIR}/databases/firebird20-client
.endif
-.if defined(WITH_SSH)
-LIB_DEPENDS+= ssh.4:${PORTSDIR}/security/libssh
+
+.if ${PORT_OPTIONS:MSSH}
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libssh.so.4:${PORTSDIR}/security/libssh
+RUN_DEPENDS+= ${LOCALBASE}/lib/libssh.so.4:${PORTSDIR}/security/libssh
CFLAGS+= -I${LOCALBASE}/include
.endif
-.if defined(WITH_SVN)
+
+.if ${PORT_OPTIONS:MSVN}
LIB_DEPENDS+= svn_client-1:${PORTSDIR}/devel/subversion
.endif
-.if defined(WITH_X11)
+.if ${PORT_OPTIONS:MX11}
USE_GNOME= gtk20 pkgconfig
PLIST_FILES+= bin/xhydra
MAN1+= xhydra.1
@@ -73,9 +73,9 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/dpl4hydra.sh ${PREFIX}/bin
@${INSTALL_MAN} ${WRKSRC}/hydra.1 ${MANPREFIX}/man/man1/hydra.1
@${INSTALL_MAN} ${WRKSRC}/pw-inspector.1 ${MANPREFIX}/man/man1/pw-inspector.1
-.if defined(WITH_X11)
+.if ${PORT_OPTIONS:MX11}
@${INSTALL_PROGRAM} ${WRKSRC}/hydra-gtk/src/xhydra ${PREFIX}/bin
@${INSTALL_MAN} ${WRKSRC}/xhydra.1 ${MANPREFIX}/man/man1/xhydra.1
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/hydra/distinfo b/security/hydra/distinfo
index 76b249ed6726..66e9a836ea9a 100644
--- a/security/hydra/distinfo
+++ b/security/hydra/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hydra-7.2-src.tar.gz) = f15c6b833c6c34891aacefa1c6d1afb67d0d50350d26273a784e29114f69970e
-SIZE (hydra-7.2-src.tar.gz) = 652142
+SHA256 (hydra-7.3.tar.gz) = 14805ba70f3f22beb00344db161a1a84d61059655f2be37dd02a5c5cceae306d
+SIZE (hydra-7.3.tar.gz) = 660873
diff --git a/security/hydra/pkg-descr b/security/hydra/pkg-descr
index db6381ed34e0..b5b1b9d98622 100644
--- a/security/hydra/pkg-descr
+++ b/security/hydra/pkg-descr
@@ -1,8 +1,5 @@
Hydra is a parallized login hacker utility. Hydra can brute force attack on
FTP, POP3, IMAP, Telnet, HTTP Auth, NNTP, VNC, ICQ, Socks5, PCNFS and more
-services within SSL support. This port is provided as a standalone program to
-avoid installing a full Nessus scanner system.
+services within SSL support.
-NEWS: Hydra is now included in Nessus!
-
-WWW: http://freeworld.thc.org/thc-hydra/
+WWW: http://freeworld.thc.org/thc-hydra/