aboutsummaryrefslogtreecommitdiff
path: root/security/i2p
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-01-18 13:20:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-01-18 13:20:31 +0000
commit02f27a83b44d4566fd409edc60570ac0734eb63e (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /security/i2p
parentbddf1289efd81317364118eb60cdc28cc766c3c2 (diff)
downloadports-02f27a83b44d4566fd409edc60570ac0734eb63e.tar.gz
ports-02f27a83b44d4566fd409edc60570ac0734eb63e.zip
The output of tools like awk, date, sort, tr,... depends on the current
locale set by the user. Add LANG=C and LC_ALL=C at the beginning of bsd.port.mk and export them so all commands are executed with the C locale. LC_ALL=C overrides all other LC_* variables. LANG is used by setlocale(3) as default value for LC_* variables, so normally it isn't used when LC_ALL is set, but there's code out there that looks at LANG directly so it's safer to set it as well. The only commands not captured by this are != assignments before any inclusion of bsd.port.*mk. Introduce USE_LOCALE=<locale> that adds LANG=<locale> and LC_ALL=<locale> to CONFIGURE_ENV and MAKE_ENV so upstream build systems can be executed with a different locale (e.g. USE_LOCALE=en_US.UTF-8). PR: 215882 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=431796
Diffstat (limited to 'security/i2p')
-rw-r--r--security/i2p/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/security/i2p/Makefile b/security/i2p/Makefile
index ab5d31b5a287..104a0100c3e2 100644
--- a/security/i2p/Makefile
+++ b/security/i2p/Makefile
@@ -37,11 +37,11 @@ USE_ANT= yes
USE_JAVA= yes
JAVA_BUILD= jdk
JAVA_VERSION= 1.6+
+USE_LOCALE= en_US.UTF-8
ALL_TARGET= \
updater \
tarball
-MAKE_ENV= LANG=en_US.UTF-8
PORTDATA= *