aboutsummaryrefslogtreecommitdiff
path: root/security/i2p
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-05-09 20:09:07 +0000
committerSteve Wills <swills@FreeBSD.org>2019-05-09 20:09:07 +0000
commit65d4f0186f3a361dc156508bd441e47b3533eecd (patch)
treed1e9623b914fc54faf227bc129345a15aa782c8d /security/i2p
parent9ecfcd3649162c82a269c68b0420d6009ea09b33 (diff)
downloadports-65d4f0186f3a361dc156508bd441e47b3533eecd.tar.gz
ports-65d4f0186f3a361dc156508bd441e47b3533eecd.zip
Notes
Diffstat (limited to 'security/i2p')
-rw-r--r--security/i2p/Makefile2
-rw-r--r--security/i2p/distinfo6
-rw-r--r--security/i2p/files/patch-apps_i2pcontrol_java_com_thetransactioncompany_jsonrpc2_package-info.java11
-rw-r--r--security/i2p/files/patch-apps_i2pcontrol_java_org_mindrot_jbcrypt_BCrypt.java35
-rw-r--r--security/i2p/files/patch-apps_streaming_java_src_net_i2p_client_streaming_impl_I2PSocketManagerFull.java19
5 files changed, 50 insertions, 23 deletions
diff --git a/security/i2p/Makefile b/security/i2p/Makefile
index c4bdd2453e3c..3fc9ceb473ab 100644
--- a/security/i2p/Makefile
+++ b/security/i2p/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= i2p
-DISTVERSION= 0.9.38
+DISTVERSION= 0.9.40
CATEGORIES= security java net-p2p
MASTER_SITES= SF/${PORTNAME:tl}/${PORTVERSION} \
http://download.i2p2.no/releases/${PORTVERSION}/ \
diff --git a/security/i2p/distinfo b/security/i2p/distinfo
index 78c690b82f9e..b4d44f7f9166 100644
--- a/security/i2p/distinfo
+++ b/security/i2p/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1548602826
-SHA256 (i2psource_0.9.38.tar.bz2) = 65fe327fdd11272a764c9e1c6ae1f38b151cea9003216b861c7ff2b281ca2970
-SIZE (i2psource_0.9.38.tar.bz2) = 30702106
+TIMESTAMP = 1557365594
+SHA256 (i2psource_0.9.40.tar.bz2) = 5d31e0a324dfe429135ac17595b3cab3e81d85d4aa7a720db402dec47bfeda23
+SIZE (i2psource_0.9.40.tar.bz2) = 30808508
diff --git a/security/i2p/files/patch-apps_i2pcontrol_java_com_thetransactioncompany_jsonrpc2_package-info.java b/security/i2p/files/patch-apps_i2pcontrol_java_com_thetransactioncompany_jsonrpc2_package-info.java
new file mode 100644
index 000000000000..28e8bcbe9e2d
--- /dev/null
+++ b/security/i2p/files/patch-apps_i2pcontrol_java_com_thetransactioncompany_jsonrpc2_package-info.java
@@ -0,0 +1,11 @@
+--- apps/i2pcontrol/java/com/thetransactioncompany/jsonrpc2/package-info.java.orig 2019-04-17 11:52:29.174848000 -0400
++++ apps/i2pcontrol/java/com/thetransactioncompany/jsonrpc2/package-info.java 2019-04-17 11:55:57.085931000 -0400
+@@ -13,7 +13,7 @@
+ * exception of <i>batching / multicall</i>. This feature is deliberately left
+ * out as it tends to confuse users (judging by posts in the JSON-RPC forum).
+ *
+- * <p>See the <a href="http://www.jsonrpc.org/specification"></a>JSON-RPC 2.0
++ * <p>See the <a href="http://www.jsonrpc.org/specification">JSON-RPC 2.0
+ * specification</a> for more information or write to the
+ * <a href="https://groups.google.com/forum/#!forum/json-rpc">user group</a> if
+ * you have questions.
diff --git a/security/i2p/files/patch-apps_i2pcontrol_java_org_mindrot_jbcrypt_BCrypt.java b/security/i2p/files/patch-apps_i2pcontrol_java_org_mindrot_jbcrypt_BCrypt.java
new file mode 100644
index 000000000000..d8878d217e5f
--- /dev/null
+++ b/security/i2p/files/patch-apps_i2pcontrol_java_org_mindrot_jbcrypt_BCrypt.java
@@ -0,0 +1,35 @@
+--- apps/i2pcontrol/java/org/mindrot/jbcrypt/BCrypt.java.orig 2019-04-17 11:58:51.939865000 -0400
++++ apps/i2pcontrol/java/org/mindrot/jbcrypt/BCrypt.java 2019-04-17 11:58:57.299331000 -0400
+@@ -32,25 +32,25 @@
+ * call the hashpw method with a random salt, like this:
+ * <p>
+ * <code>
+- * String pw_hash = BCrypt.hashpw(plain_password, BCrypt.gensalt()); <br />
++ * String pw_hash = BCrypt.hashpw(plain_password, BCrypt.gensalt());
+ * </code>
+ * <p>
+ * To check whether a plaintext password matches one that has been
+ * hashed previously, use the checkpw method:
+ * <p>
+ * <code>
+- * if (BCrypt.checkpw(candidate_password, stored_hash))<br />
+- * &nbsp;&nbsp;&nbsp;&nbsp;System.out.println("It matches");<br />
+- * else<br />
+- * &nbsp;&nbsp;&nbsp;&nbsp;System.out.println("It does not match");<br />
++ * if (BCrypt.checkpw(candidate_password, stored_hash))
++ * &nbsp;&nbsp;&nbsp;&nbsp;System.out.println("It matches");
++ * else
++ * &nbsp;&nbsp;&nbsp;&nbsp;System.out.println("It does not match");
+ * </code>
+ * <p>
+ * The gensalt() method takes an optional parameter (log_rounds)
+ * that determines the computational complexity of the hashing:
+ * <p>
+ * <code>
+- * String strong_salt = BCrypt.gensalt(10)<br />
+- * String stronger_salt = BCrypt.gensalt(12)<br />
++ * String strong_salt = BCrypt.gensalt(10)
++ * String stronger_salt = BCrypt.gensalt(12)
+ * </code>
+ * <p>
+ * The amount of work increases exponentially (2**log_rounds), so
diff --git a/security/i2p/files/patch-apps_streaming_java_src_net_i2p_client_streaming_impl_I2PSocketManagerFull.java b/security/i2p/files/patch-apps_streaming_java_src_net_i2p_client_streaming_impl_I2PSocketManagerFull.java
deleted file mode 100644
index 38fa1aee08a4..000000000000
--- a/security/i2p/files/patch-apps_streaming_java_src_net_i2p_client_streaming_impl_I2PSocketManagerFull.java
+++ /dev/null
@@ -1,19 +0,0 @@
---- apps/streaming/java/src/net/i2p/client/streaming/impl/I2PSocketManagerFull.java.orig 2018-06-26 11:12:11 UTC
-+++ apps/streaming/java/src/net/i2p/client/streaming/impl/I2PSocketManagerFull.java
-@@ -28,6 +28,7 @@ import net.i2p.client.streaming.I2PServerSocket;
- import net.i2p.client.streaming.I2PSocket;
- import net.i2p.client.streaming.I2PSocketManager;
- import net.i2p.client.streaming.I2PSocketOptions;
-+import net.i2p.client.streaming.RouterRestartException;
- import net.i2p.crypto.SigAlgo;
- import net.i2p.crypto.SigType;
- import net.i2p.data.Certificate;
-@@ -354,7 +355,7 @@ public class I2PSocketManagerFull implements I2PSocket
- * @throws ConnectException (since 0.9.17; I2PServerSocket interface always declared it)
- * @throws SocketTimeoutException if a timeout was previously set with setSoTimeout and the timeout has been reached.
- */
-- public I2PSocket receiveSocket() throws I2PException, ConnectException, SocketTimeoutException {
-+ public I2PSocket receiveSocket() throws I2PException, RouterRestartException, ConnectException, SocketTimeoutException {
- verifySession();
- Connection con = _connectionManager.getConnectionHandler().accept(_connectionManager.getSoTimeout());
- I2PSocketFull sock = new I2PSocketFull(con, _context);