aboutsummaryrefslogtreecommitdiff
path: root/security/ike
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-10-21 02:51:20 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-10-21 02:51:20 +0000
commit28c8e95f4a6aa1b4d061f3bf1d8018433f41c608 (patch)
treeea9d8b8ae1ac14d429b7a87dba77e2718fd71030 /security/ike
parent6410bf15596daa3f4320fea14d5dcb1f0c1697f1 (diff)
downloadports-28c8e95f4a6aa1b4d061f3bf1d8018433f41c608.tar.gz
ports-28c8e95f4a6aa1b4d061f3bf1d8018433f41c608.zip
This port contains the Shrew Soft ike daemon and client tools. The
software supports ike v1 communications between two gateways or a a client and a gateway. For more information please visit ... WWW: http://www.shrew.net/ PR: ports/116684 Submitted by: mgrooms at shrew.net
Notes
Notes: svn path=/head/; revision=201702
Diffstat (limited to 'security/ike')
-rw-r--r--security/ike/Makefile94
-rw-r--r--security/ike/distinfo3
-rw-r--r--security/ike/pkg-descr7
-rw-r--r--security/ike/pkg-plist8
4 files changed, 112 insertions, 0 deletions
diff --git a/security/ike/Makefile b/security/ike/Makefile
new file mode 100644
index 000000000000..232f8eb1d9a5
--- /dev/null
+++ b/security/ike/Makefile
@@ -0,0 +1,94 @@
+# New ports collection makefile for: ike
+# Date created: 24 march 2007
+# Whom: mgrooms@shrew.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= ike
+PORTVERSION= 2.0.1
+CATEGORIES= security net
+MASTER_SITES= http://www.shrew.net/vpn/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-release
+EXTRACT_SUFX= .tbz2
+
+MAINTAINER= mgrooms@shrew.net
+COMMENT= Shrew Soft IKE daemon and client tools
+
+BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+
+ONLY_FOR_ARCHS= i386 amd64
+
+USE_BISON= build
+USE_OPENSSL= yes
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+OPTIONS= QTGUI "Enable QT client front end applications" on \
+ NATT "Enable NAT-Traversal (kernel-patch required)" off \
+ LDAP "Enable LDAP XAuth daemon support" off \
+ DEBUG "Enable Debug support" off
+
+MAN5= iked.conf.5
+MAN8= iked.8
+
+CMAKE_ARGS= -DCMAKE_INSTALL_PREFIX=${PREFIX}
+
+.include <bsd.port.pre.mk>
+
+.ifdef(WITH_DEBUG)
+CMAKE_ARGS+= -DDEBUG=YES
+.endif
+
+.ifdef(WITH_LDAP)
+USE_OPENLDAP= YES
+CMAKE_ARGS+= -DLDAP=YES
+.endif
+
+.ifdef(WITH_NATT)
+CMAKE_ARGS+= -DNATT=YES
+.endif
+
+.ifdef(WITH_QTGUI)
+CMAKE_ARGS+= -DQTGUI=YES
+LIB_DEPENDS+= qt-mt:${PORTSDIR}/x11-toolkits/qt33
+.endif
+
+post-patch:
+.ifdef(WITH_NATT)
+. if ${OSVERSION} < 700000
+ @${ECHO_MSG} "===> -------------------------------------------------------------------------"
+ @${ECHO_MSG} "===> ATTENTION: You need a kernel patch to enable NAT-Traversal functionality!"
+ @${ECHO_MSG} "===> You can download the patch here:"
+ @${ECHO_MSG} "===> http://ipsec-tools.sf.net/freebsd6-natt.diff"
+ @${ECHO_MSG} "===> You might possibly have to do some steps manually if it fails to apply."
+ @${ECHO_MSG} "===> -------------------------------------------------------------------------"
+. else
+ @${ECHO_MSG} "===> -------------------------------------------------------------------------"
+ @${ECHO_MSG} "===> ATTENTION: You need a kernel patch to enable NAT-Traversal functionality!"
+ @${ECHO_MSG} "===> There is no known NAT-T patch for FreeBSD 7!!!"
+ @${ECHO_MSG} "===> You might possibly have to do some steps manually if it fails to apply."
+ @${ECHO_MSG} "===> -------------------------------------------------------------------------"
+. endif
+ @sleep 3
+.endif
+
+do-configure:
+ @cd ${BUILD_WRKSRC}; cmake ${CMAKE_ARGS} .
+
+post-build:
+# QT 3.3 UIC (User Interface Compiler) creates these, so remove them.
+# Otherwise x11-toolkits/qt33 would have to be patched, as Gentoo did.
+.for f in .qt_plugins_* qt_plugins_*
+ @${RM} -f ${LOCALBASE}/etc/settings/${f}
+.endfor
+ @${RMDIR} ${LOCALBASE}/etc/settings || ${TRUE}
+
+post-install:
+ @if ! ${SYSCTL} -a | ${GREP} -q ipsec; then \
+ ${ECHO_MSG} "WARNING: IPsec feature is disabled on this host"; \
+ ${ECHO_MSG} " You must configure a kernel with this option to use this software"; \
+ fi ;
+
+.include <bsd.port.post.mk>
diff --git a/security/ike/distinfo b/security/ike/distinfo
new file mode 100644
index 000000000000..1e56013b6a22
--- /dev/null
+++ b/security/ike/distinfo
@@ -0,0 +1,3 @@
+MD5 (ike-2.0.1-release.tbz2) = d986b6c56f413bd380d7d710d7aee8f1
+SHA256 (ike-2.0.1-release.tbz2) = 2f079773c4964d27ce37add9b4a2d69aad6698c21705c7da7eca6bd60883b41d
+SIZE (ike-2.0.1-release.tbz2) = 483146
diff --git a/security/ike/pkg-descr b/security/ike/pkg-descr
new file mode 100644
index 000000000000..e4e76f077a03
--- /dev/null
+++ b/security/ike/pkg-descr
@@ -0,0 +1,7 @@
+This port contains the Shrew Soft ike daemon and client tools. The
+software supports ike v1 communications between two gateways or a
+a client and a gateway.
+
+For more information please visit ...
+
+WWW: http://www.shrew.net/
diff --git a/security/ike/pkg-plist b/security/ike/pkg-plist
new file mode 100644
index 000000000000..a65e567f7a13
--- /dev/null
+++ b/security/ike/pkg-plist
@@ -0,0 +1,8 @@
+@unexec if cmp -s %D/etc/iked.conf %D/etc/iked.conf.sample; then rm -f %D/etc/iked.conf; fi
+etc/iked.conf.sample
+@exec [ -f %D/etc/iked.conf ] || cp %D/etc/iked.conf.sample %D/etc/iked.conf
+sbin/iked
+bin/ikea
+bin/ikec
+lib/libike.so
+lib/libpfk.so