aboutsummaryrefslogtreecommitdiff
path: root/security/intel-ipsec-mb
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2020-09-13 12:52:17 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2020-09-13 12:52:17 +0000
commitbc0f49c532aa4da55517f6baea2d332955a7f86d (patch)
treefc47cc96a112f7b4f398c66d0ca047dad829d042 /security/intel-ipsec-mb
parent039934f03242b47abd1233b43055e76b53d859b3 (diff)
downloadports-bc0f49c532aa4da55517f6baea2d332955a7f86d.tar.gz
ports-bc0f49c532aa4da55517f6baea2d332955a7f86d.zip
Add intel-ipsec-mb g20200801, intel(R) Multi-Buffer Crypto for IPsec
Library. PR: 248285 Submitted by: freebsd@sysctl.cz
Notes
Notes: svn path=/head/; revision=548475
Diffstat (limited to 'security/intel-ipsec-mb')
-rw-r--r--security/intel-ipsec-mb/Makefile42
-rw-r--r--security/intel-ipsec-mb/distinfo3
-rw-r--r--security/intel-ipsec-mb/files/patch-perf_ipsec__perf.c15
-rw-r--r--security/intel-ipsec-mb/pkg-descr5
4 files changed, 65 insertions, 0 deletions
diff --git a/security/intel-ipsec-mb/Makefile b/security/intel-ipsec-mb/Makefile
new file mode 100644
index 000000000000..bce91b9b408e
--- /dev/null
+++ b/security/intel-ipsec-mb/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= intel-ipsec-mb
+DISTVERSION= g20200801
+CATEGORIES= security
+
+MAINTAINER= freebsd@sysctl.cz
+COMMENT= Intel(R) Multi-Buffer Crypto for IPsec Library
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64
+
+BUILD_DEPENDS= nasm:devel/nasm
+
+USES= gmake compiler:c11 localbase:ldflags
+
+USE_GITHUB= yes
+GH_ACCOUNT= intel
+GH_PROJECT= intel-ipsec-mb
+GH_TAGNAME= 3209c57
+
+USE_LDCONFIG= yes
+PLIST_FILES= include/intel-ipsec-mb.h \
+ lib/libIPSec_MB.so \
+ lib/libIPSec_MB.so.0 \
+ lib/libIPSec_MB.so.0.54.1 \
+ man/man7/libipsec-mb.7.gz
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/lib/intel-ipsec-mb.h ${STAGEDIR}${PREFIX}/include/
+ ${INSTALL_LIB} ${WRKSRC}/lib/libIPSec_MB.so.0.54.1-dev ${STAGEDIR}${PREFIX}/lib/libIPSec_MB.so.0.54.1
+ ${RLN} ${STAGEDIR}${PREFIX}/lib/libIPSec_MB.so.0.54.1 ${STAGEDIR}${PREFIX}/lib/libIPSec_MB.so.0
+ ${RLN} ${STAGEDIR}${PREFIX}/lib/libIPSec_MB.so.0 ${STAGEDIR}${PREFIX}/lib/libIPSec_MB.so
+ ${INSTALL_MAN} ${WRKSRC}/lib/libipsec-mb.7 ${STAGEDIR}${PREFIX}/man/man7
+
+do-test:
+ cd ${WRKSRC}/test && ./ipsec_xvalid_test -v
+ cd ${WRKSRC}/test && ./ipsec_MB_testapp -v
+
+.include <bsd.port.mk>
diff --git a/security/intel-ipsec-mb/distinfo b/security/intel-ipsec-mb/distinfo
new file mode 100644
index 000000000000..f037dee0d003
--- /dev/null
+++ b/security/intel-ipsec-mb/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1596650698
+SHA256 (intel-intel-ipsec-mb-g20200801-3209c57_GH0.tar.gz) = 31e968fb9ffa8188a706592b9db8a5af0cca37f82429494a5f37d6eb187d910d
+SIZE (intel-intel-ipsec-mb-g20200801-3209c57_GH0.tar.gz) = 962139
diff --git a/security/intel-ipsec-mb/files/patch-perf_ipsec__perf.c b/security/intel-ipsec-mb/files/patch-perf_ipsec__perf.c
new file mode 100644
index 000000000000..c3fcb6bd188c
--- /dev/null
+++ b/security/intel-ipsec-mb/files/patch-perf_ipsec__perf.c
@@ -0,0 +1,15 @@
+--- perf/ipsec_perf.c.orig 2020-07-30 14:06:18 UTC
++++ perf/ipsec_perf.c
+@@ -32,8 +32,11 @@
+ #include <inttypes.h>
+ #include <string.h>
+ #include <errno.h>
++#if defined (__linux__) || defined (__FreeBSD__)
++#include <stdlib.h>
++#else
+ #include <malloc.h> /* memalign() or _aligned_malloc()/aligned_free() */
+-
++#endif
+ #ifdef _WIN32
+ #include <windows.h>
+ #include <process.h>
diff --git a/security/intel-ipsec-mb/pkg-descr b/security/intel-ipsec-mb/pkg-descr
new file mode 100644
index 000000000000..fa4f60f0ea76
--- /dev/null
+++ b/security/intel-ipsec-mb/pkg-descr
@@ -0,0 +1,5 @@
+Intel Multi-Buffer Crypto for IPsec Library is highly-optimized software
+implementations of the core cryptographic processing for IPsec, which
+provides industry-leading performance on a range of Intel(R) Processors.
+
+WWW: https://github.com/intel/intel-ipsec-mb