aboutsummaryrefslogtreecommitdiff
path: root/security/ipguard
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2014-02-11 16:48:58 +0000
committerRenato Botelho <garga@FreeBSD.org>2014-02-11 16:48:58 +0000
commitedccd619fba5662b89e1febe96b6b37e8510a93d (patch)
treef8347e50c7d06fa524165f514595814378b26ec6 /security/ipguard
parent4f1604c79cd140192cf4b07fe942c0586dba37fc (diff)
downloadports-edccd619fba5662b89e1febe96b6b37e8510a93d.tar.gz
ports-edccd619fba5662b89e1febe96b6b37e8510a93d.zip
- Support STAGE
- Modernize LIB_DEPENDS - Add LICENSE - Respect CC Approved by: portmgr (blanket infrastructure)
Notes
Notes: svn path=/head/; revision=343768
Diffstat (limited to 'security/ipguard')
-rw-r--r--security/ipguard/Makefile15
-rw-r--r--security/ipguard/files/patch-Makefile35
2 files changed, 42 insertions, 8 deletions
diff --git a/security/ipguard/Makefile b/security/ipguard/Makefile
index a68c3f88e61e..6ea2b7bf2d73 100644
--- a/security/ipguard/Makefile
+++ b/security/ipguard/Makefile
@@ -10,18 +10,17 @@ MASTER_SITES= http://ipguard.deep.perm.ru/files/ http://deep.perm.ru/files/ipgua
MAINTAINER= sead@deep.perm.ru
COMMENT= Tool designed to protect LAN IP address space by ARP spoofing
-LIB_DEPENDS= net:${PORTSDIR}/net/libnet
+LICENSE= BSD2CLAUSE
+
+LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
USE_RC_SUBR= ${PORTNAME}
-MAN8= ${PORTNAME}.8
PORTDOCS= COPYRIGHT NEWS README README.tcpdump README.log ethers.sample rfc826.txt
-PLIST_FILES= sbin/ipguard
+PLIST_FILES= sbin/ipguard \
+ man/man8/${PORTNAME}.8.gz
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}
- @cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/security/ipguard/files/patch-Makefile b/security/ipguard/files/patch-Makefile
new file mode 100644
index 000000000000..0a52b5a5f430
--- /dev/null
+++ b/security/ipguard/files/patch-Makefile
@@ -0,0 +1,35 @@
+--- Makefile.orig 2014-02-11 16:45:41.000000000 -0200
++++ Makefile 2014-02-11 16:46:25.000000000 -0200
+@@ -10,7 +10,7 @@
+ ETHERS?=/etc/ethers
+
+ ## FreeBSD
+-LOCALBASE=/usr/local
++LOCALBASE?=/usr/local
+ LIBNET_CONFIG=libnet11-config
+
+ ## OpenBSD (tested by irix)
+@@ -26,7 +26,7 @@
+ DEFINES=`${LIBNET_CONFIG} --defines`
+
+ STATIC=
+-CC=gcc
++CC?=gcc
+
+ CFLAGS+=-g -Wall -DETHERS='"$(ETHERS)"'
+
+@@ -58,10 +58,10 @@
+ @rm -f $(NAME)
+
+ install: all
+- mkdir -p -m 755 $(PREFIX)/sbin
+- install -s -m 755 $(NAME) $(PREFIX)/sbin/$(NAME)
+- mkdir -p -m 755 $(PREFIX)/man/man8
+- install -m 644 doc/$(NAME).8 $(PREFIX)/man/man8/$(NAME).8
++ mkdir -p -m 755 ${DESTDIR}$(PREFIX)/sbin
++ install -s -m 755 $(NAME) ${DESTDIR}$(PREFIX)/sbin/$(NAME)
++ mkdir -p -m 755 ${DESTDIR}$(PREFIX)/man/man8
++ install -m 644 doc/$(NAME).8 ${DESTDIR}$(PREFIX)/man/man8/$(NAME).8
+
+ uninstall: deinstall
+