aboutsummaryrefslogtreecommitdiff
path: root/security/ipsec-tools
diff options
context:
space:
mode:
authorBrad Davis <brd@FreeBSD.org>2015-05-19 17:00:57 +0000
committerBrad Davis <brd@FreeBSD.org>2015-05-19 17:00:57 +0000
commit33b56f642c4b74633fc7a1406c8528b5c7eafdfb (patch)
treefc88601dfa667a1bd3145c1495e41498496ce45b /security/ipsec-tools
parent3495d8e943ddf3127dc233c2ef409185b1ade769 (diff)
downloadports-33b56f642c4b74633fc7a1406c8528b5c7eafdfb.tar.gz
ports-33b56f642c4b74633fc7a1406c8528b5c7eafdfb.zip
Update ipsec-tools with a patch from NetBSD to fix a memory leak.
PR: 200334 (reported in) Submitted by: brd Approved by: bdrewery (mentor, portmgr) MFH: 2015Q2
Notes
Notes: svn path=/head/; revision=386793
Diffstat (limited to 'security/ipsec-tools')
-rw-r--r--security/ipsec-tools/Makefile1
-rw-r--r--security/ipsec-tools/files/patch-src_racoon_gssapi.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index a5787d9eae9c..21604ea0bd7d 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -8,6 +8,7 @@
PORTNAME= ipsec-tools
PORTVERSION= 0.8.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
diff --git a/security/ipsec-tools/files/patch-src_racoon_gssapi.c b/security/ipsec-tools/files/patch-src_racoon_gssapi.c
new file mode 100644
index 000000000000..1310b7ecd893
--- /dev/null
+++ b/security/ipsec-tools/files/patch-src_racoon_gssapi.c
@@ -0,0 +1,14 @@
+--- src/racoon/gssapi.c.orig 2015-05-19 16:38:06 UTC
++++ src/racoon/gssapi.c
+@@ -192,6 +192,11 @@ gssapi_init(struct ph1handle *iph1)
+ gss_name_t princ, canon_princ;
+ OM_uint32 maj_stat, min_stat;
+
++ if (iph1->rmconf == NULL) {
++ plog(LLV_ERROR, LOCATION, NULL, "no remote config\n");
++ return -1;
++ }
++
+ gps = racoon_calloc(1, sizeof (struct gssapi_ph1_state));
+ if (gps == NULL) {
+ plog(LLV_ERROR, LOCATION, NULL, "racoon_calloc failed\n");