aboutsummaryrefslogtreecommitdiff
path: root/security/ipsec-tools
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-02-11 11:20:52 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-02-11 11:20:52 +0000
commit85fd614298e0faddf0d278c676cc889527128bbf (patch)
tree5cb130986ed5e8321a5c7d2dea704b4decd01c3f /security/ipsec-tools
parent7d92c0126f5f98a1aa7de44731c64cb5be8b457b (diff)
downloadports-85fd614298e0faddf0d278c676cc889527128bbf.tar.gz
ports-85fd614298e0faddf0d278c676cc889527128bbf.zip
Remove CFLAGS unsupported by ancient gcc and just remove -Werror to have the code build with clang
Reported by: olgeni
Notes
Notes: svn path=/head/; revision=343733
Diffstat (limited to 'security/ipsec-tools')
-rw-r--r--security/ipsec-tools/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index e3d94d2dafa2..40be5a02cf28 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -23,9 +23,6 @@ USE_BZIP2= yes
INSTALL_TARGET= install-strip
-CFLAGS+= -Wno-knr-promoted-parameter \
- -Wno-sizeof-pointer-memaccess \
- -Wno-incompatible-pointer-types
USES= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -161,6 +158,9 @@ CONFIGURE_ARGS+= --enable-idea
CONFIGURE_ARGS+= --disable-idea
.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s/-Werror//g" ${WRKSRC}/configure
+
post-install:
@${MKDIR} ${STAGEDIR}/${PREFIX}/etc/racoon
@if [ -z `/sbin/sysctl -a | ${GREP} -q ipsec && ${ECHO_CMD} ipsec` ]; then \